No announcement yet.

Got XM to work, then it took a dump

  • Filter
  • Time
  • Show
Clear All
new posts

  • Got XM to work, then it took a dump

    Sorry in advance for the long post, I just want to write as much detail as possible to make sure I didn't screw up something during the process.

    Here is what I am using:
    - XMD1000
    - USB to XM direct converter
    - Streetdeck for the interface

    After finding the TI driver and installing it, I went to the satellite radio settings to detect my XM, but was told that it could not find any com ports with the XM signal. So I returned to the home menu and pressed the Satellite Radio option and to my amazement the XM signal was getting through. I was only getting channel 1, but this was easily fixed by going to the xm website and refreshing my signal. Once that was done my XM was working great! This was Friday. Used my car Saturday, still working great. Did not use the car for the last half of Saturday and all of Sunday.

    So, Monday morning comes around and I try to start my car and its obvious that my battery is dead (seems the XM stayed on even though the car and computer were off for about a day and a half). No problem there, just switched the +12v lead from the converter to the remote 12v instead to make sure the XM turns off when the computer turns off. After dealing with that issue, I turn the computer back on and run Streetdeck, but this time the XM is not working. Tried to autodetect the XM through the settings and it still will not find it. Tried to uninstall the USB/com driver and reinstall it and still nothing. There is no XM signal, no station 1, no radio information, nothing. Tried to change USB ports and reinstall the driver and still get nothing. The only difference this time is that the computer now detects the usb/com port as a serial mouse. So i disabled the serial mouse, but still get no XM signal. I unplug the XM to see if maybe the XM box died. When I did that Streetdeck gave me a message that it had lost the XM signal which is most likely due to a loose connection. (HOw could it lose a signal it was not getting?) Plugging the XM back fixed the loose connection problem, but I was still getting no signal. I know what you are thinking, I just need to refresh my signal from XM. Problem with that is that at the very least the radio needs to at least be getting the signal from channel 1 along with the radio information in order for the refresh signal to work, but I am not getting this at all. And yes the USB converter is getting power.

    So my quandry is that I do not understand why the XM stopped working. The only thing that changed between the time it was working and when it was not working was the battery died. If somebody has any idea what might be going on please give me some feedback. I tried to write everything I remembered about the process of getting XM to work the first time and the process of getting XM to work again after the battery died. Thanks in advanced!

  • #3
    What was the fix??

    I have the smae issue. If I run timetrax to initialize it works until I turn off the power. What is the fix?


    • #4
      The only reason why you will get the loose connection message is if it does not recieve any feedback from the XM hardware for 10 or more seconds. This usually is the result of a loose connection. Developer (I am Chuck)
      Get StreetDeck at
      The Official StreetDeck Forums have moved, please visit us at for official support for Streetdeck.