No announcement yet.

Problems installing and updating streetdeck

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems installing and updating streetdeck

    I grabbed the latest files from and installed them.

    Then I immediatly started the online update program, it failed terribly with an error message that didn't make to much sence to me. I then noticed the thread "Download streetdeck updates" at Now, I downloaded the file and extracted the programpath files into my C:\Program Files\streetdeck directory and yet again started online updates.

    It now fins A newer version ( of Streetdeck.

    Pushing yes starts to download the update, but when it finishes, it says, "The streetDeck update archive in invalid. The update will not continue!" *not a typo*

    Now, to be honest, i'm experiencing alot of different problems with streetdeck. The interface and all in the video impressed me, and this is something I'd really wanna use. But is it worth all the hazzle to get it up and running?

    btw, I read the f.a.q, etc. etc. and tried to find information on this.

  • #2
    Lots of things are changing from one release to the next - you could just wait for the final release if you don't want to be "testing"...

    I have found that applying the updates using a USB flash drive is much simpler than using online updates. You could try that. Just copy the update to a USB flash drive and stick it in while SD is running. It will "see it" and ask if you want to update.


    • #3
      I've had downloads from fail. The setup program that should be something around 22MB arrives at about 128KB.

      You can try downloading from the link in the sticky updates thread and double-clicking the .sdu file with SD closed if updating from within SD doesn't work or the update utility keeps failing.


      • #4
        To download and install streetdeck, you should download the setup.exe, then run the online auto update utility to check for newer versions.

        Trying to run an update for a version prior to the currently installed one will cause the update to fail. You should only download the latest patch file directly if you can't use the auto update feature cause your car is not internet connected. Developer (I am Chuck)
        Get StreetDeck at
        The Official StreetDeck Forums have moved, please visit us at for official support for Streetdeck.


        • #5
          I've tried updating on 3 different computers now, with the same result on each and every one.

          1) I downloaded the current version from
          2) I ran the online updater which said there were a new version ""
          3) On complete, it says the update file is invalid
          4) I downloaded the .sdu and double klicked it, with the same result


          • #6
            Still having the same problems..

            Can't we get the latest version put on so that the ones of us that have this problem can upgrade to


            • #7
              My Fix

              The best way for me was to remove the previous version completely and install the new one (no updating) - personally, since your not losing any configuration stuff, what difference does it make?
              View my current SD Projects:


              • #8
                The thing is, that is what I did, installed the latest version from and started the online update program right away.

                It says there is a new version, but once i've downloaded it, it wont work.


                • #9
                  The same thing happens to me.
                  If the properties page is accurate, then the download version is, but the update is
                  Have you looked in the FAQ yet?
                  How about the Wiki?

                  Under normal circumstances, a signature would go here.


                  • #10
                    Originally posted by 06TC_OWNER
                    The best way for me was to remove the previous version completely and install the new one (no updating) - personally, since your not losing any configuration stuff, what difference does it make?
           is an installable app., is a patch to the major rev. of

                    A .4 setup executable isn't an option currently I think. You can install but then have to path up to The difference is whether or not there is a setup executable or *.sdu file.

                    When I ran into problems with the Media Paths tool on upgrade, I completely uninstalled SD installed and then outside of SD double-clicked the .4 *.sdu file. That worked for me.


                    • #11
                      Downloaded Dev-Edition which is

                      There is no update link to download!

             would not install manually!

                      Autoupdate doesn't work!

                      Usb flash drive .sdu file is not recognized!

                      What a mess