Announcement

Collapse
No announcement yet.

1.0.4.8 - Awesome for skinning, BAAAD for the car!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 1.0.4.8 - Awesome for skinning, BAAAD for the car!

    I put 1.0.4.8 in my home and it ran awesome. No crashes in the development environment, nothing. So I decided to put 1.0.4.8 into the car and I was in for a real bad surprise. First of all Streetdeck continuously crashed and restarted after being installed - this seemed to be particularly related to either trying to load music or run navigation. Mapquest 2006 would crash "most" of the time when Streetdeck would hang or crash.

    The cdrom isn't being found either, but I don't think this is related. I think maybe it is time to roll back to 1.0.4.7 until the next release!

    If this rollback doesn't work, then maybe I have something a little more sinister in the works here.
    View my current SD Projects:

  • #2
    Second test reveals what's really going on....

    Ok, I gave it a second chance in the car and as it turns out it must be the background mp3 loader - I can run fine with navigation and xm radio and flip between all the screens and channels and navigation views (the nav night view is pretty cool); however, the second I hit select music and "all," that's all she wrote. Crash... and the dialog for sending the report comes up. I restart it and as long as it doesn't try to continue with the music section it's fine (sometimes requires a full reboot so Streetdeck doesn't try to pick up where it left off and start loading music), but select music (anything over one or two files) and it's all over. I may try reindexing all my music, but this isn't looking good as it appears to be a persistant failure...
    View my current SD Projects:

    Comment


    • #3
      Originally posted by 06TC_OWNER
      Ok, I gave it a second chance in the car and as it turns out it must be the background mp3 loader - I can run fine with navigation and xm radio and flip between all the screens and channels and navigation views (the nav night view is pretty cool); however, the second I hit select music and "all," that's all she wrote. Crash... and the dialog for sending the report comes up. I restart it and as long as it doesn't try to continue with the music section it's fine (sometimes requires a full reboot so Streetdeck doesn't try to pick up where it left off and start loading music), but select music (anything over one or two files) and it's all over. I may try reindexing all my music, but this isn't looking good as it appears to be a persistant failure...
      Does it work if you run with -NoDelayComp?
      StreetDeck.com Developer (I am Chuck)
      Get StreetDeck at http://www.streetdeck.com
      The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

      Comment


      • #4
        Haven't tried it...be right back.
        View my current SD Projects:

        Comment


        • #5
          Ok, I checked it out, and it appears that the music will work normal (and faster in that mode), but if I switch between NAV and music, it crashes, all I have to do is either play with a few of the buttons in Nav or change a few songs in the music list - the only thing different between my home computer and that one (other then the music was imported by Streetdeck and it has Navigation) is the fact that I am running all of the plugins (google map data, gps status, and weather). Are any of these plugins no longer compatible, or does this likely have nothing to do with it. Switching between NAV and XM seems to have no effect, but yet every time it crashes with the music, it also crashes Mappoint 06??

          Oh yeah, and my home computer is 10x more powerful... PD 2.4
          View my current SD Projects:

          Comment


          • #6
            THe plugins haven't been officially released yet, they should work though, we don't actively test them before each release though. You should rename the scripts directory and try it again, although, I don't know why running music would have anything to do with it, if they were the cause.
            StreetDeck.com Developer (I am Chuck)
            Get StreetDeck at http://www.streetdeck.com
            The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

            Comment


            • #7
              Ok, not the plugins and not the re-indexing of the music. I can safely say that this USUALLY happens when I switch to the 50/50 view with the compass in the navigation module and sometimes while flipping through music after accessing the navigation module and Mappoint failing seems to be consistent at this point.
              View my current SD Projects:

              Comment


              • #8
                Mappoint always fails if streetdeck does first. So is it still true, you never crash if you don't run music. I haven't been able to duplicate anything yet, can you run with -verbose and send me a log?
                StreetDeck.com Developer (I am Chuck)
                Get StreetDeck at http://www.streetdeck.com
                The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

                Comment


                • #9
                  I will send a log after I am done reinstalling Mappoint 06 (if it still fails) I'll keep you posted. I only thought to reinstall Mappoint because once you've done everything else, that's the last thing...
                  View my current SD Projects:

                  Comment


                  • #10
                    I added a -NoBackgroundMP3 option, see if that fixes your problems.

                    http://www.mp3car.com/vbulletin/showthread.php?t=68597
                    StreetDeck.com Developer (I am Chuck)
                    Get StreetDeck at http://www.streetdeck.com
                    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

                    Comment


                    • #11
                      http://www.sciondeck.com/2006-07-03_11_31 PM.zip

                      So still crashing after reinstall of Mappoint (of course) This link above is the -verbose report.

                      Did you also know that the latest version of SD doesn't reload your play list when you reload it? It used to, but now it just loads the one song you were listening to when you closed it...
                      View my current SD Projects:

                      Comment


                      • #12
                        I stress tested the living crap out of SD using the -NoBackgroundMP3 option and I could not get it to fail! I will continue to use this option until there is a solution to this issue as it doesn't really affect me much due to the fact that I spend 90% of my time in my detail view when messing with MP3's and not in the list view. Did the error report shed any light?

                        This did not fix the reloading of the list on restart though (minor annoyance)...
                        View my current SD Projects:

                        Comment


                        • #13
                          Update: when running Streetdeck on my home computer without the -NoBackgroundMP3 option, it will eventually crash just like the car computer. It only takes a little longer (25 mins). I had the music playing and the slideshow going and eventually it crashed. I also had the music playing with the view just on the list and it eventually crashed (after a few hours). There appears to be a definite bug within the background loading of MP3s... maybe it has a problem with the invalid/missing id3 tags? I'm not sure...
                          View my current SD Projects:

                          Comment


                          • #14
                            Originally posted by god_of_cpu
                            I added a -NoBackgroundMP3 option, see if that fixes your problems.

                            http://www.mp3car.com/vbulletin/showthread.php?t=68597
                            I was having the EXACT same problem and the -NoBackgroundMP3 option seemed to fix the problem.

                            I was so excited to see that feature added, but alas, it caused Streetdeck to continually crash. :-( Any luck on debugging the problem, or is this something that's lower on the priority list to get fixed.

                            Thanks! :-D

                            Comment


                            • #15
                              Originally posted by mrclean12
                              I was having the EXACT same problem and the -NoBackgroundMP3 option seemed to fix the problem.

                              I was so excited to see that feature added, but alas, it caused Streetdeck to continually crash. :-( Any luck on debugging the problem, or is this something that's lower on the priority list to get fixed.

                              Thanks! :-D

                              Please run with 1.0.4.9 and send me the memory dump .dmp file when it crashes.

                              I haven't been able to duplicate this myself yet, but as soon as I can figure out where its coming from, I can fix it.
                              StreetDeck.com Developer (I am Chuck)
                              Get StreetDeck at http://www.streetdeck.com
                              The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

                              Comment

                              Working...
                              X