Announcement

Collapse
No announcement yet.

Invalid Argument

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Invalid Argument

    I keep on getting an invalid argument when trying to set the Navigation and also when I am trying to set my OBDII. do you know any idea what is going on. This is the first time this has happen. I just recently reimage my system and when trying to configure it. It give me this error.

  • #2
    Log Files

    INFO: ************************************************** ******************************
    INFO: StreetDeck Application Data Log
    INFO: Log started: Saturday, August 26, 12:00 PM
    INFO: Application Version: 1.0.5.4
    INFO: Command Line: -WaitForPrevInstance
    INFO: ************************************************** ******************************
    INFO:

    OnPreCreate - Initialization time 0.030 / 0.030 seconds.


    INFO:

    RenderWindow PreCreate - Initialization time 0.040 / 0.070 seconds.


    INFO:

    RenderWindow Create - Initialization time 0.010 / 0.080 seconds.


    INFO:

    Init Loading Logo - Initialization time 0.010 / 0.090 seconds.


    INFO: CUVAppData::OnCreate - Navigation controller successfully initialized!
    INFO:

    Window / Direct3D Create - Initialization time 0.010 / 0.100 seconds.


    WARNING: CAuthorize::ReadPhysicalDriveInNTWithZeroRights - DeviceIOControl IOCTL_STORAGE_GET_MEDIA_SERIAL_NUMBER error = The request is not valid for this device.
    INFO:

    LoadRegInfo - Initialization time 0.020 / 0.120 seconds.


    WARNING: UV_GetFileList - The system cannot find the file specified.00000002
    INFO:

    Init Plugins - Initialization time 0.000 / 0.120 seconds.


    INFO:

    OneTimeDOne - Initialization time 0.050 / 0.170 seconds.


    INFO:

    OneTimeSceneInit - Initialization time 0.000 / 0.170 seconds.


    INFO:

    FindBestWindowedMode - Initialization time 0.000 / 0.170 seconds.


    INFO: CDrawWnd::Initialize3DEnvironment...
    INFO: CDrawWnd::Initialize3DEnvironment - Successfully created D3D device!
    INFO:

    PreInitDeviceObjects - Initialization time 0.151 / 0.321 seconds.


    INFO: Initializing POI database...
    WARNING: CSqlStatement::NextRow - Library used incorrectly
    INFO:

    OnInitDeviceObjects Start - Initialization time 0.010 / 0.331 seconds.


    WARNING: CInfillOverlay::OnStartup - Error opening infill device hardware! (Open Failed!)
    INFO:

    Folder Init - Initialization time 0.090 / 0.421 seconds.


    INFO: CRenderEngine::InitDeviceObjects...
    INFO:

    RenderEngine Init - Initialization time 0.000 / 0.421 seconds.


    INFO: Loading Textures...
    INFO: CTextureBag::LoadTextures...
    INFO:

    Load Textures - Initialization time 0.010 / 0.431 seconds.


    INFO:

    Load Logo Texture - Initialization time 0.020 / 0.451 seconds.


    INFO: Initializing Textures...
    INFO:

    Initialize Textures - Initialization time 0.000 / 0.451 seconds.


    INFO: Initializing Speech Controller...
    INFO:

    Init Speech - Initialization time 0.000 / 0.451 seconds.


    INFO: Initializing Media Event Processor...
    INFO:

    Init Media Event Processor - Initialization time 0.000 / 0.451 seconds.


    INFO: Initializing Volume Control Textures...
    INFO:

    Init POI DB - Initialization time 0.000 / 0.451 seconds.


    INFO:

    Init Media Managers - Initialization time 0.000 / 0.451 seconds.


    INFO:

    Enumerate Apps - Initialization time 0.000 / 0.451 seconds.


    INFO: CAppData::LoadSkin - Loading skin Default...
    INFO: CAppData::LoadSkin - Loading skin C:\Documents and Settings\Administrator\My Documents\StreetDeck\UI\Skins\Default\Skin.skn...
    INFO: CAppData::LoadSkin - Finished loading skin...
    INFO:

    Load Skin - Initialization time 0.090 / 0.541 seconds.


    INFO: CAppData::OnInitDeviceObjects - Skin successfully loaded!
    INFO:

    CDVDManager - Initialization time 0.000 / 0.541 seconds.


    INFO:

    CXMRadioManager - Initialization time 0.010 / 0.551 seconds.


    INFO:

    CRadioManager - Initialization time 0.010 / 0.561 seconds.


    INFO:

    CTVManager - Initialization time 0.000 / 0.561 seconds.


    INFO:

    CVideoFileManager - Initialization time 0.000 / 0.561 seconds.


    INFO:

    CAudioFileManager - Initialization time 0.000 / 0.561 seconds.


    INFO:

    Media Manager Ontime Scene Init - Initialization time 0.000 / 0.561 seconds.


    INFO: CFontBag::InitDeviceObjects...
    INFO:

    Init FontBag - Initialization time 0.030 / 0.591 seconds.


    INFO:

    Overlays - Initialization time 0.000 / 0.591 seconds.


    INFO:

    User Overlays - Initialization time 0.000 / 0.591 seconds.


    INFO:

    User Modules - Initialization time 0.010 / 0.601 seconds.


    INFO:

    Volume Modules - Initialization time 0.010 / 0.611 seconds.


    INFO:

    Voice Modules - Initialization time 0.000 / 0.611 seconds.


    INFO:

    Relay Modules - Initialization time 0.020 / 0.631 seconds.


    INFO:

    Media Change Modules - Initialization time 0.010 / 0.641 seconds.


    INFO:

    MsgBox Modules - Initialization time 0.000 / 0.641 seconds.


    INFO:

    External Apps Modules - Initialization time 0.000 / 0.641 seconds.


    INFO: CScriptedModule::LoadSkin - Loading skin C:\Documents and Settings\Administrator\My Documents\StreetDeck\Scripts\{1FB0936A-FD23-4A41-86E3-61C3F3977B0F}\main.sds...
    INFO: CScriptedModule::LoadSkin - Finished loading skin...
    INFO:

    Scripting Modules - Initialization time 0.050 / 0.691 seconds.


    INFO:

    Tray Overlays - Initialization time 0.010 / 0.701 seconds.


    INFO:

    EQ Modules - Initialization time 0.000 / 0.701 seconds.


    INFO:

    MultiMon Modules - Initialization time 0.040 / 0.741 seconds.


    WARNING: CPluginBag::GetPlugin - LoadLibrary - The specified module could not be found.0000007e
    WARNING: CPluginBag::GetPlugin - Could not load plugin (C:\Documents and Settings\Administrator\My Documents\StreetDeck\Plugins\Input\InputG35SWC.dll )!
    WARNING: CPluginBag::GetPlugin - LoadLibrary - The specified module could not be found.0000007e
    WARNING: CPluginBag::GetPlugin - Could not load plugin (C:\Documents and Settings\Administrator\My Documents\StreetDeck\Plugins\Input\InputPhidgetsEn coder.dll)!
    WARNING: .\SpeechController.cpp:191 HRCALL Failed!
    0x80040154 = m_pVoice.CoCreateInstance(CLSID_SpVoice)

    INFO:

    Package Modules - Initialization time 0.150 / 0.891 seconds.


    INFO:

    Load Modules - Initialization time 0.000 / 0.891 seconds.


    INFO: CAppData::LoadXMLSettings - Loading XML Settings from C:\Documents and Settings\Administrator\My Documents\StreetDeck\config.xml...
    INFO: CGirderModule::OnLoadXMLConfig - No plugins were loaded from the girder plugin path!
    WARNING: CRelayModule::OnLoadXMLConfig - No plugins were loaded from the Relay plugin path!
    INFO:

    Load Settings - Initialization time 0.030 / 0.921 seconds.


    WARNING: CAppData::SortOverlays - Could not find overlay (CPanelChooserOverlay) to set Z-Order!
    INFO:

    Init Skin - Initialization time 0.000 / 0.921 seconds.


    INFO:

    Overlay Scene Init - Initialization time 0.000 / 0.921 seconds.


    INFO:

    Module Scene Init - Initialization time 0.000 / 0.921 seconds.


    INFO: CDrawWnd::RestoreDeviceObjects...
    WARNING: .\D3DBitmapFont.cpp:1632 HRCALL Failed!
    0x8876086c = g_pd3ddev->CreateVertexShader(&VertexFVF[i], &g_pVertexFVF[i])

    WARNING: .\D3DBitmapFont.cpp:1632 HRCALL Failed!
    0x8876086c = g_pd3ddev->CreateVertexShader(&VertexFVF[i], &g_pVertexFVF[i])

    WARNING: .\D3DBitmapFont.cpp:1632 HRCALL Failed!
    0x8876086c = g_pd3ddev->CreateVertexShader(&VertexFVF[i], &g_pVertexFVF[i])

    WARNING: .\D3DBitmapFont.cpp:1632 HRCALL Failed!
    0x8876086c = g_pd3ddev->CreateVertexShader(&VertexFVF[i], &g_pVertexFVF[i])

    INFO: CDrawWnd::OnSettingsChange...
    WARNING: .\VoiceInputModule.cpp:348 HRCALL Failed!
    0x80040154 = m_cpEngine.CoCreateInstance(CLSID_SpSharedRecogniz er)

    INFO: CNAVGPSController::Connect - Simulating GPS Data
    WARNING: CNAVGPSController::COMM_Thread - The GPS simulation data file (C:\Program Files\StreetDeck\GPSSim.txt) was not found. GPS data will NOT be simulated!
    INFO: Performing CDVDManager startup...
    INFO: Performing CXMRadioManager startup...
    INFO: Performing CRadioManager startup...
    INFO: Performing CTVManager startup...
    INFO: Performing CVideoFileManager startup...
    INFO: Performing CAudioFileManager startup...
    WARNING: CNetSyncSettingsModule::OnStartup - Could not open sync settings file (C:\Documents and Settings\Administrator\My Documents\StreetDeck\NetSync.dat) to get encrypted password!
    INFO: CDrawWnd::Create - Initialization completed!
    INFO: CDrawWnd::Create - Program initialization completed in 0 seconds.
    INFO: Loading Sounds...
    INFO: CSoundController::InitDeviceObjects...
    INFO: CSoundController::LoadSounds...
    WARNING: .\SpeechController.cpp:191 HRCALL Failed!
    0x80040154 = m_pVoice.CoCreateInstance(CLSID_SpVoice)

    WARNING: .\SpeechController.cpp:169 HRCALL Failed!
    0x80040154 = SpGetTokenFromId(CSpDynamicString(lpszVoiceId), &pVoiceToken)

    WARNING: CSpeechController::SetVoiceId - Could not get the voice token from the current id !
    INFO: MessageBox:
    Save Settings?
    One or more settings have changed. Would you like to save these changes before exiting the module?
    WARNING: .\SpeechController.cpp:191 HRCALL Failed!
    0x80040154 = m_pVoice.CoCreateInstance(CLSID_SpVoice)

    WARNING: .\SpeechController.cpp:169 HRCALL Failed!
    0x80040154 = SpGetTokenFromId(CSpDynamicString(lpszVoiceId), &pVoiceToken)

    WARNING: CSpeechController::SetVoiceId - Could not get the voice token from the current id !
    INFO: MessageBox:
    Initializing...
    Please wait while navigation initializes.
    INFO: CProcessShutdownModule::Exit - The initial shutdown sequence has completed processing. (Shutdown Option = 4)
    INFO: CAppData::QueryShutdown - Shutdown Allowed!
    INFO: Peforming NAV Shutdown...
    INFO: Peforming XM Shutdown...
    INFO: CAppData::SaveXMLSettings - Saving XML Settings...
    INFO: CAppData::SaveSettings - Saving Binary Settings...
    INFO: CAppData::PerformShutdown - Shutdown complete!
    INFO: CDrawWnd::Cleanup3Denvironment...
    INFO: CDrawWnd::InvalidateDeviceObjects...
    INFO: CDrawWnd:eleteDeviceObjects...
    INFO: CNAVController::~CNAVController - Navigation components unloaded.
    WARNING: CDrawWnd::Cleanup3DEnvironment - RefCount=1 on release!
    INFO: CDrawWnd::Cleanup3Denvironment - Cleanup complete

    Comment


    • #3
      1) What do you mean by "set the navigation"? Set the COM port that the GPS uses? Set the home location? Set a destination?
      2) If you were trying to set the COM port for the GPS, did you run Streetdeck with the -allcomm command line switch?
      3) Did you run StreetDeck with the -verbose command line switch to generate this log?
      Have you looked in the FAQ yet?
      How about the Wiki?



      Under normal circumstances, a signature would go here.

      Comment


      • #4
        Originally posted by DarquePervert View Post
        1) What do you mean by "set the navigation"? Set the COM port that the GPS uses? Set the home location? Set a destination?
        2) If you were trying to set the COM port for the GPS, did you run Streetdeck with the -allcomm command line switch?
        3) Did you run StreetDeck with the -verbose command line switch to generate this log?
        This is the crash log.

        I mean when I try to set the up the com port for the gps. It get set then when I hit save an error pops up saying Invalid argument. It will not let me save.

        Comment


        • #5
          OK. So you answered #1.....
          What about the other two questions?
          Have you looked in the FAQ yet?
          How about the Wiki?



          Under normal circumstances, a signature would go here.

          Comment


          • #6
            i formated it. Tiny xp rev 5 had given me so much problem now its works fine.

            Comment


            • #7
              I am having this same problem. It worked correctly the first time I had it setup. I removed the GPS reciever from the USB port and put it into another port. Reopened SD and try to change the setting to the new port and get "An Invalid Argument was encountered".

              I have rebooted and tried changing it back to the same port it was in. Still.... nothing.
              2003 E46 BMW
              Lilliput Transflective, GM965 mobo w/ Processor
              ELMSCAN 5 USB, Slot load DVD, BU-353 GPS
              Everything is for sale.

              Comment


              • #8
                Just tried a repair on SD

                I uninstalled SD... UNinstalled the driver for the GPS rebooted and reinstalled everything.....and still same error.

                Attached Log file

                (This is not very impressive for my initial setup)
                Attached Files
                2003 E46 BMW
                Lilliput Transflective, GM965 mobo w/ Processor
                ELMSCAN 5 USB, Slot load DVD, BU-353 GPS
                Everything is for sale.

                Comment


                • #9
                  Originally posted by polo6979 View Post
                  Just tried a repair on SD

                  I uninstalled SD... UNinstalled the driver for the GPS rebooted and reinstalled everything.....and still same error.

                  Attached Log file

                  (This is not very impressive for my initial setup)
                  If you are using Tiny XP rev 5 a service was remove to give it that error. Best bet is just use normal windows and disable those service. I was just testing out Tiny XP and found out its not friendly with certain programs. Also if u try to install it onto a system with PCMIA it does not install those driver either and its a pain to go search for it.

                  Comment


                  • #10
                    I used Nlite to create the XP install.

                    Do we know what service this could be? I cant reformat again... I would have to move 60 gigs of music AGAIN!
                    2003 E46 BMW
                    Lilliput Transflective, GM965 mobo w/ Processor
                    ELMSCAN 5 USB, Slot load DVD, BU-353 GPS
                    Everything is for sale.

                    Comment


                    • #11
                      Originally posted by polo6979 View Post
                      I used Nlite to create the XP install.

                      Do we know what service this could be? I cant reformat again... I would have to move 60 gigs of music AGAIN!
                      U should make 2 partitions. NO music to move then. I really dont know what services was disable for it to do this. Could be many things. All I say is keep the basic stuff that is needed.


                      To get the maximum amount of performance out of your system, you have the option of disabling all of the services on your computer that are not critical to the system. This would take away a lot of the nice features and conveniences of Windows, but you would have a much faster machine. The following is a list of system-critical services that should not be disabled. Feel free to disable all other services.

                      Bare Minimum Services:

                      Com+ Event System
                      Cryptographic Services
                      DCOM Server Process Launcher
                      DHCP Client
                      DNS Client
                      Event Log
                      IPSEC Services
                      Workstation
                      Shell Hardware Detection
                      System Event Notification
                      Protected Storage
                      Network Connections
                      Plug + Play
                      Print Spooler
                      Remote Procedure Call
                      Secondary Logon
                      Security Accounts Manager


                      Disable the following services:

                      Background Intelligent Transfer Service
                      Distributed Link Tracking Client
                      Error Reporting Service
                      Fast User Switching Compatibility
                      Help and Support
                      Indexing Service
                      Messenger
                      Machine Debug Manager
                      Network Location Awareness (NLA)
                      Portable Media Serial Number Service
                      Remote Registry (Only included with Windows XP Pro)
                      SSDP Discovery Service
                      Terminal Services
                      Windows Image Acquisition (WIA)
                      Wireless Zero Configuration (If you have a wireless network card, do not disable this one)
                      Windows Time
                      WebClient
                      Task Scheduler Continued...

                      Try not to disable shell.

                      Comment


                      • #12
                        Do you really need the print spooler service running? and also event log? Thought you could stop both of those

                        Comment


                        • #13
                          Originally posted by geeky_hawkes View Post
                          Do you really need the print spooler service running? and also event log? Thought you could stop both of those
                          Yout dont need those services at all. Event log its up to u. Let u know what crash your system. But if you dont care. Disable.

                          Comment


                          • #14
                            Would this really be a service running if it worked at one time and then stopped?
                            2003 E46 BMW
                            Lilliput Transflective, GM965 mobo w/ Processor
                            ELMSCAN 5 USB, Slot load DVD, BU-353 GPS
                            Everything is for sale.

                            Comment


                            • #15
                              Originally posted by polo6979 View Post
                              Would this really be a service running if it worked at one time and then stopped?
                              Most likely it is a services that is not running that is giving the problem.

                              Comment

                              Working...
                              X