Announcement

Collapse
No announcement yet.

SD+MP2K6=No Wokrie. HELP! :)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SD+MP2K6=No Wokrie. HELP! :)

    Hello.

    I'm trying out the latest version of SD (Demo).

    First I found the NAv was working (module no initialized, check log blah blah).

    I then learned i needed Mappoint installed.

    I had Street & Trips 2005 installed.

    I uninstalled it, and then installed MapPoint 2006 (MSDN).

    So now thte Navigation Options work, and I can pick my GPS port and such.

    Now SD asks if the Navigation Data is Installed when I click Navigation.

    I checked that the COM plugin is registered in Mappoint, and it is, and it's checkmarked.

    I reregistered the COM object as per some other thread had suggested, but it made no difference.

    That person solved it by reinstalling SD and Mappoint on another system to "fix" it. That's not much help to me.

    Any ideas?
    Cheers!

    techie007

  • #2
    You can try mappoint.exe /register
    StreetDeck.com Developer (I am Chuck)
    Get StreetDeck at http://www.streetdeck.com
    The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

    Comment


    • #3
      Originally posted by god_of_cpu View Post
      You can try mappoint.exe /register
      Thanks for the quick reply, but nope -- same deal.

      Does an uninstall of Streetdeck deregister/remove that COM object?

      I'm thinking I'll need to do a thorough uninstall and registery cleaning of all things StreetDeck, S&T, and Mappoint, and then reinstall. I just want to make sure I deregister and get rid of any COM objects that may hang around.

      Anyone know of any MS uninstallers for Streets and Trips?
      Cheers!

      techie007

      Comment


      • #4
        Originally posted by techie007 View Post
        Thanks for the quick reply, but nope -- same deal.

        Does an uninstall of Streetdeck deregister/remove that COM object?

        I'm thinking I'll need to do a thorough uninstall and registery cleaning of all things StreetDeck, S&T, and Mappoint, and then reinstall. I just want to make sure I deregister and get rid of any COM objects that may hang around.

        Anyone know of any MS uninstallers for Streets and Trips?
        beware if you uninstall it might cause a premature timeout of the demo...

        Comment


        • #5
          Well that's not good news!

          I've already reinstalled SD once, and it maintained most of my settings, and so far hasn't given me any troubles regarding the time-out.

          What are the chances it "might" do this, and is there a fix if it does?

          I'd rather not do all this registry cleaning, reisntalling and such, so are there any other ideas on how to fix it?

          I'm hoping to fix this with a knife and not a sledge hammer.

          Has only one other person (who bothers to come to forums) run into this?
          Cheers!

          techie007

          Comment


          • #6
            Originally posted by techie007 View Post
            Well that's not good news!

            I've already reinstalled SD once, and it maintained most of my settings, and so far hasn't given me any troubles regarding the time-out.

            What are the chances it "might" do this, and is there a fix if it does?

            I'd rather not do all this registry cleaning, reisntalling and such, so are there any other ideas on how to fix it?

            I'm hoping to fix this with a knife and not a sledge hammer.

            Has only one other person (who bothers to come to forums) run into this?

            It seems to happen if you remove the "StreetDeck" folder from your mydocuments, or in my case, I had foldershare syncing mydocs between the 2 systems, and so it caused my test pc to go nuts and expire.. the main still works fine..

            Comment

            Working...
            X