Announcement

Collapse
No announcement yet.

Nav buttons don't respond to keypresses...only mouse clicks

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nav buttons don't respond to keypresses...only mouse clicks

    What version of StreetDeck is this bug report for?

    1.0.6.3


    Please give a basic description of the issue here.

    Nav buttons don't respond to keypresses...only mouse clicks


    Is the systemt that is listed in your CarPC specs under your user name the same system where you encountered this bug?

    yes


    If no, please describe your system here.




    Please provide any relevent information regarding the issue you have encountered.

    Since updating to 1.0.6.3, When I use the nav module, the small, square buttons on the left of the main navigation screen (the "Create new route", "Change perspective", "Virtual Earth", or "GPS info" buttons) no longer respond to keystroke activation. I can highlight them and move the highlight between them by using the keyboard or the mouse, but if I press "enter" to activate the highlighted button, nothing happens. Even stranger, if the highlight is not on the middle button when I press enter, a button above or below the middle, the highlight moves itself back to the middle button.

    However, the buttons behave properly when clicked with the mouse.

    This problem only occurs in the main nav module screen. If I create new buttons to perform the same function as the disabled buttons in the main nav module screen, the new buttons exhibit the same behavior. However, if I make a new button that performs the same function in another module (i.e. I make a new button in the main screen module to call the "Create new route" module), that new button functions correctly.

    This behavior occurs when using the default skin or my custom skin, and with the -testmode switch on and off. It occured immediately after the 1.0.5 ---> 1.0.6.3 upgrade. I've made sure the "allow keyboard/mouse focus" property is set to "true" from within the development environment, but it has had no effect. I'm wondering if this is a intentional "feature", but I can't find any reference to it anywhere or imagine why mouse selection would be allowed but keyboard disallowed.

    Help!

    An amateur built the Ark. The Titanic was built by professionals.

  • #2
    Should we expect a response to bug reports in these forums?

    An amateur built the Ark. The Titanic was built by professionals.

    Comment


    • #3
      eventually they do respond, once you post here.. they start testing it.... and they wont respond until they need further input from you and/or they have fixed the bug

      which might not be until the next release
      Pentium 4m 1.5GHz|MB896|Roadie Extreme|XM-Direct|Rikaline 6010|T-View 7"|Streetdeck|160gb Western Digital|1Gb DDR2-533 Ram

      Comment


      • #4
        Originally posted by strohj View Post
        eventually they do respond, once you post here.. they start testing it.... and they wont respond until they need further input from you and/or they have fixed the bug

        which might not be until the next release
        Ah...I see. Thanks.

        Acknowledgement would be nice though...

        An amateur built the Ark. The Titanic was built by professionals.

        Comment


        • #5
          indeed
          Pentium 4m 1.5GHz|MB896|Roadie Extreme|XM-Direct|Rikaline 6010|T-View 7"|Streetdeck|160gb Western Digital|1Gb DDR2-533 Ram

          Comment


          • #6
            This is an issue with the default skin not allowing focus for those items.. It will be fixed in 1.0.7.6.

            Originally posted by parksgm View Post
            Should we expect a response to bug reports in these forums?
            As strojh said, we don't respond until we have more of an answer then ok. This forum is monitored daily and just by posting here, you can assume its been read.
            StreetDeck.com Developer (I am Chuck)
            Get StreetDeck at http://www.streetdeck.com
            The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

            Comment


            • #7
              Originally posted by god_of_cpu View Post
              This is an issue with the default skin not allowing focus for those items.. It will be fixed in 1.0.7.6.
              Great!

              As strojh said, we don't respond until we have more of an answer then ok. This forum is monitored daily and just by posting here, you can assume its been read.
              Good to hear. Thanks!

              An amateur built the Ark. The Titanic was built by professionals.

              Comment


              • #8
                From your previous post elsewhere, am I correct in assuming this issue has been resolved with the 8.1 release?
                Jan Bennett
                FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

                Please post on the forums! Chances are, someone else has or will have the same questions as you!

                Comment


                • #9
                  Originally posted by RedGTiVR6 View Post
                  From your previous post elsewhere, am I correct in assuming this issue has been resolved with the 8.1 release?
                  Yep. Nav onscreen buttons respond to keypresses properly now. I've even skinned some additional buttons, and those work as intended as well (which wasn't possible for me with 1.0.6.3).

                  An amateur built the Ark. The Titanic was built by professionals.

                  Comment


                  • #10
                    Issue closed then!
                    Jan Bennett
                    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

                    Please post on the forums! Chances are, someone else has or will have the same questions as you!

                    Comment

                    Working...
                    X