Announcement

Collapse
No announcement yet.

Streetdeck pauses for long periods of time on startup

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Streetdeck pauses for long periods of time on startup

    What version of StreetDeck is this bug report for?

    1.0.8.1


    Please give a basic description of the issue here.

    Streetdeck pauses for long periods of time on startup


    Is the systemt that is listed in your CarPC specs under your user name the same system where you encountered this bug?

    yes


    If no, please describe your system here.




    Please provide any relevent information regarding the issue you have encountered.

    This only happens every four or five times I resume from hibernation. Streetdeck will just show up as a black screen when Windows resumes, and will stay like that for about 45 to 60 seconds. I think I may have figured out the problem though, and I'm sure it wouldn't be to hard to fix with a quick update. I noticed that every time this happens, the songs in the queue get multiplied a few times. After restarting one or two more times, the growth is exponential and causes the system to hang for long periods. I'm not really sure what could be causing this in SD, but it could have something to do with the randomization algorithem, since it namely happens with random turned on. I'll get a report in next time it happens.
    Build Two:
    Planning: [==========]100%
    Purchasing: [=====---------]50% (Car just got broken into)
    Design: [=======-----]70% (Building a false panel to cover up my goodies)
    Install: [======--------]600% (Need to replace screen and beisel)

  • #2
    I am reporting that I also encounter this issue.

    This is also for 1.0.8.1 and my system is listed in my profile.

    I found that every time I resume from sleep, the queue is multiplied. If I have nine songs when I go into sleep there will be 18 when I resume, all double of the original 9. The next time it will be 36 and exponentially larger. When that queue contains several thousand of the same 9 songs, the startup is very slow.

    I do not have repeat or random play turned on.
    ____________________________
    My Worklog

    Monthly North Texas Meet Thread

    My Website

    Comment


    • #3
      Queued music gets re-added after resume from hibernation

      What version of StreetDeck is this bug report for?

      1.081


      Please give a basic description of the issue here.

      Queued music gets re-added after resume from hibernation


      Is the systemt that is listed in your CarPC specs under your user name the same system where you encountered this bug?

      yes


      If no, please describe your system here.




      Please provide any relevent information regarding the issue you have encountered.

      It isn't EVERY time, but it is pretty frequent. Let's say I have 11 songs in my queue. If I hibernate, then resume, it has 22 songs (the same 11 put in the queue again). It seems to be when I leave the song playing during hibernation. The last time I paused playback prior to hibernation it did NOT do it.

      Comment


      • #4
        Originally posted by pickupthepace View Post
        What version of StreetDeck is this bug report for?

        1.081


        Please give a basic description of the issue here.

        Queued music gets re-added after resume from hibernation


        Is the systemt that is listed in your CarPC specs under your user name the same system where you encountered this bug?

        yes


        If no, please describe your system here.




        Please provide any relevent information regarding the issue you have encountered.

        It isn't EVERY time, but it is pretty frequent. Let's say I have 11 songs in my queue. If I hibernate, then resume, it has 22 songs (the same 11 put in the queue again). It seems to be when I leave the song playing during hibernation. The last time I paused playback prior to hibernation it did NOT do it.
        I am also having the same issue. queue music list readd after hibernation too. making it double, tripple etc

        Comment


        • #5
          third.

          Comment


          • #6
            a different twist on this: I see SD taking a long time (10-20 seconds) at various times when I hit the music button on the main screen, click the album art in the queue view, click artists from the music selection screen, and other music related things.

            I've only recognized it in the music modules, but perhaps it occurs elsewhere also. I do not see CPU spike with it, and once it happens, if I then repeat the same functions/actions, it goes quickly as usual. I use the -nodelaycomp and -nodelayload switches every time I run SD.

            I have not noticed whether this is related to a large queue or not.

            Comment


            • #7
              me also

              Comment


              • #8
                Should be fixed in the next patch.
                StreetDeck.com Developer (I am Chuck)
                Get StreetDeck at http://www.streetdeck.com
                The Official StreetDeck Forums have moved, please visit us at http://www.streetdeck.com/forum for official support for Streetdeck.

                Comment


                • #9
                  Originally posted by god_of_cpu View Post
                  Should be fixed in the next patch.
                  Thanks Chuck.

                  Ryan

                  Comment


                  • #10
                    Originally posted by god_of_cpu View Post
                    Should be fixed in the next patch.
                    Great!

                    I believe that this is the same issue that was posted to and I added to here: http://www.mp3car.com/vbulletin/stre...e-startup.html

                    Thanks Chuck.
                    ____________________________
                    My Worklog

                    Monthly North Texas Meet Thread

                    My Website

                    Comment


                    • #11
                      I get the same type of delays resuming from sleep while in the XM module. Nothing in my music queue. Doesn't happen every time, but maybe 1 out of 5 times.

                      Comment


                      • #12
                        Happened again. A 13 song playlist got multiplied to a 40600 song playlist. Not fun.
                        Build Two:
                        Planning: [==========]100%
                        Purchasing: [=====---------]50% (Car just got broken into)
                        Design: [=======-----]70% (Building a false panel to cover up my goodies)
                        Install: [======--------]600% (Need to replace screen and beisel)

                        Comment


                        • #13
                          Any mod have any idea what is causing this?
                          Build Two:
                          Planning: [==========]100%
                          Purchasing: [=====---------]50% (Car just got broken into)
                          Design: [=======-----]70% (Building a false panel to cover up my goodies)
                          Install: [======--------]600% (Need to replace screen and beisel)

                          Comment


                          • #14
                            please retest on 1.0.9.8 and report back with your findings.
                            Jan Bennett
                            FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

                            Please post on the forums! Chances are, someone else has or will have the same questions as you!

                            Comment


                            • #15
                              please retest on 1.0.9.8 and report back with your findings.

                              BTW - EvilLawn - the Moderators on this forum do not work for MP3Car.com, they are volunteers. They are not responsible for QA or development of StreetDeck nor are they responsible for answering Bug Reports.
                              Jan Bennett
                              FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

                              Please post on the forums! Chances are, someone else has or will have the same questions as you!

                              Comment

                              Working...
                              X