Announcement

Collapse
No announcement yet.

resuming from hibernation in test mode, the Testmode confirmation dialog - 1.0.9.8

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • resuming from hibernation in test mode, the Testmode confirmation dialog - 1.0.9.8

    What version of StreetDeck is this bug report for?

    1.0.9.8


    Please give a basic description of the issue here.

    When resuming from hibernation in test mode, the Testmode confirmation dialog box appears and must be dismissed two (or sometimes three) times before SD is usable.


    Is the system that is listed in your CarPC specs under your user name the same system where you encountered this bug?

    Yes.
    If no, please describe your system here.

    Are you able to reproduce this bug at will?

    Yes. By resuming from hibernation.
    Please list the steps required to recreate the issue you are reporting.
    Resume from hibernation.

    Please provide any relevent information regarding the issue you have encountered.

    I have multiple usb input devices installed...could that be an issue?
    • USB mouse
    • USB joystick
    • Griffin Powermate
    • Lilliput 629 touchscreen...drivers supplied by manafacturer

    An amateur built the Ark. The Titanic was built by professionals.

  • #2
    I fixed the title. I'll let Chuck or Adam comment on the bug.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

    Comment


    • #3
      Chuck/Adam - updates?
      Jan Bennett
      FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

      Please post on the forums! Chances are, someone else has or will have the same questions as you!

      Comment


      • #4
        just fyi - i use testmode 100% of the time and have not run into this myself. I use a touchscreen, rotary encoder (ccStick) and RF keyboard (amongst other USB devices)

        Comment


        • #5
          resume from hibernation in test mode

          I certainly have this problem as well. My previous version (1.0.6.3) did not.
          Originally posted by S4Per View Post
          just fyi - i use testmode 100% of the time and have not run into this myself. I use a touchscreen, rotary encoder (ccStick) and RF keyboard (amongst other USB devices)

          Comment


          • #6
            Same here after the 1.0.9.8 update.

            Comment


            • #7
              I have the same problem after update as well, its quite annoying! I thought it was only supposed to come up when you started the program the first time, not on a hibernate resume. And having to hit it 2-3 times sucks too!
              - Mike

              Comment


              • #8
                it will always come up, on resume also, not just start. hitting it 2-3 times though is certainly not by design.

                Comment


                • #9
                  Originally posted by S4Per View Post
                  it will always come up, on resume also, not just start. hitting it 2-3 times though is certainly not by design.
                  ...and it will frequently stop the current track after the second press. The track playing before hibernation begins playing correctly, but then stops. That's annoying as well.

                  An amateur built the Ark. The Titanic was built by professionals.

                  Comment


                  • #10
                    I too have this problem.

                    Comment


                    • #11
                      This is streetdeck operating as designed. When coming out of hibernation the focus is taken from SD. The first push is to select the window. The second is to select the option.

                      Comment


                      • #12
                        Originally posted by StreetDeckAce View Post
                        This is streetdeck operating as designed. When coming out of hibernation the focus is taken from SD. The first push is to select the window. The second is to select the option.
                        Is there a way to make it where the window is automatically selected when resuming from hibernation so that we only have to click it once? It's quite annoying. I don't even really understand why there has to be a warning at all when resuming from hibernation because when the program first starts you see the dialog and have to acknowledge it. That itself should be enough to take liability away from the SD developers. Not to mention that to run it in testmode you have to add the testmode parameter to the shortcut, so obviously the user had to know he was doing that. I don't see how it popping up after every hibernate helps take anymore safety liability away from the developers.
                        - Mike

                        Comment


                        • #13
                          Originally posted by StreetDeckAce View Post
                          This is streetdeck operating as designed. When coming out of hibernation the focus is taken from SD. The first push is to select the window. The second is to select the option.
                          That's not what happens on my system...it seems there are actually two seperate confirmation dialogs. When I dismiss the first, the screen displays the SD logo very briefly, fades to black, and then fades back into a screen with another confirmation dialog on it. When that confirmation dialog is accepted, the screen again displays the SD logo before fading to black and then back to the main SD screen.

                          Is that expected behavior?

                          An amateur built the Ark. The Titanic was built by professionals.

                          Comment


                          • #14
                            Likewise i get this warning several times after a resume. Ive taken to closing SD and letting the laptop hibernate itself. That way when i restart and select SD i only have to cancel the warning once!

                            Comment


                            • #15
                              I think I am going to try to find some mouse simulator software that can simulate clicking the dialog twice after resume to fix this problem for me. Ill let you guys know if i figure anything out
                              - Mike

                              Comment

                              Working...
                              X