No announcement yet.

LinuxICE install to USB hit wall at partitioning

  • Filter
  • Time
  • Show
Clear All
new posts

  • LinuxICE install to USB hit wall at partitioning

    Hi all,

    Newbie here so please bear with me. I am trying to install LinuxICE to USB from CD but I can't get past the partitioning. I get messages about unable to create file system or something (lost my notes during a reboot). I'm using a 4gb stick on Via EN12000EG. The stick seems fine as I have been able to partition it with other tools and almost got Gentoo working (partitioned fine during install but I'm having other issues on that distro).

    I'm going to try it again and will post in this thread about actual messages and sequence of events. I see there are other threads about LinuxICE and other forums and will dig through those, but thought I'd throw up a post in the meantime in case someone can quickly provide some tips/tricks on how to get past this. I have experience in linux/unix environments but not at the sysadmin level.

    Sometimes it feels like I'm in a loop when going through the process. It seems a bit odd. More info to follow. Thanks.

    -- Darin

  • #2
    OK, more details...

    Booted from CD, loads up fine and can browse around. Went into system tools and install. Selected "use entire disk" option when it got to partioning step. Radio button for SCSI3 (0,0,0)(sda) - 4.1 GB USB 2.0 Flash Disk selected. Hit forward and then it says preparing disk space for a sec, progress bar goes across, then it flashes back to last screen before going to migrate docs/settings. I have not users or OS to import so I hit "forward" again. Fill in my info and then hit next again.

    READY TO INSTALL info: "partition tables of the following devices are changed (scsi3 0,0,0 sda), the following partitions are going to be formatted: #1 as ext3, #5 as swap

    Starting up the partitioner, installing system, detecting file systems... always hangs here at 15% and detecting FS. After a long wait, quickly changes to 5% progress and "installing system - creating ext3 file system for / in partition #1 of SCSI3 (0,0,0)(sda)" but also get error dialog "Failed to create a file system - The ext3 file system creation in partition #1 of .... failed."

    I hit OK and it goes back to step 4 and the automatically tries to do the guided/use entire disk again I think. Then it comes back and "guided resize" is selected. I max out the scroll bar for new partition size to give it 1.4 GB to see what happens. Warning about taking a long time, hit OK.

    One thing that's making it hard to got through this is that my cursor is always a watch so it's not obvious when the system is working vs waiting for input. I just noticed that the forward button was active so I hit that again. It's staying on this screen but the button is dimmed now so I *think* the system is working. I don't see any activity on my USB drive's status light though. And it's been sitting here a long time. Hmm.

    OK now it is saying "please wait -- checking the ext2 file system in partition 1 of scsi3" etc. ext2? Where did ext2 come from... thought we were doing ext3? Still no activity on my USB drive's light. No movement on the progress bar on screen either.

    Now got a dialog "go back and correct erros? - the test of the FS ext2 partition1 scsi3 found uncorrected errors. if you do not go back to partitioning and correct these errors, partition will be used as is." Not sure if I should go back or continue. Hmm. I guess that I will try to continue to see if it gets anything up and running on the stick for me. I have not seen this dialog box on previous attempts.

    It goes on to "resizing partition" quickly hits 50% then dialog with "resize operation failure, error while writing changes to the storage devices... resize aborted"

    Back to "scanning disks" after hitting OK.

    Now I have prepare partitions showing with the following:
    /dev/sda1 type=blank format=unchecked size=3824mb used=0
    /dev/sda5 type=swap format=unchecked size=230mb used=0

    I choose sda1 to edit because it doesn't list type or mount point. I set it to 3300mb, ext3, mount point /

    After delay and I click on sda5 it asks me if I want to save these changes to disk. Hit Yes. Now I'm not sure if it's done/doing this or if it's waiting for me to do something. The changes made in the last step are not showing on the main table. I reselect sda1 to check settings were in there. It did have the mount point and size as changed but format was blank. I change it to ext3 again and then the installer crashed with an "assertion error" in the dialog.

    I can't close the "installer crashed" dialog... button and X in top right of window do not do anything.

    Anyway, that's all for now. Any tips from anyone?


    • #3
      After system restart, boot from CD, go into installer again. Go all the way to partitions and I choose manual this time to see what I've got. Same as last listing except it's showing 13mb as used. I go in to try to set mount point, ext3 and resize to 3300 again. Get the warning about not being able to undo, hit OK, then decide to hit forward instead of trying to increase size of swap to over 256 as per instructions on screen. I want to see if I can get past this. (Think next try if this fails, I'll leave sda1 as-is and just see if I can get past this partitioning -- it seems like it half worked and gave me some new partitions.)

      Hanging for a long time again after hitting forward and the button dimming. After the wait, a couple of screens flash and then dialog error with ext3 file sys creation failed. Another dialog about resize aborted, then it scans the disks.

      PROGRESS! this time it comes up with ext3 and the mount point as / but with the 3824mb size, so it looks like only the resize failed. Format is also checked. So I am going to try to proceed with these settings. Make it to step 7/ready to install and it says it is going to format partition1 as ext3. It also says that the partition tables of sda are changes but no other info.

      Install progress goes to 15% again and detecting file systems, hangs for a long time. Don't see activity on usb stick. Hope is fading fast as I wait. Seems like there could be an issue when it is taking so long to detect the file systems all the time. Failure dialog again.

      Goes back to partitioning step, scans, I choose manual. Scans again, and I've lost type=ext3 and mount point again. Edit sda1 and it still has my last value for 3300mb. Change that to the existing value so hopefully it won't try to resize the partition. I do reset mount point and ext3.

      Confirmation screen says it is going to format partitions 1 and 5 as ext3 and swap. No changes to partition table this time so crossing fingers. Back to 15% and detecting file systems, hanging... again. Failure on ext3 file system creation.


      • #4
        Well, I made an attempt to use fdisk mkswap and all that to do this manually but still is failing. I'm not sure if I created a mount for the main ext3 partition though. Maybe I'll look into that, but I'm getting very very frustrated and am really almost done with this. I've spent a few days trying to get this working already.

        I'm about ready to either (1) abandon LinuxICE for now and try to get another distro working, (2) call in my linux swat team to see if they will have a go at this, (3) go to the dark side msft based stuff, so at least I can put my hardware to use -- though that idea really, really bums be out, or (4) go buy a CF card and IDE adapter to see if things install better over another device/non-usb device, (5) pray that someone helps me see the light and keep trying.

        Any advice?


        • #5
          I'm really about to throw this equipment out the window. Really.

          I just tried two things -- tried to configure the partitions manually in linux. Maybe that would have worked if it was perfect, but I can't say if it was.

          Then, I took the usb drive and put it into windows vista (what I'm trying to avoid dealing with) and used the HP util to wipe the drive.

          Still I hang on 15% and then get some random movement and then failure to create ext3.

          I'm ready to give up.


          • #6
            try another usb stick if you can. Just a thought
            Former author of LinuxICE, nghost, nobdy.
            Current author of Automotive Message Broker (AMB).
            Works on Tizen IVI. Does not represent anyone or anything but himself.


            • #7
              Thanks, Kev. Looking for one around here. But I also did this and it worked perfectly:

              Now I'm trying to reinstall ICE to the stick to see if the pen drive install might have helped out the format of my stick. I may not know what I'm talking about here, but it might have done something to the MBR that was causing a problem for me with ICE. I'm also suspicious of something about GRUB that may have come from another installation. I don't know if GRUB has been loaded on-board or on the stick, but if it's on the stick, maybe pen drive linux blew it away (I hope). I just want to give ICE a nice, clean stick (or alternatively, a manually configured stick if the install partitioning on ICE is the problem) and all this other brand new hardware to see if it can install.

              I have rebooted to the CD and on first attempt I had a whole new penguin button at the lower left of the screen. Never seen that before. But I can't start a terminal window to run fdisk to see what the stick has, and I also found out I can't run the installer. Rebooting again to see if running install before clicking around on other things works. But it was interesting to have that new button.

              My next attempt will be to update the VIA bios. I have not yet done that or figured out how to do it. Not sure if I should try to update to the latest bios from VIA, the linux patch BIOS, or some other bios. Or if this is the wrong path to pursue altogether.


              • #8
                OK, the installer works after reboot (sent straight into it without clicking on anything else, not even the cute little penguin button that I want to click on so badly). On prepare partitions, aI have 2 partitions -- efi @ 3824mb and swap at 230mb. No mount point. Never seen efi in here before, but the partition sizes seem to match what I've ended up with in previous attempts.

                Since I have no mount point, I'm stuck. I was hoping not to have to change anything about partitoins but since stuck I am going to try to add one and change sda1 to ext3.

                Now on the 15% point where everything usually goes fubar. Hanging again so I think I'm most likely out of luck. Yep. Same failure error.

                Is there any other method that I can use to install this? Is there any way to manually configure the USB drive and via untar put files where they should be and make the disk bootable? I feel like I'm fighting against the installer more than anything. The pendrivelinux method worked like a champ.

                Can anyone tell me if GRUB/mbr or bios are likely culprits here?


                • #9
                  Use entire disk fails as well.


                  • #10
                    I have not been able to find my other stick but will keep looking. But I have installed Linux Mint which I think is based on ubuntu along with a few other distros using guides at and they all seem to be fine. Well, they are pretty slow running. Is this because they are running as "live" over the usb? Will an actual install of ICE be faster than one of these pendrivelinux "live" iso installs?

                    So I think the stick is actually OK and I *really* would like to get it to work on this 4gb guy. This is the perfect use for a stick that otherwise sits around a lot so I hate to go out and buy another, or buy a IDE CF card adapter and new CF card.

                    Any other suggestions I can try before going with something else or buying more hardware?

                    To Kev -- maybe we can meet in person some time. I just was in Layton, UT for bit around a month ago. I may be there again in the coming weeks.


                    • #11
                      if memory serves me I also ran into problems when trying to install to a 4gb usb drive. I ended up buying a hard drive. A usb drive is slow but a live usb drive is even slower because it has to extract and copy to ram, figure out hardware on the fly etc. I have yet to be impressed by solid-state speeds compared to a spinning 2.5" hdd.

                      Yeah, Layton is real close to where I live. Were you there for business, visiting family?
                      Former author of LinuxICE, nghost, nobdy.
                      Current author of Automotive Message Broker (AMB).
                      Works on Tizen IVI. Does not represent anyone or anything but himself.


                      • #12
                        I almost bought a 3.5 inch 500gb drive for 120 or so but I'm glad that I didn't because I found power specs and 3.5 seems to suck SOOO much more power than 2.5, not to mention that 2.5 are supposedly more rugged for mobile use.

                        Since I have not been able to get ICE loaded onto the stick, I have installed a few different distros and currently have Puppy Linux installed. Sounds interesting since it runs totally from memory (file system and all). Does ICE do anything like this? You mention copy to ram so I think it may.

                        I was in Layton visiting a niece and nephew. I have a lot of family in Utah. My sister lives in Park City and she wants me to drive with her to Sacramento to my other sister's house for thanksgiving. So I may be coming to utah in a few days to do that and would be there before and/or after thanksgiving.


                        • #13
                          Heres the answer to your problem during partitioning phase, the Distro automounts the usb drive when it gets to the partitioning phase. You have to disable usb automounting, and how you do that, I have no clue, but if you find out let me know. Right now im trying to dd the install from a regular hdd onto my thumb drive. I tried disabling autofs, but instead it just mounts the partition twice, so whats on the cd for automounting I have no clue.


                          • #14
                            hmmm, try doing a:

                            sudo apt-get remove --purge usbmount
                            Initially I had this installed on the livecd but then later resorted to autofs and didn't remove usbmount. usbmount might be getting in the way.
                            Former author of LinuxICE, nghost, nobdy.
                            Current author of Automotive Message Broker (AMB).
                            Works on Tizen IVI. Does not represent anyone or anything but himself.


                            • #15
                              here's better solution:
                              use CF with IDE adapter, it works just fine, and it's not that expensive
                              EPIA TC 1G 256MB 60GB Linux,WindowMaker, Roadnav, Xine, XMMS, iGuidance3
                              Lilliput 8", Pharos i360, WUSB11v2.6 WiFi