No announcement yet.

XUbuntu 7.04 corrupting the harddrive

  • Filter
  • Time
  • Show
Clear All
new posts

  • XUbuntu 7.04 corrupting the harddrive

    I have Xubuntu 7.04 (cause anything 7.10 won't run X on my system, it just gives me a "something is wrong with X and we're waiting 2 minutes to try again", but thats another problem for another time) installed on my carpc (Voom PC 2, simple setup: runs off of car battery/alternator power with a switched power line as its 'turn on'/'turn off' signal).

    Now, my problem is that when I first install Ubuntu, everything works fine for about 2 to 3 weeks. Then I start getting 2 start up issues. The first: When I boot up the computer, it gives me "BOOT DISK FAILURE, INSERT MASTER BOOT DISK AND PRESS ENTER". The only way to remedy this is to just wait a while (>~3 hours) and try again and hope. If it boots up fine, then you have about 10 more startups before the problem returns again and you have to walk away for another 3 hours before it fixes itself. Second problem: This is much rarer, but occasionally I get a message about the "file system being corrupt [or missing]". It doesn't seem to be repeatable so I don't remember it off the top of my head. This is solved easily simply by pulling up the BIOS, and then resaving it and restarting.

    So, for the first problem: It seems like the way Xubuntu is being powered off is causing it to slowly corrupt the MBR (which, I admit, I'm not too familiar with). Has anybody else had this problem? Or know how to fix it? Any other ideas on what it could be? Is it a GRUB problem? And if it is because its a hardware shutdown vs a software shutdown, is there anyway to set xubuntu so that it treats both the same (as a software shutdown)? How shutting off this way is any different then normal is beyond me.
    For the second problem: Thats not a huge deal for me cause it happens so rarely. But, obviously, any help would be appreciated.

    I know its not the hardware, cause I was running Windows for about 8 months on the exact same hardware and none of these issues happened. When I switched to Linux a few months ago, it happened within the first month, so I bought a new harddrive and it happened again.

    Right, sorry for the hugely long post, but I'm hoping that more information leads to a quicker, better solution. Let me know if you need any other information (you might need to post to steps required to get that info as I'm not completely used to digging around the underpinnings of linux).


  • #2
    Maybe you got a bad hard drive and not the OS's fault? Have you wiped the drive and started from scratch? Do you still get the same errors? Does Windows work on the drive for any length of time?


    • #3
      how are you shutting down? you should remount the drive as read only at least before you shut it down. I also sounds to me like a bad hard drive.
      Former author of LinuxICE, nghost, nobdy.
      Current author of Automotive Message Broker (AMB).
      Works on Tizen IVI. Does not represent anyone or anything but himself.


      • #4
        This seriously sounds like a harddrive issue that is unrelated to Linux. Any chance it's an SATA harddrive? The older SATA cables were notoriously loose-fitting (at least the ones I used), and they caused occasional disk read/write failures for me until I litterally replugged them. Even if you ripped the power cable out instead of shutting down, it wouldn't effect the MBR.

        For the other issue, was specifically is (or are) the error message(s)? What does the error in /var/log/Xorg.0.log say?