No announcement yet.

Linux + Touch screen problem.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux + Touch screen problem.

    I cannot get touchscreen to work on linux no matter what i tried.
    I successfully installed ubuntu mobile on my desktop, but the touchscreen driver does not work. I can move cursor around but its totally wrong position.
    I tried calibrating, but it seem to have no effect. Anyone have a clue on what i should do to fix it?

  • #2
    Is the position inverted? Or just off by a lot?
    My carputer project


    • #3
      its seems weird... at the middle everything is ok, as u move towards the left the cursor moves to the right, and vice versa.


      • #4
        And if you move up the cursor goes down right?

        One of the posts in this forum suggested loading your touchscreen driver by doing this:

        modprobe touchkitusb swap_xy

        make sure the module isn't loaded already by doing an rmmod touchkitusb.

        I'm not sure if this is the driver you are using, but I'm guessing it might be.
        My carputer project


        • #5
          this is the ubuntu builtin driver, i'm trying to install the eeti driver but its not working
          the instruction say go into the USBSrc folder and type make all, but it doesnt work for me. No file so i have no idea how to install it


          • #6
            The eeti drivers are binaries. If you get the package from their site you shouldn't have to compile anything. Just put the modules in the right directories and change the xorg.conf file
            My carputer project


            • #7
              Sorry for my stupidity, i just started with linux
              I'mve having problem understanding this part of the procedure.
              and i dont have this particular file "/var/lib/” should i put it there?

              b.) configure the xorg configuration file
              Edit the xorg configuration file (e.g. /etc/X11/xorg.conf) and add the configuration used by
              the driver to connect to the device installed on your system.

              (1) Add an Input device declaration in “ServerLayout” section.
              For example:

              Section “ServerLayout”

              InputDevice “EETI” “SendCoreEvents”

              Note: If more than one TouchKit controllers ( 2 or more TouchKit touchscreens ) are
              used for the system, please add multiple InputDevice declarations in the
              “ServerLayout” section with different names.

              For example:
              InputDevice “EETI1” “SendCoreEvents”
              InputDevice “EETI2” “SendCoreEvents”

              (2) Configure the Xorg module configuration for TouchKit device.
              For each InputDevice section declared in the “ServerLayout” section you will
              need to create additional separate configuration in the xorg.conf file.

              For only one USB device in the system:

              Section “InputDevice”
              Identifier “EETI”
              Driver “egalax”
              Option “Device” “usbauto”
              Option “Parameters” “/var/lib/”
              Option “ScreenNo” “0”

              Note: The Identifier line must be same as the name declared it in the section

              For multiple devices ( RS232 and USB ) in the system:

              Section “InputDevice” ( For RS232 device )
              Identifier “EETI1”
              Driver “egalax”
              Option “Device” “/dev/ttyS0”
              Option “Parameters” “/var/lib/”
              Option “ScreenNo” “0”

              Section “InputDevice” ( For USB device )
              Identifier “EETI2”
              Driver “egalax”
              Option “Device” “usbauto”
              Option “Parameters” “/var/lib/”
              Option “ScreenNo” “0”


              • #8
                the terminal report my X version to be 1.5.2 Which does not corespond to any driver.
                So i tried the following anyway:

                Here are the things i've tried: for both version 1.3/1.4 from eeti website, neither gave me a response from the touch screen.
                After some diggin, i've gotten this far
                I've placed the into /usr/lib/xorg/modules/input
                Section "InputDevice"
                Identifier "EETI"
                Driver "egalax"
                Option "Device" "hiddevs"
                Option "Parameters" "/var/lib/"
                Option "ScreenNo" "0"
                Section "ServerLayout"
                Identifier "Default Layout"
                Screen "Default Screen"
                InputDevice "EETI" "SendCoreEvents"


                • #9
                  strange, I've setup egalax on half a dozen computers and it has worked every time...

                  can you paste the output of `lsusb`?

                  also, in ubuntu, `dpkg -l | grep xserver` should give you your version. This is what mine looks like in intrepid:

                  [email protected]:~$ dpkg -l | grep xserver
                  ii xserver-xorg 1:7.4~5ubuntu3 the X.Org X server
                  i xserver-xorg-core 2:1.5.2-2ubuntu3 Xorg X server - core server

                  since it looks like you are also running intrepid (based) ubuntu, we both may be out of luck with regard to touchscreen. Until the eeti people roll out a driver for 1.5... That sucks, I just upgraded my carPC to intrepid last night. I'll give egalax a try, but I'm not hopeful...

                  edit: looks like they have a beta driver for 1.4.99. I assume the is the beginnings of a 1.5 driver. Maybe if enough of us shoot them an email asking for a 1.5 driver, they'll hurry it up :P.
                  Former author of LinuxICE, nghost, nobdy.
                  Current author of Automotive Message Broker (AMB).
                  Works on Tizen IVI. Does not represent anyone or anything but himself.


                  • #10
                    ok, so it appears you are right, we have the exact same versions:
                    ii xserver-xorg 1:7.4~5ubuntu3 the X.Org X server
                    i xserver-xorg-core 2:1.5.2-2ubuntu3 Xorg X server - core server

                    output from lsusb is
                    BUS 001 Device 002: ID 0eef:0001 D-Wav Scientif Co., Ltd eGalax TouchScreen

                    I tried to go back to the instruction of the egalax driver
                    when i do the make all in USBSrc, i keep getting the error
                    "no rule to make target modules/2.6.27-4-lpia/build"


                    • #11
                      anyone know a command by command tutorial for installing touchkit on ubuntu?


                      • #12
                        There are pdf files in the Guide directory when you download the binaries. It is about as line by line as you can get.

                        I hope that helps.
                        My carputer project


                        • #13
                          i can't get get pass the make all part of the documentation.


                          • #14
                            can you paste what make says its doing before it fails?
                            My carputer project


                            • #15
                              Here it is:
                              [email protected]:~/Documents/bin-usb/elousbctrl-src$ make
                              make -C /lib/modules/2.6.27-4-lpia/build M=/home/ubuntu/Documents/bin-usb/elousbctrl-src modules
                              make[1]: Entering directory `/lib/modules/2.6.27-4-lpia/build'
                              make[1]: *** No rule to make target `modules'. Stop.
                              make[1]: Leaving directory `/lib/modules/2.6.27-4-lpia/build'
                              make: *** [default] Error 2