Announcement

Collapse
No announcement yet.

TFT Touchscreen with eGalax Touch driver + USB Mouse -> weired mouse pointer action

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • TFT Touchscreen with eGalax Touch driver + USB Mouse -> weired mouse pointer action

    hi!

    i'm running ubuntu 9.04, kernel 2.6.28-15-generic, X server X.Org X Server 1.6.0 Release Date: 2009-2-25 X Protocol Version 11, Revision 0.

    to get the TFT touchscreen working, i've installed package xserver-xorg-input-evtouch and driver eGalax Touch driver for 32bit Linux kernel 2.6.x, version 2.06.2905-32b-k26.

    output of cat /proc/bus/input/devices
    Code:
    I: Bus=0003 Vendor=0eef Product=0001 Version=0112
    N: Name="eGalax Inc. Touch"
    P: Phys=usb-0000:00:1d.0-2/input0
    S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.0/input/input5
    U: Uniq=
    H: Handlers=mouse1 event3
    B: EV=1b
    B: KEY=401 0 30000 0 0 0 0 0 0 0 0
    B: ABS=f
    B: MSC=10
    everthing works fine UNTIL i plugin USB mouse controller.
    then the mouse controller is not working properly, means the pointer is moving on the screen, but i cannot select anything.

    this problem is described here http://www.conan.de/touchscreen/evtouch.html
    "Since Xorg 7.2 there is always a default-mouse-pointer which will run simultaneously with evtouch if you do not prevent it from loading. It is extremely important that you add the following to your configuration. Otherwise you will get double click events and all kind of strange things."

    but as HAL is used i don't know how this should be implemented.

    can someone assist here?

    THX

  • #2
    I have a similar setup but I never managed to calibrate the screen properly. I am using the standard in-kernel egalax drivers. Any tips? Which screen are you using?
    My project: double indash, Golf IV
    http://www.mp3car.com/vbulletin/showthread.php?p=841754

    Comment


    • #3
      hi!

      it's a navilock 8" TFT touchscreen http://www.navilock.de/produkte/grup...8_VGA_169.html

      the calibration is simple if you just don't run any calibration program.

      i just setup the HAL driver files properly by means of defining the calibration values properly.
      the file can be found here: usr/share/hal/fdi/policy/20thirdparty/

      or review my posting here http://forum.ubuntuusers.de/topic/to...-kalibriert/2/

      Comment


      • #4
        Sadly I don't speak German (yet!) but thanks for the tip. I'll have a look at it.
        My project: double indash, Golf IV
        http://www.mp3car.com/vbulletin/showthread.php?p=841754

        Comment


        • #5
          Originally posted by cmonty View Post

          can someone assist here?

          THX
          What is the content of your /etc/X11/xorg.conf file???

          That might explain a few things...

          Comment


          • #6
            Originally posted by JaseP View Post
            What is the content of your /etc/X11/xorg.conf file???

            That might explain a few things...
            you're just a little late on this thread....

            Comment

            Working...
            X