No announcement yet.

Linux hibernate/suspend

  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux hibernate/suspend

    Is anyone able to help me...?

    I have an Epia 5000 which I have installe Mandrake 10.1 on. The kernel version is

    I cannot hibernate the machine by running:
    echo 4 > /proc/acpi/sleep
    as it resumes immediately.

    but I can get it to go into standby by running:
    echo 1 > /proc/acpi/sleep
    and it doesn't wake till I press the keyboard or something (which is correct).

    I've checked many sites on the internet but none have any answers. Can you help please?

  • #2
    Originally posted by mkkbb
    I cannot hibernate the machine by running:
    echo 4 > /proc/acpi/sleep
    as it resumes immediately.

    echo 4/4b> /proc/acpi/sleep


    • #3
      Do you know if that is supported by the motherboard with kernel 2.6? ACPI has pretty much been broken in 2.5/2.6 for a while now....that is why swsup2 exists....

      steven n

      95 Saturn SC1
      Alpine 9831 + Blaupunkt SR04
      Stereo Integrity 327 Comps + MTX 4244
      Resonant Engineering XXX 18 D2 + Elemental Designs Nine.1 + 7.5ft^3 tuned to ~29Hz

      Carputer Progress: Rethinking, box has consumed my trunk


      • #4
        Thanks for your replies. I've tried echo 4/4b> /proc/acpi/sleep but it still auto resumes.

        I'm not sure about the motherboard supporting it, I know it supoprts ACPI.

        I've tried patching the kernel with swsup2, but it complains that it can't patch cleanly so it removes itself. Any ideas on how I can patch the kernel?


        • #5
          What kernel version is the swsusp2 patch made for? If it's a recent kernel 2.6.x, you might be able to force the patch and then just fix the errors.

          Usually a patch that works cleanly on kernel a.b.c will still get applied to kernel a.b.c+6; but you'll have to look at the error file and see what cause the patch command to fail.

          If you luck out, it could just be a simple line or two of code that need changing or moving.

          What errors do you get when applying the patch? What kernel version is the patch for?

          Help us help you.
          DashPC - The Linux Car (since 1999).

          Dash LCD, Via Epia, GPS, XM, OBDII, DSSC Shutdown Controller.

          As seen in the book Geek My Ride


          • #6
            Just to keep you updated I decided to scrap Mandrake 10.1 and try out the distro called Ubuntu. It is fantastic, fast and very well supported, and they have a very good support/website too.

            I've managed to patch the kernel, and build it very very easily, maybe because it is based on Debian, but it is far better than Mandrake.

            (plus they send out free CDs).

            Once it has compiled, left it running overnight, i'll try the software suspend 2 features.


            • #7
              Sooo... Did it work?


              • #8
                Sorry I didn't reply to this thread sooner.

                I managed to patch the kernel with software suspend 2, and the suspend to disk did work fine, but the resume didn't, it would hang after about 30% (this is only in X mode, not just text mode as text mode worked fine). Maybe I need to shutdown some services to resume properly?

                I am now trying the latest kernel, 2.6.11 to see if it is any better (there is a bug fix in the latest software suspend 2 version which only works on the latest kernel).

                I'll let you know how I get on (quicker response too hopefully )


                • #9
                  Mandrake kernels are heavily patched. this is probably why the patch failed using the stock mdk kernel. just a fyi


                  • #10
                    My Car PC is running 2.6.12-gentoo-r3 patched with like a charm. Boot in < 15 sec.
                    Offical Freeway Subforum
                    Official Freeway Website


                    • #11
                      My system is running off a SuSE-9.3 based 2.6.11 kernel and suspends to disk no problems but I have to stop the network first (it stumbles with the rt2500 module otherwise). I'm using an MII-12000.
                      Silverwolf 2 is dead.
                      Silverwolf 3...?