Announcement

Collapse
No announcement yet.

Calibrating touchscreen

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Calibrating touchscreen

    Is there any software out there to calibrate a Xenarc 700IDT touchscreen? I am currently running in 800x480 resolution (16:9 widescreen).
    Offical Freeway Subforum
    Official Freeway Website

  • #2
    Nevermind. If anyone has this issue, let me know and I'll explain my solution.
    Offical Freeway Subforum
    Official Freeway Website

    Comment


    • #3
      Dude, how did you do it. Can you please explain? I can not figure it out.
      ODYSSEY

      Originally posted by Tidder
      Hey, as long as it's not any particular race I'm offending, I can stand to be a pedophile.
      All information expressed in this post is my opinion, and should not be regarded as a statement of fact.
      Digital-Car UK|

      (\__/)
      (='.'=)
      (")_(")

      Comment


      • #4
        Me too.
        POOP
        I'm nice, warm and brown :)

        Comment


        • #5
          yeah please tell us. We are mere mortals

          Comment


          • #6
            *** For 700IDT only, sorry Lilliput users, I don't have a screen to experiment with...but if someone sends me one to borrow, I can try to get it to work ***

            First of all, I found that using the eGalax driver (touchkitusb) was a complete bust. The screen worked, but the calibration was horrendous. Here's what I did.

            Note, this guide is probably for the more Linux experienced. If you are running a binary distribution like Debian, you will need to make sure you have glibc-devel, kernel sources, and of course gcc installed. I am running Gentoo, and this works perfectly.

            1. If you have previously installed the touchkitusb module, remove all traces of it.

            2. Go find your 700IDT drivers CD that came with the monitor. If you don't have it, let me know and I will send you the appropriate drivers. I am using Gentoo Linux, and I was able to get the Fedora 2 drivers to compile perfectly (Driver/Linux/Fedora2).

            3. Make sure you have the sharutils package installed (emerge sharutils in gentoo will do the trick). Also make sure you have tcl installed (emerge tcl). Then run the installation script (touchkit.setup_fdrII.sh).

            4. I got a ton of errors when I ran this script, but it at least created an archive and extracted it to /tmp/touchkit. Change to this directory and, if you are like me and don't have rpm installed, edit the "setup" file. You are looking for this line:

            found=`rpm -qa | sed -n /^$pkg-[0-9][0-9]*\\\\./p`

            If you are confident all the appropriate packages are installed, change it to found='hello' or anything of your liking. Note the single quote, rather than the accent mark.

            5. Save the file and run setup. You are looking to run full mode (choice #2). The module and daemons should start compiling.

            6. run tpaneld

            7. modules-update

            8. modprobe tkusb

            9. Ensure that /dev/tkpanel0 exists. cat /dev/tkpanel0 and touch the touchscreen. If jibberish comes up on the screen, it works.

            10. Restart X and run touchcfg to calibrate the screen

            Let me know if anyone has questions, and if you still can't figure it out, I can shell into your box and compile everything for you if I get some time.
            Offical Freeway Subforum
            Official Freeway Website

            Comment


            • #7
              Snap!
              Originally posted by ghettocruzer
              I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
              Want to:
              -Find out about the new iBug iPad install?
              -Find out about carPC's in just 5 minutes? View the Car PC 101 video

              Comment

              Working...
              X