No announcement yet.

second com port not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • second com port not working

    Hi Everyone,

    Not sure if this is a hardware or software problem... I'm trying to use the second com port on my epia m10000. If I run 'setserial /dev/ttyS1' it detects it and shows the UART type. Then I ran 'cat /dev/hda > /dev/ttyS1' and plugged my homemade serial cable to my windows box to hopefully see some garbage scrolling past. I don't see anything. I'm pretty sure my cable is wired correctly, and the com parameters are correct (if I set up /dev/ttyS0 I can log in through the cable). Is there anything special I have to do to enable this port?

    BTW I'm using LinuxBios.. not sure if that makes a difference.

  • #2

    I don't see two serial ports on this board.
    Are you sure it's not a virtual port associated with IrDa ?


    • #3
      It's got one - it's a header though. In that page you linked me to, if you look under "Onboard I/O Connectors", it has "1 Connector for LVDS module1 Serial port connector for a second com port" - somehow they missed a bullet and jumbled all of that onto one line.

      Check out the bottom of the first post here: That's how I wired mine (different board, but same pin-out on the connector).


      • #4
        Ok i see, then you should suspect that something is not activated in the bios, did you checked with "dmesg | more" or had a look in the very early boot stage in the syslog to see what hardware is detected ?


        • #5
          dmesg gives me this:

          [ 3893.729673] Serial: 8250/16550 driver $Revision: 1.90 $ 2 ports, IRQ sharing
          [ 3893.738815] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
          [ 3893.745923] serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A

          So looks like the kernel does see it...

          I just tried with another cable, same problem.


          • #6
            Ok with the kernel, that's a good point

            Is your cable a straight cable i mean pin to pin or is it a twisted null modem cable ?
            Try to reverse the tx and rx pins it won't be harmfull for the hardware and a wrong pin assignment is still possible, this could explain the situation.


            • #7
              For Epia boards, you have to use VIA header cable due to some pins are mixed on pinheader comparing to Intel standart. At least I had to make cable myself.


              • #8
                It would be nice to post the pin assigment if you have it somewhere


                • #9
                  Ok I found the problem - with LinuxBios, the port doesn't work, with the original via bios it works fine. So it wasn't my cable after all. I'll have to rethink whether I really want to use LinuxBios... the extra 2-ish seconds it saves me doesn't seem worth all the effort I've put in to it.

                  By the way, anybody looking for the pinout of the epia board, see - it's in the first post, near the end. The pin numbers correspond exactly to the DB9 pins, so pin 1 of the epia's com header goes to pin 1 of the male DB9, etc. It's also in the pdf manual on the via site.