No announcement yet.

HOWTO : ScanTool.Net for Linux (ODB-II)

  • Filter
  • Time
  • Show
Clear All
new posts

  • HOWTO : ScanTool.Net for Linux (ODB-II)

    First off, download allegro, and install it. That should be straightforward.
    (you need at least 4.1.18 as far as I can tell, which is ~x86 masked in Gentoo at the time of this writing)

    Second of all, download
    DZCOMM which you can get from this place.
    So download it...

    Then from inside the folder, do this.
    $ chmod +x
    $ ./

    $ ./configure
    $ make
    # make install

    Download Scantool.Net 1.08 from this page.
    This is a link to the file.
    1.13 is out at the time of this writing but I haven't tested it. Shouldn't be too different though.

    Next you have to apply a patch to the makefile. That failed miserably for me, so I'm just going to attach my new, *working* makefile. Remove .txt and replace your existing makefile.
    Then just type

    $ make LINUX=1

    and you'll be set. Please let me know how it worked out for you!

    [edit ... Doh! should this have been in the software tutorial forum?]
    Attached Files

  • #2
    running scantool under linux


    Following your instructions I have tried to run scantool (versions I already tried: 1.08, 1.11, 1.12, 1.13) on my Slackware 12 (kernel smp huge) with dzcomm 0.99i and allegro (versions: 4.2.0, 4.3.0, 4.2.2 ) unfortunelly was not able to see menu screen.

    Few questions to you:

    1. What were the system params you ran the software on ?
    (especially distro/kernel)
    2. Which version of dzcomm you have used ?
    3. Does the application need an HW interface connected in order to start to main screen?
    4. Any other dependencies etc?

    First I have had a problem with scantool.dat
    but it appears that I have already fixed it (I hope)

    Now I have such behaviour that the application starts,
    I can see for tens of milliseconds the window with background colour,
    then it closes and nothing else is happening.

    any Ideas? suggestions? recommended setup?




    • #3
      A quick note on serial ports
      (I use OpenSuse 11.0)

      ScanTool has com ports 1-8 as /dev/ttys0-8
      - so one may need to ln -s, example ln -s /dev/ttyUSB0 /dev/ttys0

      /Owen, Denmark
      Owen Brotherwood, Denmark