Announcement

Collapse
No announcement yet.

iGuidance 2.1.3 in Wine

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • iGuidance 2.1.3 in Wine

    I wanted to thank everyone else out there who helped me make my first CarPC what it was. I say "was" because the laptop harddrive with RR on XP recently gave up the ghost.

    That got me thinking about my original plan of making my CarPC Linux-based WITH door-to-door gps navigation software and a highly customized native front-end.

    The only thing that really stands in the way of realizing this goal is getting my favorite gps navigation software, iGuidance 2.1, working with Wine. That is, until now.

    Ubuntu Dapper Drake 6.06 on a Celeron 733 with 256MB of RAM. I installed Wine 0.9.9 (the latest with Dapper at the moment) from the default sources list. I mapped a SMB share to my windows box where I had my iGuidance DVD drive mounted. A simple "wine setup.exe" led me through the initial install with no issues. It autostarts the maploader installer, but it gave me errors about finding the map data, etc.

    So, I installed iGuidance on the same Windows box. I ran the maploader, selected the states I wanted, and allowed it to install them on the C: drive. I then simply copied the map data (C:\iNav IGuidance\Maps) into my wine's drive_c folder (/home/geese/.wine/drive_c/iNav\ iGuidance/Maps).

    Now, I tried "wine /home/geese/.wine/drive_c/program\ files/iNav/iGuidance/iGuidance.exe". However, it complained about not being able to find "names.bin" or somesuch. The trick was to cd to the directory first and then run "wine iGuidance.exe".

    So now it's running, but no GPS yet.

    To test my GPS (a Deluo based on the SirfII chipset), I used gpsd. Ubuntu sets it up as /dev/ttyS0 or /dev/ttyUSB0 depending on which connector I used. In the end, both worked well (modprobe pl2303 was needed for the USB).

    I set up the symlink in /home/geese/.wine/dosdevices such that com1 pointed to /dev/ttyS0 and fired up iGuidance again. No luck. Lots of Setupcomm errors

    So, I went to winehq's site and downloaded 0.9.17 from them after adding their site to my sources. Still, no luck. They fixed the original Setupcomm errors, but another popped up.

    I then went and bought Cedaga, installed it, and tried the whole reinstalling process over again. Still, no luck. There weren't any comm errors, but it didn't work.

    I went back to wine (0.9.17) and futzed with it some more. Then, *magically*, it worked. I kid you not, I don't know what did it or how. But, it works. Sound worked (alsa or oss), and I was able to get a lock.

    Can I repeat this? I hope so. I'm going to try my darndest to do it again and document *exactly* the steps I took. I'll be sure to post here when that happens.

    My question is, can a wine-based window be "trapped"/integrated with a linux-based front-end much like skinbedder?

  • #2
    Good Work GEESE! I just started messing with knoppix (diff distribution) and read that there arent any availible GPS software yet. So GPS was really holding me back too. Hopefully you can replicate the work! Good luck.

    Comment


    • #3
      Also, just as an FYI, I've let it run continuously for 48 hrs with no issues. It will occasionally lose lock, so I'll check on it. It still is receiving data, but just not from enough satellites. Mind you, this is in a bedroom with a north-facing window. If I give it a few minutes, another satellite comes in and it regains lock. I'm pretty impressed.

      Comment


      • #4
        There is a native navigation software.

        http://www.directions.ltd.uk/moreinfo.php?id=1080

        So far only interesting, if youlife somewhere in Europe.

        But they told me, they will have North America Maps in fall of 2006.

        Bye Stefan

        Comment


        • #5
          Well, it appears that wineserver likes to consume 60K of memory every few seconds. The iGuidance process stays rock solid, though. This means that it can't be run for more than 2 hrs or so without it resorting to mad disk swapping.

          Still, I'm very close...

          Comment


          • #6
            Navigon Mobile Navigator for Laptop is working fine with wine.

            Only problem is that the programm starts 20px to low and all messageboxs are wrong placed, except this it works fine


            updates for Destinator 6:


            heavy cpu usage @ Epia M10000 with 512MB Ram


            (plz excuse my bad english)

            Comment


            • #7
              Thanks to Geese's inspiration I also tried to get Iguidance running on Ubuntu Dapper Drake 6.06. Instead of the stock wine or transgaming versions I use Crossover Office from Code Weavers. I have had a subscription with them for 3 years.

              I created a new bottle (what they call a wine instance) in the CXinstaller.
              I ran ~cxoffice/bin/cxrun
              I selected the bottle I created and entered winecfg
              This popped up the wine configuration tool that let me select the XP environment template.

              I threw in the Iguidance DVD in the drive and used Crossover office’s “install unsupported application" option.

              Then I navigated to the DVD and ran setup.exe.

              The map loader worked the first time. Crossover even put all the icons on my desktop.

              I followed Geese’s instructions in how to add gpsd and the com port to dosdevices located in ~.cxoffice/bottlename/dosdevices
              I have a Garmin handheld that can simulate a full lock which (very much needed since this machine is in the basement and not near a window).
              I connected the handheld to the serial port and tested the connection.
              I made sure that I was getting data by using the xgps client.

              After I was sure that the GPS port was spitting out the right data I started IG3 UMPC and got the nag screen. Success.
              Since the gps is only sending the test data there was no movement to see and I could not test a trip but that is next.

              Thanks for all the info Geese!
              Attached Files
              2006 Subaru STI
              Voom2PC with CN700 Lilliput 7" Digimoto mOByDic
              Sirius-SR1 BU-355 - EWF/Roadrunner/LSX

              Comment


              • #8
                Have you noticed any appreciable redraw lag or other weirdness compared to "real" WindowsXP?
                Silverwolf 2 is dead.
                Silverwolf 3...?

                Comment


                • #9
                  I guess the short answer to your question is that it runs well enough for me. Read on for the long answer:
                  I can only talk about moving the screen around and watching the GPS info update since my machine and gps are tethered. On Ubuntu - moving the screen around forces redraws but not too much lag maybe a second but no more. When I install it on Damn Small Linux (DSL) the XVESA environment forces some more lag into the equation but still not to the point where I think it will be a problem in the car. Unfortunately, I am getting the "too many pipes" error in DSL to try it out in the car as is. I also can't get Ubuntu to install on my Epia 800 test box to confirm what my desktop is doing. Until I get Gentoo working I am forced into DSL for right now.
                  2006 Subaru STI
                  Voom2PC with CN700 Lilliput 7" Digimoto mOByDic
                  Sirius-SR1 BU-355 - EWF/Roadrunner/LSX

                  Comment


                  • #10
                    Originally posted by intuitionsys View Post
                    Have you noticed any appreciable redraw lag or other weirdness compared to "real" WindowsXP?
                    Nothing really that noticeable.

                    When you drag the screen around in 3D mode, there is about a 1/2 second redraw time. This is compared to about a 1/4 of a second in XP. Behaves the exact same way, just a tad bit slower in that regard.

                    I'm rebuilding my testing environment using TinyGentoo, so I'll continue to update this thread with new insights or issues.

                    Comment


                    • #11
                      I tried to use Damn Small Linux to see if crossover/iG3 would work and the install is very straight forward. Just make sure that your bottle is set to emulate XP.

                      Once ig3 is started my Epia 800 reports 38 megs of memory used with 4% CPU. When actively getting gps signal (I start out tethered and stationary and then move the gps around as far as the cable allows) it jumps to 35%. This will work for a few minutes and then crashes with the "too many open files error". The killer seems to be the com port code that others have reported on other threads (yes, I do )

                      Darn it. I was very happy with the cpu/memory usage on DSL. I can't wait until Geese gets his TinyGentoo howto together.
                      2006 Subaru STI
                      Voom2PC with CN700 Lilliput 7" Digimoto mOByDic
                      Sirius-SR1 BU-355 - EWF/Roadrunner/LSX

                      Comment


                      • #12
                        Well I installed the latest crossover office demo and made the symlink ln -s /dev/ttyUSB0 com1 (which I found out the com1 has to be lower case). And the results are in the image below.

                        iGuidance 3 runs in linux under crossover-standard-demo-5.0.3. I haven't done any detailed testing but from the few minutes I've played with it it seems to work.

                        I'm running the iGuidance UMPC.

                        It appeared to crash after a while while I was clicking on things.
                        Performance seems to be great. You would think it was a native app.
                        I guess the trick now is to find out how to prevent it from crashing.

                        Edit: I wonder if crossover office demo has a nag screen. It is possible that poping up (though I haven't actualy seen one pop up) could be a problem.

                        Is it stable for you other guys?
                        Attached Files
                        My carputer project

                        Comment


                        • #13
                          I'll be able to see in about two weeks. I'm going to try IG3 in wine, cedega, cvscedega, and crossover office and hope one of them "just works".

                          My TinyGentoo platform is coming along nicely. I'm going to try to work this into that build image very soon now.

                          Comment


                          • #14
                            Great news. I can't wait to see it. Tiny Genoo looks like the ticket without having to go the full embedded route.
                            2006 Subaru STI
                            Voom2PC with CN700 Lilliput 7" Digimoto mOByDic
                            Sirius-SR1 BU-355 - EWF/Roadrunner/LSX

                            Comment


                            • #15
                              benny how did you get destinator 6 running?was it with normal wine?did you needed some tweak?
                              In a world without Gates and Windows there are no fences or walls!!

                              Comment

                              Working...
                              X