Announcement

Collapse
No announcement yet.

Help! "Create Network..."

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help! "Create Network..."

    Anyone know how to create a network that will persist after awakening from sleep and will automatically be created when starting up my Mac Mini???

    I found an Applescript at http://www.macosxhints.com/article.p...08081808383349. It seems to work ... sometimes. On sleep, the network disappears and I have to manually recreate it.

    My goal is to use the iPhone's Remote app, as well some of the wireless keyboard/mousepad apps, to control my Mac Mini. Unfortunately, they need to be on the same wireless network. Every time the Mini goes to sleep, I'm losing my network.

  • #2
    Originally posted by 1999MockOne View Post
    Every time the Mini goes to sleep, I'm losing my network.
    That's pretty unusual, I've 6 different machines (including VISTA)in my home network and I don't see any "network" problem after waking up (except VISTA, she doesn't wake up at all sometime) with default setup. From the Network > Airport > Advanced... in the System Preferences have you checked that "Remember any network this computer has joined" is checked? Cheers!!!

    Comment


    • #3
      MacUsers, I think he is talking about creating an AdHoc network from the Mini itself.

      I ran into the same issue when I started playing with using my iPhone to offer unsupported and an authorized functionality to my Mini.

      My solution was to install a Wifi router in the car directly wired to the battery. I'm using a Linksys WRT-54G v2.0 running DD-WRT and it was working great until the engine disabling system got tripped in my car Hopefully that was just bad luck and it won't do it again when I hook the router back up this weekend.

      The best part about the Linksys and DD-WRT is that you essentially have another computer in the car. My plan is to use it's serial ports with a web page to control some functions (windows, door locks, starting the engine) without having to wake the Mini (though I have also enabled WOL for it since it is hardwired to the router).

      -dave
      My pathetic worklog.
      CarFrontEnd (now it's own sub-forum!!!!)

      Comment


      • #4
        Originally posted by iamgnat View Post
        MacUsers, I think he is talking about creating an AdHoc network from the Mini itself.
        Exactly!


        Originally posted by iamgnat View Post
        I'm using a Linksys WRT-54G v2.0 running DD-WRT and it was working great until the engine disabling system got tripped in my car
        What does the DD-WRT give you in addition to stock firmware?

        I have a WRT54GS ver. 6 just languishing in my closet. Can you just clip off the wall wart and attach the wires to the battery terminals or is it more involved than that? If that's the case, that would be a relatively easy solution.

        Comment


        • #5
          Originally posted by 1999MockOne View Post
          What does the DD-WRT give you in addition to stock firmware?
          The simple answer is "you turn your consumer grade router into a commercial grade router". It essentially gives you full access to all the things your router really can do (e.g. VPNs, better/standard firewall, ssh access/administration, etc..).

          I replaced my Verizon POS router with a WRT-54G and now have much better control over my network, including the ability to administer and get into it remotely.

          I have a WRT54GS ver. 6 just languishing in my closet.
          The best are the v4s and earlier as they had more memory/flash to play with. You can still use the v6, but you have to use the mini firmware which is missing a few options (no idea off the top of my head). Additionally the v1 - v2 (may be possible with higher versions, but I haven't seen details about how to do it with them) have ports that allow you to add serial ports and an SD-Card if you are handy with a soldering iron. That essentially makes what you can do with these things almost limitless.

          Can you just clip off the wall wart and attach the wires to the battery terminals or is it more involved than that? If that's the case, that would be a relatively easy solution.
          That's exactly what I did. Check the specs on yours, but the v2s that I have take 12v @ 1A directly. Even better is that the woman I bought the car one from gave me an extra supply because the Linksys was toast. I tried to give her the good one back since all I needed was the cable from the old one, but on well .

          It all ran great for 2 days, until I disconnected it while trying to figure out why the car wouldn't start (turns out I fried the security system when I disassembled the steering column for something unrelated). My iPhone would pick up the network about 100' away without issue

          Once I get it running again, I do need to adjust the wifi power and CPU speed (more features of *-WRT over the default fireware) so that A) my wifi isn't visible from more than about 30 feet and B) it sucks up less power while the car is off.

          -dave
          My pathetic worklog.
          CarFrontEnd (now it's own sub-forum!!!!)

          Comment


          • #6
            Originally posted by iamgnat View Post
            That's exactly what I did.
            To be more specific in case you aren't familiar with all this stuff, technically I attached it to the power connections for one of my Amps. That line does go directly to the battery with a 60A fuse. Really i'm being bad that I don't have a 1A fuse between the Amp and the router.

            If you do go this route, don't follow my example. Install that fuse so you don't have a risk of short/fire.

            -dave
            My pathetic worklog.
            CarFrontEnd (now it's own sub-forum!!!!)

            Comment


            • #7
              Originally posted by iamgnat View Post
              To be more specific in case you aren't familiar with all this stuff, technically I attached it to the power connections for one of my Amps. That line does go directly to the battery with a 60A fuse. Really i'm being bad that I don't have a 1A fuse between the Amp and the router.

              If you do go this route, don't follow my example. Install that fuse so you don't have a risk of short/fire.

              -dave
              Hey! Thanks for all the info!

              I think I have an old WRT-54G also, but I can't locate it right now, so I have no idea what version it is. Maybe I'll check out Amazon and ebay for one.

              Comment

              Working...
              X