Announcement

Collapse
No announcement yet.

Widcomm + WM6 auto answer problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Widcomm + WM6 auto answer problem

    Hi,
    I'm currently working on my carputer project. Everything is working wonderfully and right now I'm going through the final phase of having my Windows Mobile phone use the car speakers and microphone as headset.

    On my carputer I am running on Widcomm BT ver 5. The WM6 phone (HTC Universal on custom WM6 rom) is running the MS stack. I managed to pair and connect successfully with my WM6 device. The headset works very nicely, but with a problem:

    Whenever a phone call comes in the phone automatically answers the call without even asking me. It rings once then answers. This does not happen while not using a BT headset nor does it happen with my regular portable Samsung BT headset. The software I'm using is PhoneControl.net, though this is happening even without loading Phoco. So I'm assuming the problem is in the Widcomm driver. There doesn't seem to be anything I can change in the software settings.

    Does anybody know how to solve this problem? I obviously don't want every single call that comes in to get answered. I wouldn't even mind answering the call from the phone itself (and not Phoco) as long as the voice gets routed from the phone to the car stereo with the external mic.

    Thanks!
    Yaniv
    My Car PC project
    Current status: Fabricating screen

  • #2
    I have spend the last 48 hours scratching my head on this one.

    Reading all the resources I could find.
    I tried the following widcomm versions: 1100,1200,1700,2400,3600,4200
    Every conceivable registry setting.

    I am happy to say I finally figured it out for my HTC Touch with WM6

    Here is the excerpt from the manual that helped me figure it out.
    Auto Answer
    Provide options to set how quickly incoming calls are automatically answered during hands-free operation. Choose options as 3, 4, 6, 8, or 10 seconds). Choose Never to disable this option. However, these settings do not apply when the ring type is Silent.

    Red being the important part. I put my phone on normal mode for the ringtone, and what do you know! It now waits for me to accept the call!

    Now I must search the rest of the forum for those other users I saw with the same problem. Help it helps

    Comment


    • #3
      Salmizar, I have been struggling with this issue for MONTHS with no solution! But for me, it has nothing at all to do with the auto-answer settings on the phone. It has to do with the Broadcom stack on the PC and how it interacts with Windows Mobile's stack.

      I have the problem regardless of whether I'm on silent or normal, and the Auto-answer function in Windows Mobile is ALWAYS disabled on my phone. Are you sure that's all you had to do?
      My Grandma & Her Friends on Their Spring Vacation

      Comment


      • #4
        I think I may have spoke too soon. I have the auto answer function within WM always off as well. I think I may be suffering from the same problem. Here is what I have now.

        I have test everything on both freefone and phonecontrol(registered copy).

        I can make calls without a hitch. I call out. I hear them, they hear me. When the call is done I hang up and all is well.

        Incoming calls are where the problem is. I think my device was improperly paired, resulting in no true headset connection. So I was able to click accept, but then no mic could be heard on the other end.

        I re-installed the drivers for my bt, and paired the device. Now It always auto accepts everytime now, and the mic works properly. It's to bad too, because its the only thing preventing a completed install for me.

        Have you considered contacting Boardcom about the issue? Their technical support seems willing to help with technical issues related to the software.

        I contacted Belkin and they wanted me to RMA the bt device back to them. I have gone ahead with an advanced RMA, but I doubt it will do any good.

        Centrafuse is apparently working on their own custom bt stack that they claim will work with most if not all phones. It's to bad though, because I prefer RoadRunner to it.

        Comment


        • #5
          Originally posted by Salmizar View Post
          Centrafuse is apparently working on their own custom bt stack that they claim will work with most if not all phones. It's to bad though, because I prefer RoadRunner to it.
          Are you sure about this? I always thought they use the Widcomm SDK.
          My Car PC project
          Current status: Fabricating screen

          Comment


          • #6
            Originally posted by yaniv View Post
            Are you sure about this? I always thought they use the Widcomm SDK.
            I am just going by what I read in their forum http://forums.fluxmedia.net/showthread.php?t=2084

            Comment


            • #7
              Hmm interesting. I should uninstall widcomm and go plain with centrafuse. I will try this tonight when I get home.

              Thanks!
              My Car PC project
              Current status: Fabricating screen

              Comment


              • #8
                I just read this again.
                The current version still uses phonecontrol.net (which doesn't have the built-in stack).

                Guess I'll have to wait for this "new solution" to come out :/
                My Car PC project
                Current status: Fabricating screen

                Comment


                • #9
                  Did you installed the CONNECTOR from PhoCo to your HTC/Smartphone? You have to hotsync/install the CAB file from Phoco and it won't auto-answer. It will show the PhoneControl icon on the phone after it's installed.

                  Comment


                  • #10
                    Originally posted by Maddominican View Post
                    Did you installed the CONNECTOR from PhoCo to your HTC/Smartphone? You have to hotsync/install the CAB file from Phoco and it won't auto-answer. It will show the PhoneControl icon on the phone after it's installed.
                    I installed it (half) manually by installing the CAB from the centrafuse folder. I have the phoco icon on my WM6 today screen and I can see all my contacts from centrafuse. It also seems to connect properly from the phoco wizard. So phoco works.
                    My Car PC project
                    Current status: Fabricating screen

                    Comment


                    • #11
                      Originally posted by Salmizar View Post
                      I think I may have spoke too soon. I have the auto answer function within WM always off as well. I think I may be suffering from the same problem. Here is what I have now.

                      I have test everything on both freefone and phonecontrol(registered copy).

                      I can make calls without a hitch. I call out. I hear them, they hear me. When the call is done I hang up and all is well.

                      Incoming calls are where the problem is. I think my device was improperly paired, resulting in no true headset connection. So I was able to click accept, but then no mic could be heard on the other end.

                      I re-installed the drivers for my bt, and paired the device. Now It always auto accepts everytime now, and the mic works properly. It's to bad too, because its the only thing preventing a completed install for me.

                      Have you considered contacting Boardcom about the issue? Their technical support seems willing to help with technical issues related to the software.

                      I contacted Belkin and they wanted me to RMA the bt device back to them. I have gone ahead with an advanced RMA, but I doubt it will do any good.

                      Centrafuse is apparently working on their own custom bt stack that they claim will work with most if not all phones. It's to bad though, because I prefer RoadRunner to it.
                      I've already communicated with Broadcom support and they said literally told me that they have no solution for this problem. It only happens with Windows Mobile phones, unfortunately. Also, I've tried four different BT dongles, including the same Belkin model twice, and it still does it. So, when you get your new Belkin BT dongle, it's unforunately, going to do the same thing.

                      It's a crazy bug, but I'm glad I'm finally starting to see other people who can relate. When I first started to post about this bug several months ago on several different forums, I got no responses at all, most likely because no one else was using the same setup and hardware as me.

                      Right now, according to everyone I've talked to, there is no solution for this. Maybe we can all put our heads together and come up with something.
                      My Grandma & Her Friends on Their Spring Vacation

                      Comment


                      • #12
                        Originally posted by Maddominican View Post
                        Did you installed the CONNECTOR from PhoCo to your HTC/Smartphone? You have to hotsync/install the CAB file from Phoco and it won't auto-answer. It will show the PhoneControl icon on the phone after it's installed.
                        Yes, the PhoCoAdapter is installed on our phones. If it wasn't, PhoCo wouldn't work at all with our phones.

                        And to say that it "won't auto-answer" after installing the cab, is 100% incorrect. Trust me, I've done every possible thing there is to do to fix this. I've tweaked every registry key on both the desktop and phone, talked to PhoCo, Broadcom, and Microsoft (no help from Microsoft or Broadcom at all of course), and still no solution. Zoran, the developer of PhoCo was very helpful for two months in trying to help me find the solution. He will tell you himself that there is no solution for this problem.
                        My Grandma & Her Friends on Their Spring Vacation

                        Comment


                        • #13
                          I'll think about this problem a bit further. Thanks for all the help, if I find something I'll post to this thread.
                          My Car PC project
                          Current status: Fabricating screen

                          Comment


                          • #14
                            I very disappointed about all of this. When I went in search of a new phone to replace my Blackberry. My #1 concern was having it function with my carputer. PhoneControl listed my phone as being compatible. 155$ later in dongles/software and no solution.

                            I am waiting to see how the Centrafuse solution works. And hoping that they will make it available separate from Centrafuse itself (doubt it, but you never know).

                            Comment


                            • #15
                              If it makes you feel any better, I know for a fact that it's the Broadcom stack, and if CF's Phone solution does not use that (I'm pretty sure they are building their own stack), then it will hopefully be good. I can also tell you to make you feel better that every other type of handsfree solution I've tested with my Windows Phone DOES work the way it's supposed to. It really is only the way Broadcom's stack communicates with WM's stack that has this problem. Unfortunately as far as PhoCo is concerned, Broadcom's stack is the only supported one, and the only one with a Handsfree profile.
                              My Grandma & Her Friends on Their Spring Vacation

                              Comment

                              Working...
                              X