Announcement

Collapse
No announcement yet.

USB 2.0 drivers without SP1 WINXP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • USB 2.0 drivers without SP1 WINXP

    Because I don't want to use SP1 but do want my USB 2.0 ports to work as they supposed to, I'm looking for drivers which willl work for my epia M10000 board wit WINXP professional. Anyone solved this problem correct? I've downloaded something from intel and installed it, which makes it recognize the hub. Everything works fine with or withou the intel driver, but not with USB 2.0 Speed. ANyone??

  • #2
    I wanted the same thing and could never find a solution so I just installed SP1 =\

    Comment


    • #3
      There's nothing wrong with SP1
      [H]4 Life
      My next generation Front End is right on schedule.
      It will be done sometime in the next generation.
      I'm a lesbian too.
      I am for hire!

      Comment


      • #4
        Originally posted by frodobaggins
        There's nothing wrong with SP1
        Unless you can't upgrade to it because you have a bogus copy of XP.

        Not that I do...now.
        Aura MR62 (F and R)
        My Current MP3s
        IamDefiler.com

        Comment


        • #5
          Originally posted by Defiler
          Unless you can't upgrade to it because you have a bogus copy of XP.

          Not that I do...now.
          Smart people get around that everyday
          [H]4 Life
          My next generation Front End is right on schedule.
          It will be done sometime in the next generation.
          I'm a lesbian too.
          I am for hire!

          Comment


          • #6
            Originally posted by frodobaggins
            Smart people get around that everyday
            Even dumb people too. It was just a reply for shiznits and giggleizles.
            Aura MR62 (F and R)
            My Current MP3s
            IamDefiler.com

            Comment


            • #7
              I would never promote illegal SW, but I have a "friend" who tried installing SP1 on his win xp pro EPIA. My friend had problems installing sp1...something about a licensing issue...and now he can't get his usb2 wireless LAN adapter to work . What should I tell my "friend"?
              -AL
              * 2000 Ford Expedition
              * EPIA M10000/512 meg RAM, Win XP PRO, 90w OPUS, 80 gig HD
              * TM-710VGT LCD, Wireless mouse, keyboard
              * M-Audio Sound Card, 2 Alumapro 10" subs, 2 PPI Amps (1kW)

              Comment


              • #8
                I'd tell your "friend" to reinstall XP with a "corporate" key.

                Comment


                • #9
                  Originally posted by Rireal
                  I'd tell your "friend" to reinstall XP with a "corporate" key.
                  Tell your friend to search the net.... there is a program for your friend that will allow you to change your key so that when you try to install sp1 from microsoft.com it will recognize it as a legal copy..... Very easy
                  My carputer

                  Comment


                  • #10
                    Either way, generally SP1 is required to run USB2 in any fashion. In our service department, our tech and I have attempted many times to circumvent this seemingly nonsense requirement.

                    With every motherboard we attempted, the driver CD (as well as the downloaded versions from the manufacturers) demanded to see SP1 before they would allow USB2.

                    We contacted a couple of the manufacturers direct (Asus and Gigabyte), and asked their technicians what gives. Apparently, a few key components that makes USB2 work, yet retain backwards compatibility with USB1.1, were not included in the initial build of XP, simply because USB2 was not a common thing to have at the time of its development and subsequent release. It was never believed that USB2 would catch on, since firewire already had the market by the short and curlies.

                    Once it was discovered that USB2 was catching on bigger than ever anticipated, the capability was added to XP via Service Pack 1. Mobo manufacturers attempt to enforce stability of their products under XP by locking down the installation of drivers, unless SP1 is present. We were told that there are methods by which we could force the needed driver files to their appropriate places from their drivers CDs, and even add the required registry entries, but without the necessary DLLs to make the communications happen the way they are expected to, you will still never see USB2 functionality.

                    Despite the problems that some users have had with installations of SP1, bear in mind that an overwhelming majority of users that had problems with it were owners of preman machines (Dell, Compaq, Gateway etc.) Most homebuilt-users (including yours truly) may install it without issues, as long as one of two requirements are met. The first is that you have a legal copy of Windows. The second is that you have a "it's legal as of right now because I found a way around it" copy. Either one, using the CD key you got when you purchased the installation disc, or the Corporate Edition key (also the MSDN Developers' key) will let you download and install SP1 without a problem.
                    The ALEXIS Project
                    MP3---VIDEO---GPS---REARVIEW---OBD---SKINNING
                    Color Coding :
                    DONE / MOSTLY DONE / BASE FEATURES / WORKING CONCEPT / NO CODE COMPLETED

                    Comment


                    • #11
                      Well i dont know about you guys, but its easy to get USB2 working in XP without SP1 (and 2k). After activating the Windows Update Catalog option in windows update, i searched and downloaded the USB2 drivers for 2k and XP. I now have a nice little directory on my hdd with the USB2 drivers and I can use these without XPSP1.

                      Hope this helps some how.

                      Matthew
                      Matthew
                      Mitsubishi Lancer Hatch
                      VIA EPIA 800V
                      128RAM - 10 GB HDD
                      200 Watt PSU - 300 Watt Inverter
                      Lilliput 7" Touchscreen
                      D-Link USB FM Radio
                      Dlink DWL-520+ b/g Wifi Card
                      Fortuna GPSmart
                      Alpine Amp and Splits
                      Gentoo Linux/Windows 2000

                      Comment


                      • #12
                        I got sp1 to work on my system and so did usb 2.0

                        Comment

                        Working...
                        X