No announcement yet.

GPS Acting as Mouse and solutions don't work for XP Sp2?

  • Filter
  • Time
  • Show
Clear All
new posts

  • GPS Acting as Mouse and solutions don't work for XP Sp2?

    I had the problem of the GPS being mistaken for a mouse by Windows, and I tried the solutions presented in here:

    The problem is that the posted serial.reg on routis' website didn't work for me, and with Windows XP SP 2, as soon as I disconnected the GPS unit so the curser wouldn't be so crazy, the hardware list in the device manager to disable would also dissapear, making it impossible for me to disable it in the first place. (it's also near impossible to access the device manager when the curser is acting crazy) If I reconnected the GPS unit, windows would then fix the error (and the offending "fake hardware" in the form of a serial mouse wouldn't be there anymore), but disconnecting the gps unit and then reconnecting every time I boot is out of the question.

    The solution is to manually edit the registry by hand (for some reason, with SP2, the values did not change upon running the sermouse.reg file.

    first run regedit (start->run->regedit)

    browse to here: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\sermouse

    change the value of "Start" to 4 (doesn't matter if it's hex or dec, but leave it how it was). It will probably be a value of 3

    this is the exact same values as in the reg file that routis supplies, but for some reason in my installation of windows XP sp2, it didn't work (it worked for when I was running sp1).

    Hope it helps.

  • #2
    I have the same problem with my GPS35 from Garmin that uses an RS232 converter. I just have the device manager open and ready so that I can quickly disable it. Also, is you're GPS using an USB/RS232 converter? Anyways, that suggestion worked for me.


    • #3
      how did you set your device manager to open up? the whole problem was that i couldn't open it up with the mouse clicking everywhere.


      • #4
        GPS acting as mouse?? It must be a pain to have to drive south west to get to the start button...

        What I can't figure is how would you click??
        Caputer Mk. II
        '02 VX Holden Commodore Series II Executive
        MII12000, 512MB RAM, 60GB HDD (5400rpm), 16X DVD, TS200V
        Morex 60W DC-DC, Custom S/SDC
        OS/Software: Developing...


        • #5
          I have a GPS25 engine and have had the whole mouse going mental/ taskbar going all over the screen scenario, and I solved it by only powering up the GPS once the PC was booted. I used to use a manual switch, my new car pc has a timed delay circuit which delays the 5v supply until the PC is up..
          ....Yes, I know it has a stupid name, those crazy Japanese!


          • #6

            Eh, do yall have a touch screen ? If so whats happening is that the GPS port and Touch screen Port are the same, Both peices of software use USB-Serial drivers that basically create a virtual serial port on your machine..

            The touch screen and GPS reciever are using the same port hence the crazy mouse situation. Try reinstalling your touch screen drivers with the GPS loaded and running...
            Progress [I will seriously never be done!]
            Via EPIA MII
            512MB RAM
            OEM GPS (embedded)
            nLite WinXP pro on
            1GB Extreme III CF card
            Carnetix 1260 startup/ DC-DC regulator
            Software: Still, re-Writing my existing front end in .Net


            • #7
              @ Intelliworks

              I'm not so sure about that, I had the same problem with a serial mouse on com 1 or 2, the touch screen would use a higher emulated port.
              ....Yes, I know it has a stupid name, those crazy Japanese!