No announcement yet.

mpxplay and ess sound cards

  • Filter
  • Time
  • Show
Clear All
new posts

  • mpxplay and ess sound cards

    Does anyone that uses mpxplay use an onboard ESS sound controller? I have an Soyo motherboard (SY-5SSM) with built on audio and mpxplay won't detect my sound card.

    When I try 'mpxplay -sct 2' it just says cannot initiate ESS Soundcard (or something).

    Anyone have any suggestions or anything?
    95 Honda Civic DX Coupe - In Progress
    mp3civic site

  • #2
    install the dos drivers for your soundcard maybe?

    I have had no problems with an ess 688 and a 1688.
    The poster formerly known as bgoodman


    • #3
      I think you may have ESS Solo1 Sound card which been used on most motherboards with onboard sound. This sound card is only will work under windows evirement. It doesnt have DOS drivers and only way to get it working with mpxplay is to run the mpxplay from the windows.

      System Comp V3 - In progress.
      Low power MB with C7 CPU, DC-DC PSU, car ECU link, USB TV, GPS, 7" TFT, Wireless, Voice.


      • #4
        Originally posted by Fosgate:
        <STRONG>It doesnt have DOS drivers and only way to get it working with mpxplay is to run the mpxplay from the windows.</STRONG>

        I had the same troubles with Vibra 128's under DOS with MPXPLay, using windows dos box is fine, pure DOS.... no way!!
        Project - GAME OVER :(


        • #5
          Ya, you guys are right. It is a ESS Solo1 chip.

          It seems like there are drivers because when I execute a file called essolo.exe it does some stuff and tells me it's emulating an SBPro at 220 irq5 all that stuff. I guess that is just emulation eh?

          That sucks. So much for my quick boot up into DOS idea.

          Thanks for your help though.

          [ 07-12-2001: Message edited by: schrodos ]
          95 Honda Civic DX Coupe - In Progress
          mp3civic site


          • #6
            Hi schrodos,
            Go to MSDOS.SYS and change the line
            "BootGUI=1" to "BootGUI=0". This boots into Windows, but without the GUI. It boots to a DOS prompt, eventhough Windows is running. Then just add the appropriate commands to Autoexec.bat and Config.sys to initialize the sound card, and to run MPXPLAY with whatever commandline switches you use. I also have a Soyo MB, I think, but I definitely have an ESS sound chip, and there are no DOS drivers for it. That is why you need to run in Windows, just without the GUI.



            • #7
              mikep56: Man, you seem to have quite a few good answers up your sleeve.

              How long does it take to boot into DOS through windows? Is it just like booting windows but you get strictly a DOS prompt or is it fast like booting into DOS?

              The main reason I was doing DOS was because its fast... and then because mpxf is nice.
              95 Honda Civic DX Coupe - In Progress
              mp3civic site


              • #8
                Sorry to ruin the party, but puting "bootGUI=0" in MSDOS.SYS won´t really boot into Windows, it will boot into DOS only (Won´t execute So Windows drivers like Sound won´t be loaded. Maybe you can try with some sort of Sound Blaster DOS TSR compatible drivers. Works for some cards.
                I also know it exists a DOS driver for ESS sound cards, on my old job i had a Compaq Presario with that crap and it had a DOS driver.


                • #9
                  Try this:

                  Quote taken from the ESS FAQ Website:
                  "Q: Does my sound card support the pure DOS mode?

                  A: No. All ESS Technology sound cards do not support pure DOS mode. Pure DOS is called up when you boot your system to DOS 6.22 or Windows DOS 4.0 directly, instead of to the Windows desktop. "

                  Another Quote:

                  "Q: No sound under DOS using ESS Solo-1 sound chip?
                  A: Enable the PCI Delayed Transaction in your system's CMOS setup under Chipset Features Setup."

                  This one say it works (Aopen MB):


                  • #10
                    Quote from Jetway MB site:

                    "How did use J-530BF/J-530CF (Ess solo 1 sound chipset) mainboard onboard sound driver in dos mode?

                    Answer: You must install sound driver under Windows 95/98.
                    After you have successfully installed correspond driver for Windows 95/98, you don't need install any more driver for DOS mode if you are running DOS mode under Windows 95/98.
                    If you are running DOS mode before get into Windows 95/98, you need add following command for autoexec.bat and config.sys ( you still need install correspond driver for Windows 95/98).
                    Add "" in autoexec.bat
                    Add "device=c:\essolo.sys" in config.sys
                    Enable "PCI Delay Transaction" under CHIPSET FEATURES SETUP."


                    • #11
                      Hi MPT,
                      My mobo has integrated sound and video. The CD that came with it did not have DOS drivers on it. So I loaded W98, then loaded the Sound drivers from the CD, which need W98 to run. Then I modded MSDOS.SYS. I see the loading WINDOWS 98 message on screen before the splash screen, and then the C:\prompt, from where I run MPXPLAY, which is a DOS program. This is not in a DOS box, but in Windows COmmand Prompt mode, I believe. Please correct me if I am wrong.



                      • #12
                        Hi schrodos,
                        with about 400 songs in my playlist so far, from power on to music from the speakers is about 20-25 seconds.
                        it is booting Windows, but without the GUI, which takes a long time to load. This mobo with the ESS chip doesn't have DOS drivers on the CD, so you need to boot into Windows, you just don't need the GUI.