No announcement yet.

How to disable Win98 safe mode menu?

  • Filter
  • Time
  • Show
Clear All
new posts

  • How to disable Win98 safe mode menu?

    Does anyone know how to disable the menu that pops up when Win98 doesn't get a chance to fully load? If the power is cutoff while the OS is loading, you get the menu that says something like "Windows did not fully load on the previous boot, it is recommended that you start in safe mode". By default, Safe mode is selected.

    Is there a way to disable this menu so that Windows will boot into normal mode no matter what? I've already checked TweakUI but there doesn't seem to be a way to disable this from there.


  • #2
    Sorry for not answering earlier but I have been on vacation ...

    Here is what to do:
    Edit the c:\msdos.sys and make sure you have the folowing settings:


    It should do the trick.

    // Markus

    More information aboute the msdos.sys options....
    ================================================== ==================

    The [Options] section can contain the following settings and must be
    manually inserted:


    Default: 1

    Purpose: Defines whether or not ScanDisk is run after a bad shutdown.
    A setting of 0 does not run ScanDisk; 1 prompts before
    running ScanDisk; 2 does not prompt before running
    ScanDisk but prompts you before fixing errors if any
    errors are found.

    This setting is used only by OEM Service Release 2 and
    Windows 98.



    Default: 0

    Purpose: A setting of 1 enables the Startup menu. If this setting is 0,
    then you must press the F8 key when "Starting Windows 95"
    appears, (or press and hold the CTRL key when your Windows
    98-based computer restarts) to invoke the Startup menu.



    Default: 1 if the system is running correctly
    3 if the system hung in the previous instance

    Purpose: Use this setting to set the default menu item for startup.



    Default: 30

    Purpose: This setting is used to set the number of seconds your system
    will pause on the Startup menu. If the number of seconds counts
    down to 0 without intervention, the BootMenuDefault is activated.

    NOTE: This option is not functional unless BootMenu=1 has been added to
    the [Options] section of the Msdos.sys file.



    Default: 1

    Purpose: A setting of 0 disables the safe mode boot warning message and
    the Startup menu.


    • #3
      Hi Markus,

      I'm confused. I don't have either bootMenu or BootWarn in my MSDOS.sys but I still get the safe boot menu if Win 98 doesn't load properly.


      • #4
        Hello Kevin!

        If you don't have them just add those lines to the [Options] section. You won't mess anything up.

        Bootwarn=0 should make windows to never give a warning that Windows didn't boot as it should last time.

        Just tell me if you don't get it working and I'll show you a sample.

        [This message has been edited by markus (edited 04-28-2000).]


        • #5
          Worked great, Markus. Thanks a million!



          • #6
            Great =)
            I hope it works for Phacade GSX too...