Announcement

Collapse
No announcement yet.

Strange Compass/Xport behaviour

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange Compass/Xport behaviour

    Why is it that when I close down and restart, or reboot the PC that compass/xport doesnt work again untill I open and close the compass config page??

    Nothing is passed through untill i do this, from there everything works fine again.

    I can replicate this time and time again - hibernate no problems, comes back all fully working but reboot or shut off and restart, nada, no output, not untill i simply open and close the compass cfg page, then all the devices on the mapped ports can work.

    I can even see it on xport- no dot over com64 until the mandatory open and close is performed, as soon as thats done, up comes the dot on com64 and then I can run stuff. Ive tried other ports, no change.

    Via M10k, non-hacked XP pro, bu303.

    Any ideas please anyone?

    Thanks a lot

  • #2
    Oh that's odd! I know Xport is available before Compass starts, but if the GPS isn't ready yet it may not open either port, but it should retry every few seconds. There must be something missing there. One thing you could try is disable the auto-start and make a shortcut to it and put that shortcut in the Startup menu. That would make it start a little later.

    Comment


    • #3
      Hi Curiosity, thanks for the reply.

      Just been testing what you said and no change. Running from the startup folder (without autostart checked) still needs an open-close to begin the passthru process.

      Specifically its the close event that does it. eg I reboot with compass loaded (via startup or autostart) then run an app that uses an output port, nothing happens when I open compass cfg but as soon as I close the cfg page, com64 light comes on and then the light comes on com4 or 5 and the app starts to get the gps feed normally. Makes no difference which app I run.

      Setup
      com3 is the gps, set in compass
      com64 is the link to xport
      com4 navigator output
      com5 gatsohunter output

      Im not running any logs or hiding the cursor or anything else, just autostart is checked.


      Oddly enough, if I reboot without it loading on boot and then click on compass manually, it works straight away without open-close cfg (even if the gps mouse is not locked on any sats) .... just refuses to work from autostart or the startup folder.

      Thanks a lot for looking into this, if theres any more data or anything you need id be pleased to help.

      Comment


      • #4
        I think I've got a fix for it. Download compass again and try it out. One question though: Did you notice any info on compass while it wasn't connected to XPort? That would tell me which side wasn't working right.

        Comment


        • #5
          Tried new version, no change.

          Yes there is info, the systems on my bench so theres no speed or direction data but it spins the wheel once and registers the altitude figure as soon as it boots up.

          Here, they say a picture is worth a thousand words, heres an avi of it, excuse the bad autofocussing

          http://homepage.ntlworld.com/adspace/vid/comp.avi (4.1MB)

          hth

          Comment


          • #6
            That's definitely convincing video. It can't connect to XPort right at startup. Could be something in XPort, but not sure yet. I have one more idea with Compass for you to try. After that, I don't know. So anyway, download Compass again and give it a shot.

            Comment


            • #7
              I have a exactly the same problem although I have the latest version (prior to post #4). Instead of cold/re boot, the problem I have was coming out from hibernate.
              The same Xport/Compass version is running fine without a single problem in my Supra setup. In my Matrix, it only work 95% of the time out of hibernation. Open and Close Compass configure window brings it back to life. Consider 5 out of a 100 times I have to do it, I wouldn't bother checking to see problem with setup or the software.
              2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
              89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
              Y2K Accord Dell GX150
              RoadRunner is the best FE PERIOD
              EmoRebellion is a SCAMMER

              Comment


              • #8
                Nope, theres no change again - I am getting it from here yeah?

                http://curioustech.home.insightbb.com/compass.htm

                I've nothing else loading on startup, except zone alarm and ive tried it with that disabled. Im on XP Pro SP2 (OEM version), nothing attached to physical com ports, only usb items connected are the BU303 GPS and touchscreen.

                Ive just rebooted and left it sitting there- still no action after 25 minutes, still needs an open/close to run.

                Ive looked through my event logs and nothing seems amis, i noticed is that on compass cfg close SSDP Discovery Service starts up... its xp default is manual and making it automatic doesnt change anything, if theres anything I can try let me know.

                :edit: not yet noticed a problem in hibernation, that always seems to work

                Comment


                • #9
                  i'm trying to get this solution to work for my hibernation/standby gps resumption issues. Basically Compass connects ( can see signal data etc ), but the programs using the virtual ports refuse to see any data. Here are the steps i took.
                  Setup Xport2 to Input port 64, and output ports 8, 9, 10
                  I setup the compass to port 7 ( my gps port ).
                  I can now see data when i run compass
                  When i run hypertermail using any of the virtual ports..nothing....the appropriate radio button in xport2 does indicate its on..but nothing like that on the "input" com 64 radio box, and no nmea data from the gps device.

                  What else can it be?

                  Comment


                  • #10
                    Originally posted by Mad Ad
                    Nope, theres no change again - I am getting it from here yeah?

                    http://curioustech.home.insightbb.com/compass.htm
                    That's the right now. I think I need help. Try this new one and see what happens. I added a few error dialogs that should pop up if it doesn't open or doesn't find the settings. All of you are doing everything right, it's just not working right at startup for some reason. It could be because of everything going on during startup or resume. All the drivers are resetting and using lots of CPU or maybe some permissions aren't set yet. Not sure.

                    Comment


                    • #11
                      Nope - sorry to say no change still .... didnt see any error or dialogue boxes either

                      Comment


                      • #12
                        Wow. I was expecting something like "error opening xport com port" but nothing? This may take more time, but try downloading it again. I just added code to reopen everything about 5 seconds after it starts. It should work just like opening and closing the config dialog only you won't see anything.

                        Comment


                        • #13
                          Wow, thats a definate change, at least i know im getting from the right place, but the bad news is its now its totally broken

                          1) On reboot, the com64 light now blinks rather than stay off.
                          2) On cfg open/close it doesnt make the light go solid, it continues to blink.
                          3) It doesnt pass anything through at all, completely broken.
                          4) No errors, no popups, no dialogues. compass still reports altitude data.

                          Oh - if i close compass and start it again, then do the open/close, the light stays solid but its still not passing anything through.

                          I reverted back to yesterdays update and alls back to open/close and working so its nothing thats happened this end.

                          Comment


                          • #14
                            Oh, that's not what I wanted to do at all. It was reopening at about 10Hz. Sorry. Try it one more time.

                            Comment


                            • #15
                              Your a star!! now fixed- been giving it a good going over, restarts, cold boots, hibernate and suspend all work. Excellent stuff. Thank you for sorting that out


                              Now i have used it so much ive noticed it doesnt come on very early in the boot sequence, if I put an application that needs a port in the startup folder, it errors out needing a manual start when all the tray programs are fully initialised - even xport goes funny and loads without the service ticked, but everything is rectified once the desktop is up for 5 seconds or so... on un-hibernate there is no issues at all, instantly all works again.

                              Also another niggle while im here, if I right click the compass icon the menu appears- but if I dont choose anything, it wont close by clicking on the desktop- just stays open till somethings picked, or, i click on the compass wheel itself. Even right clicking the tray icon again doesnt close it.

                              Neither of these issues are show stoppers - just minor things I thought id mention, obviously ive noticed more than I would if Id just used it with the amount ive been testing, there are a couple of even less important things but I wont mention them incase you shout at me.

                              Im just very pleased that the main problem is fixed- that little X in the corner of the cfg page was a real hassle to get at on the touchscreen, thank you again for fixing it.

                              Comment

                              Working...
                              X