Announcement

Collapse
No announcement yet.

minlogon and now ACPI does not shutdown

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • minlogon and now ACPI does not shutdown

    After setting up minlogon when I press the power button, the system doesn't shut down.
    Nothing happens at all. The power options are set properly.
    I think I remember someone else mentioning this. I can't find the thread though. Has anyone else encountered/solved this?

  • #2
    Hey there,

    I've managed to bodge my hibernation but shutdown works fine, am working on the hibernation stuff at the moment .... I got recycle bin happy and removed one too many files!!!!!

    Comment


    • #3
      Yeah, this came up before on here and on the nLite forums. Not sure where it's coming from, but I think it's an nLite thing because myself and others have normal ACPI (power button as well as the different power modes) operation.
      EWF, HORM, MinLogon on XP.

      Zotac ION Atom N330, 2GB low-profile RAM, M3-ATX
      Win Embedded Std 2011 RC
      OCZ Vertex Turbo 30GB SSD
      Lilliput 629 Transflective, WRX Screen Mount
      BlueSoleil BT, i-Blue GM-2 GPS, DirectedHD Radio, Andrea Mic
      VoomPC 2

      Comment


      • #4
        I know what it could be ..... I chose auto detect in Nlite - not ACPI Compliant PC ... will try ACPI Compliant and see if that helps.

        Comment


        • #5
          where do you see that option in nlite?

          Comment


          • #6
            It was in the Unattended Install options ..... I always install unattended - means I can leave the machine installing and walk away for 20 mins, come back and its fully installed :-)

            Will do a test on my VMWare session and see what happens.

            Comment


            • #7
              hmm. Do you have the latest nlite. I'm using the latest and I don't see that option.

              Comment


              • #8
                Ok. I've narrowed down the problem to minlogon for sure.
                I put the winlogon registry entries back on top of the minlogon ones. Swapped winlogon files and rebooted. Now the acpi shutdown works.
                I put minlogon back(not deleting winlogon entries) and it doesn't work.
                There are registry entries about shutdown events in the winlogon registry hive, but not in the minlogon.
                It seems as though minlogon doesn't support the acpi shutdown.
                SFiorito, you said you have it working though right?
                Can you send me you exported registry settings from windowsnt\winlogon please? I want to compare ours.

                Comment


                • #9
                  This is all I used:

                  Code:
                  Windows Registry Editor Version 5.00
                  
                  [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
                  "Shell"="Explorer.exe"
                  "Config"=dword:00000017
                  "LsaStart"="%SystemRoot%\\system32\\lsass.exe"
                  "ServiceControllerStart"="%SystemRoot%\\system32\\services.exe"
                  "Userinit"="%windir%\\system32\\userinit.exe,"
                  "AutoRestartShell"=dword:00000001
                  @="mnmsrvc"
                  "allocatecdroms"="0"
                  "allocatedasd"="0"
                  "allocatefloppies"="0"
                  "cachedlogonscount"="10"
                  "forceunlocklogon"=dword:00000000
                  "passwordexpirywarning"=dword:0000000e
                  "scremoveoption"="0"
                  "UIHost"=hex(2):6c,00,6f,00,67,00,6f,00,6e,00,75,00,69,00,2e,00,65,00,78,00,65,00,00,00
                  Have you tried with that new thing I found yesterday where all you need to add is the Config key?
                  EWF, HORM, MinLogon on XP.

                  Zotac ION Atom N330, 2GB low-profile RAM, M3-ATX
                  Win Embedded Std 2011 RC
                  OCZ Vertex Turbo 30GB SSD
                  Lilliput 629 Transflective, WRX Screen Mount
                  BlueSoleil BT, i-Blue GM-2 GPS, DirectedHD Radio, Andrea Mic
                  VoomPC 2

                  Comment


                  • #10
                    K. I tried that. Minlogon works by just adding the config key. But my shutdown still doesn't.
                    There was a patched minlogon xpe component released by ms. I wonder if I have an old one. I tried the one somebody had zipped up and post here. That didn't work for me either. Can you PM me yours SFiorito? The actually minlogon.exe file please.

                    Comment


                    • #11
                      Something new. If I enable hibernation and tell it to hibernate when I press my power button(power options), it will hibernate.
                      So it is getting the ACPI signal. It's not a driver issue. Hibernate works, but for some reasone shutdown does not.
                      Anyone? This is my last problem and my OS will be complete.

                      Comment


                      • #12
                        I don't know, but I wonder if this is related to my problem: mine freezes when I try to shut down.

                        Comment


                        • #13
                          Doesn't seem related. Mine doesn't even try to shut down. No freezing or anything. It's as if I never pressed the button.
                          I read your thread. Yours sounds a little more serious.

                          Comment


                          • #14
                            OK. I'm definitely using the proper minlogon file now and it still doesn't work.
                            I'm getting ****ed!!

                            Comment


                            • #15
                              Is your BIOS set to shutdown after holding the button down for X seconds or just clicking it once? Try holding the button down until it starts shutting down.
                              EWF, HORM, MinLogon on XP.

                              Zotac ION Atom N330, 2GB low-profile RAM, M3-ATX
                              Win Embedded Std 2011 RC
                              OCZ Vertex Turbo 30GB SSD
                              Lilliput 629 Transflective, WRX Screen Mount
                              BlueSoleil BT, i-Blue GM-2 GPS, DirectedHD Radio, Andrea Mic
                              VoomPC 2

                              Comment

                              Working...
                              X