No announcement yet.

USB HD enclosure has to be removed and plugged back in?

  • Filter
  • Time
  • Show
Clear All
new posts

  • USB HD enclosure has to be removed and plugged back in?

    So I have my CF card for my OS drive. All is well. I bought a USB enclosure for my laptop drive. All my media is on there. Frodoplayer plays my media from it. Woohoo!!! When the drive is disconnected Frodoplayer doesn't explode. Whew!! That's a relief. Good job Frodo.

    There's just one problem. If I leave the drive connected and reboot the system(or shutdown and power back on), windows doesn't recognize the drive is connected and as a result, Frodoplayer can't play the songs. I have to unplug the drive, then plug it back in.
    Then I it tries to autoplay, then it asks me what to do when it finds this drive. I select "do nothing".
    Frodoplayer is loaded before this happens. Now the drive is connected, but frodoplayer still doesn't play files on it. I have to restart frodoplayer now.
    Now its all working.
    It does this every time. It's driving me bonkers. I can't just turn on my car and leave. I now have to wait to unplug and plug the drive back in and restart frodoplayer every time. What a pain!
    If I unplug the drive and plug it back in again after all that, it asks me what to do again! I have to select "do nothing" every time! I disabled autoplay for that drive too. No effect.

    Does anyone have any idea what's going on? Is it windows? Is it my eden? Perhaps a bios settings or something?

  • #2
    Try a different enclosure. I had the same problem with one of my enclosures, changing to another one helped.

    Alternately, it could be timing. I had an enclosure that would just take a long time to appear. Try an experiment, boot the computer and let it complete booting, then wait a whole minute.
    Chrysler 300 - Fabricating


    • #3
      Hey knubile,

      A couple of things in the bios to play with... Try enable/disable PnP OS and see if that helps, also reset the ESCD(sp?) configuration data... Turn off the fast bios boot switch when resetting the ESCD and take a look at your configuration data.

      In windows...Try deleting all the USB device entries including the usb hubs from the device manager. Reboot with your usb HD drive disconnected and let windows detect and install drivers for the USB system and your other USB devices. Install the latest version of the the USB drivers (if available) for your HD before connecting it to the USB port. Connect the drive and hopefully the problem goes away. If you plugged in your drive before installing the drivers chances are windows installed what it though was the correct driver...

      I've had problems like this before with my old digicam and printer, and the driver version turned out to be the problem.

      Good luck and nice job with your setup.

      Carputer installed!!!
      Nlited XP+Minlogon, EpiaM10k, 512mb, Seagate 40 gig 2.5" HD, FM Dlink usb radio, DWL122 USB Wifi, XMD1000 tuner, PT5071 6 amp regulator, Xenarc 700TSV, and 1 ikea key box.


      • #4
        I'm using an nlited xp install, so I had to install all the drivers myself. I installed the ones for my eden board, so I really doubt its the drivers.
        I'll try all those bios settings and hopefully find a friend I can borrow an enclosure from. Actually I'll try it with my USB key too.

        Thanks for the tips. I'll post the results.


        • #5
          What is your progress report on this Knubile?


          • #6
            problem solved 1 minute ago!
            See this thread.