Announcement

Collapse
No announcement yet.

Bugs Wanted

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bugs Wanted

    ok.. I'm going to put a side a day or so for bug fixing. Please post below any bugs found in the 0.80 and above versions. I will then at least have a list to go at and make sure all of them are sorted for the 0.90 public release


    so far -

    Crashing just before destination - Fixed
    SDK command "toggleview", wrong way round and grabbing focus - still to do
    Loading incorrect skin on starting - Fixed
    Scroll bar on POI - still to do
    Cancel route via SDK - need to check
    Not clearing variables when route finished - need to do

    cheers guys

    CdR
    Follow me on Twitter

    http://www.FreeICE.co.uk

  • #2
    the only one i got is in .90 alpa 1
    when its about to say "you have arrived" FD crashes

    i know u already know this one.. but just reminding you
    View My Blog


    Click for 2GB FREE on-line storage!

    Comment


    • #3
      SDK:
      - SDK info text file says SDK command is "toggleview" but in fact implemented SDK command is called "viewtoggle"
      - calling "viewtoggle" SDK command from basically any application causes Freedrive (maybe its D3 SDK - God knows) to grab keyboard focus and thus host application loses it untill you press Alt-Tab.

      in any case, thank you for your time you spend on FD and patience...

      Comment


      • #4
        Day/Night Skin

        Where it starts with the opposite skin and you have to toggle to get in sync.

        Looking forward to the release, thank you

        kth

        Comment


        • #5
          Originally posted by whodwho
          Where it starts with the opposite skin and you have to toggle to get in sync.

          Looking forward to the release, thank you

          kth
          I have just had a play.. started it up in day mode, switched to night then shut FD down, started it up again and it started in night mode. Are you using the menu in FD or a sdk command ?

          cheers

          CdR
          Follow me on Twitter

          http://www.FreeICE.co.uk

          Comment


          • #7
            Originally posted by Enforcer
            Cancel route command in SDK doesn't work.

            Scroll bar on POI screen please.
            to clear (cancel) a route via sdk.. "clear" should work.. "cancel" just returns FD to the main screen.

            Will look at the POI bar..

            ta

            CdR
            Follow me on Twitter

            http://www.FreeICE.co.uk

            Comment


            • #8
              Originally posted by CdRsKuLL
              to clear (cancel) a route via sdk.. "clear" should work.. "cancel" just returns FD to the main screen.

              Will look at the POI bar..

              ta

              CdR

              Will try that, cheers

              Comment


              • #9
                Originally posted by CdRsKuLL
                I have just had a play.. started it up in day mode, switched to night then shut FD down, started it up again and it started in night mode. Are you using the menu in FD or a sdk command ?
                This is just calling up FreeDrive.exe and the menu with no frontend. The modes work correctly but when the which ever mode loads it call the opposite skin. If you don't have a different day/night skin, edit the day-off.jpg with a D and the night-off.jpg with a N. when the day mode loads it will have a N, when you switch to night it still will, when you switch back to day it will have a D.

                Hope I didn't confuse it more...

                Thanks again
                Attached Files

                Comment


                • #10
                  One thing I've noticed ..... traffic light cams sometimes alert after the camera - I'll see if I can work out what is going on for you.

                  Comment


                  • #11
                    Originally posted by Gobby
                    One thing I've noticed ..... traffic light cams sometimes alert after the camera - I'll see if I can work out what is going on for you.
                    you're driving too fast through them.

                    I mean you are supposed to at least slow down for red lights, some people have even been known to stop for them.

                    Comment


                    • #12
                      Originally posted by whodwho
                      This is just calling up FreeDrive.exe and the menu with no frontend. The modes work correctly but when the which ever mode loads it call the opposite skin. If you don't have a different day/night skin, edit the day-off.jpg with a D and the night-off.jpg with a N. when the day mode loads it will have a N, when you switch to night it still will, when you switch back to day it will have a D.

                      Hope I didn't confuse it more...

                      Thanks again
                      ok think I understand you know.. its changing the font colour, but not loading the correct background. Will have a play

                      CdR
                      Follow me on Twitter

                      http://www.FreeICE.co.uk

                      Comment


                      • #13
                        Originally posted by Enforcer
                        you're driving too fast through them.

                        I mean you are supposed to at least slow down for red lights, some people have even been known to stop for them.

                        Ahhh ... thats what I'm doing wrong!

                        Comment


                        • #14
                          Is there a posebility to add a button to resett the speedcamera direction, and get a descripton on what button to hit if you are driving towards the camera. So others like me dont get confused.
                          Hope you understod what I was writing. You are the one...

                          Comment


                          • #15
                            Because I split the GPS signal, I run Freedrive as an external GPS program and let RR use the GPS feed directly through the mappoint settings in RR Config. Ever since I started using this method, FreeDrive doesn't embed properly. I know its something simple but here's an excerpt of my rr.ini:

                            launchpath=C:\Program Files\Road Runner\LAUNCH\
                            winamppath=C:\Program Files\Winamp\
                            skinpath=C:\Program Files\Road Runner\Skins\zots.new\
                            nightskin=C:\Program Files\Road Runner\Skins\zots.new\
                            mpcpath=C:\Program Files\Road Runner\mplayerc.exe
                            screentype=4:3
                            videoautohide=false
                            videohidetime=4
                            videofiles=.avi, .mpg, .mpeg, .wmv, .mov , .mpe, m3u
                            audiofiles=.mp3, .wma, .wmv, .wav, .mpeg, .mpg , .mpe, .cda, m3u
                            speedatt=true
                            speedattmute=true
                            speedattunit=mph
                            speedattgrad=80
                            speedattvola=20
                            speedattvolb=100
                            speedattspeeda=0
                            speedattspeedb=70
                            speedattmode=line
                            speedattvolzero=70
                            speedattvolgainat50mph=10
                            speedattmaxstep=10
                            speedattvolzero=70
                            mapmonkeypath=C:\DestinatorApps\Map Monkey\MapMonkey.exe
                            gpspath=C:\Program Files\FreeDrive\FreeDrive.exe
                            gpsname=FreeDrive
                            exitmode=4
                            showicons=true
                            showextensions=false



                            Also would it be possible to get the current city as a new label when you update the SDK?

                            Lastly, And please take no offense, but I would like an easier method to execute saved routes using the destinator favorites. Right now I have to do the following:
                            Menu
                            Next
                            POI
                            Item
                            Tools
                            Favorites
                            Cancel
                            Categories

                            Then I can select the category and item I have saved for routing. Is there an easier way to accomplish this other than copying everything from my separate categories into your one "My Favorites" folder?

                            P.S. I think I mentioned a few months back that your "My Favorites" and destinator's are confusingly separate files.
                            HARDWARE: Fujitsu Stylistic ST5111w/WiFi and dock, internal Hitachi 500G HD, external 1TB HD, Sierra Wireless Aircard 550, DVD-RW, BoomzBox HD radio, XM Commander, Delorme GPS, Saitek X-52 Pro joystick, BluSoleil Bluetooth, TPMS, FB, Elm327

                            Comment

                            Working...
                            X