Announcement

Collapse
No announcement yet.

Upload Sync Issue???

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upload Sync Issue???

    Hey,

    Been doing a backup upload of the car the past couple of days and have noticed that whenever I interrupt the transmission, the file that was partially uploaded gets shown on the home machine half done. Then, when I continue the upload sync, it'll go to the next file and not finish the file that has been partially syncing. Thats the problem.

    When mirroring the home computer this problem does not appear, atleast i have not experienced this same scenario under mirroring.
    Mark

    Website: http://www.greenpowerenthusiast.com/

    Car'Puter Project
    - Xenarc 700TSV
    - MSI RS482M-IL Mobo + AMD Turion MT-32 (25W)
    - 1x 256MB Corsair XMMS DDR400
    - M2-ATX
    - Belkin 802.11G W-Nic
    - Garmin 15H GPS
    - WinXP SP2 (NLited)

  • #2
    Originally posted by DaRacerz
    Hey,

    Been doing a backup upload of the car the past couple of days and have noticed that whenever I interrupt the transmission, the file that was partially uploaded gets shown on the home machine half done. Then, when I continue the upload sync, it'll go to the next file and not finish the file that has been partially syncing. Thats the problem.

    When mirroring the home computer this problem does not appear, atleast i have not experienced this same scenario under mirroring.
    Thanks for this - I can see the cause of the problem.

    When you interrupt the sync, this results in the TCP connection getting broken. The code on the home PC side that executes when an individual file is completed also executes when the sync of an individual file is stopped half way through. This code renames the temporary file to be the actual filename. Hence you end up with a partially synced file in place.

    As I'm sure you've already found out, workaround is to delete the last file synced so that next time it will be sent again as the first file in the sync.

    I'll work on a fix.

    Ric.
    EZSync - http://www.richmet.com/ezsync

    Comment


    • #3
      This one is now fixed, and will be in the next release.
      EZSync - http://www.richmet.com/ezsync

      Comment


      • #4
        nice, thx for the fix.
        Mark

        Website: http://www.greenpowerenthusiast.com/

        Car'Puter Project
        - Xenarc 700TSV
        - MSI RS482M-IL Mobo + AMD Turion MT-32 (25W)
        - 1x 256MB Corsair XMMS DDR400
        - M2-ATX
        - Belkin 802.11G W-Nic
        - Garmin 15H GPS
        - WinXP SP2 (NLited)

        Comment

        Working...
        X