Announcement

Collapse
No announcement yet.

EZSync Server Addtion Request

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • EZSync Server Addtion Request

    Hi

    Have been using this software for a while and it is has been most usefull. Was going to do updates by windows remote but this is much easyer.

    There are a couple of suggestions I do have:

    1) Would it be possible to make the Server side not pop up when Sync is accuring. This feature is avalible on the Client but not the server. (It can be quite anoying when my GF drives the car into the drive and the server pops up in front of my work)

    2) Ive noticed that when syncing by mirroring, if a whole dir tree is deleted, only the files are removed form the client end. The dir structure is left the same: could this be sorted as to remove the unwanted dir?

    Ta

    Quenchmaster
    Quenchmaster
    -----------------------------------------------
    CarPC

    Current Project 1: Advanced Startup/Shutdown controler V2 - Using Atmel AVR
    Current Project 2: Kenwood IR remote Decoder
    Current Project 3: Kenwood Disk Changer Controler

  • #2
    Originally posted by quenchmaster
    Hi

    Have been using this software for a while and it is has been most usefull. Was going to do updates by windows remote but this is much easyer.

    There are a couple of suggestions I do have:

    1) Would it be possible to make the Server side not pop up when Sync is accuring. This feature is avalible on the Client but not the server. (It can be quite anoying when my GF drives the car into the drive and the server pops up in front of my work)

    2) Ive noticed that when syncing by mirroring, if a whole dir tree is deleted, only the files are removed form the client end. The dir structure is left the same: could this be sorted as to remove the unwanted dir?

    Ta

    Quenchmaster
    For (1) I'm fairly sure I implemented this for both client and server at the same time. Have you tried putting the same ini file entry in on the server side? Might be that I didn't document both. If it doesn't work I'll definitely sort it out. I'm at work at the moment so can't check.

    For (2) I've already had a request for this and have already developed it.

    I planned to do a release a week ago but haven't had time to do enough pre-release testing. I'll get it out as soon as I can.

    Richard.
    EZSync - http://www.richmet.com/ezsync

    Comment


    • #3
      Originally posted by ric355
      For (1) I'm fairly sure I implemented this for both client and server at the same time. Have you tried putting the same ini file entry in on the server side? Might be that I didn't document both. If it doesn't work I'll definitely sort it out. I'm at work at the moment so can't check.
      I put the "ShowOnConnect=0" line into the server ini and it worked - so its there but just not documented. I hadnt tried it before as I though it might screw up the application.

      I have found one slight bug - im not sure what does it and maybe you already know. Some times the buttons on the application are not visable - its not possible to exit or do anything else.
      Quenchmaster
      -----------------------------------------------
      CarPC

      Current Project 1: Advanced Startup/Shutdown controler V2 - Using Atmel AVR
      Current Project 2: Kenwood IR remote Decoder
      Current Project 3: Kenwood Disk Changer Controler

      Comment


      • #4
        Originally posted by quenchmaster
        I have found one slight bug - im not sure what does it and maybe you already know. Some times the buttons on the application are not visable - its not possible to exit or do anything else.
        I have seen that before but only as part of my development. It happens if there's some kind of failure during initialisation of the application. Server or Client?
        EZSync - http://www.richmet.com/ezsync

        Comment


        • #5
          I get this problem pretty frequently too. On the SERVER side.



          Originally posted by quenchmaster
          I have found one slight bug - im not sure what does it and maybe you already know. Some times the buttons on the application are not visable - its not possible to exit or do anything else.
          2002 Honda CR-V
          Carputer progress: 90% [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ -]
          Spent so far: $1105.90


          Download the NEXUS Skin for Centrafuse
          ...or even Listen to my music

          Comment


          • #6
            Originally posted by justintime
            I get this problem pretty frequently too. On the SERVER side.
            Post your server side .ini file and I'll see if I can reproduce it. Let me know which version you're running also.
            EZSync - http://www.richmet.com/ezsync

            Comment


            • #7
              Im running latest version 1.92

              Server ini is attached!


              Originally posted by ric355
              Post your server side .ini file and I'll see if I can reproduce it. Let me know which version you're running also.
              Attached Files
              2002 Honda CR-V
              Carputer progress: 90% [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ -]
              Spent so far: $1105.90


              Download the NEXUS Skin for Centrafuse
              ...or even Listen to my music

              Comment


              • #8
                Will we see something newer than 1.92, that can properly handle deletion of FOLDERS as well as files?

                Also, quick questions.... does this app only compare file names? If for example I re-tag an old/existing mp3 file with new ID3 tags, will EZsync realize there has been a change, and synch the file?

                I love this utility, keep it up

                EDIT: Sorry, I just read a few posts above that you are developing a fix for this. Would still like to know about the syncing of modified files...
                2002 Honda CR-V
                Carputer progress: 90% [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ -]
                Spent so far: $1105.90


                Download the NEXUS Skin for Centrafuse
                ...or even Listen to my music

                Comment


                • #9
                  Originally posted by justintime
                  Would still like to know about the syncing of modified files...
                  It syncs on the last modified date/time, so if you change the ID3 tags it'll be retransmitted.
                  EZSync - http://www.richmet.com/ezsync

                  Comment


                  • #10
                    Awesome. That's just perfect!
                    Thanks a ton.


                    Originally posted by ric355
                    It syncs on the last modified date/time, so if you change the ID3 tags it'll be retransmitted.
                    2002 Honda CR-V
                    Carputer progress: 90% [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ -]
                    Spent so far: $1105.90


                    Download the NEXUS Skin for Centrafuse
                    ...or even Listen to my music

                    Comment


                    • #11
                      Originally posted by quenchmaster
                      I put the "ShowOnConnect=0" line into the server ini and it worked - so its there but just not documented.
                      Well it worked once but dosnt anymore since i rebooted - the server app still pops up.
                      Quenchmaster
                      -----------------------------------------------
                      CarPC

                      Current Project 1: Advanced Startup/Shutdown controler V2 - Using Atmel AVR
                      Current Project 2: Kenwood IR remote Decoder
                      Current Project 3: Kenwood Disk Changer Controler

                      Comment


                      • #12
                        I was wondering about that myself. I tried your 'fix' it and never did get it to work!

                        Originally posted by quenchmaster
                        Well it worked once but dosnt anymore since i rebooted - the server app still pops up.
                        2002 Honda CR-V
                        Carputer progress: 90% [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ -]
                        Spent so far: $1105.90


                        Download the NEXUS Skin for Centrafuse
                        ...or even Listen to my music

                        Comment


                        • #13
                          Originally posted by justintime
                          I was wondering about that myself. I tried your 'fix' it and never did get it to work!

                          This could be your problem - check the ini file settings thread; there are two ini file settings relating to this - ShowOnConnect and StartMinimized. Set the latter to 1, assuming you've already set the former to zero. StartMinimized defaults to off, so when you reboot and the application is loaded, it shows the main window.

                          Ric.

                          ps sorry I accidentally edited your post instead of quoting it !
                          EZSync - http://www.richmet.com/ezsync

                          Comment


                          • #14
                            Well, that's not it... look at my settings:

                            [Config]
                            InitialDir=D:\General Programs\EZSync\
                            TempInputFile=D:\General Programs\EZSync\tempin.dat
                            StartMinimized=1
                            ExtraUpgradeFilesInstalled=1
                            ClientInstallDrive=P:
                            ShowOnConnect=0

                            Originally posted by ric355
                            This could be your problem - check the ini file settings thread; there are two ini file settings relating to this - ShowOnConnect and StartMinimized. Set the latter to 1, assuming you've already set the former to zero. StartMinimized defaults to off, so when you reboot and the application is loaded, it shows the main window.

                            Ric.

                            ps sorry I accidentally edited your post instead of quoting it !
                            2002 Honda CR-V
                            Carputer progress: 90% [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ -]
                            Spent so far: $1105.90


                            Download the NEXUS Skin for Centrafuse
                            ...or even Listen to my music

                            Comment


                            • #15
                              Right, I've fixed the problem of the server always popping up. It needed a code change (despite me thinking I'd implemented it, I actually hadn't - that's why it wasn't documented... ).

                              During investigating that, I also reproduced the problem of the buttons not being visible. It does it if you;
                              - Start the server, with start minimized enabled.
                              - Sync without ever double clicking the server's tray icon.
                              When you do this, the server pops up on sync, and the list boxes and buttons all disappear - seemingly after the sync.

                              If you open the server window first, it doesn't do it.

                              Still trying to find out what's wrong...

                              Ric.
                              EZSync - http://www.richmet.com/ezsync

                              Comment

                              Working...
                              X