Announcement

Collapse
No announcement yet.

Help - no background shown

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help - no background shown

    I have installed PhoneControl onto a laptop with a 1400 x 1050.
    For some reason it refuses to show a background, all other icons show ok.

    If I open the designer software it still doesn't show the background, just a series of evenly spaced dots with a white background.

    I have tried using the standard skin but still no background.

    Any suggestions ?

    Thanks in advance for your assistance.

  • #2
    Try to open the background images with IE (or Windows preview). If they don't show up there, the files might be corrupt.
    Skinning to go... VisualDesigner2!

    Comment


    • #3
      The images preview/open fine.

      In the designer it shown the image in the left hand detail pane but not on the background on the left where the buttons etc are.

      Comment


      • #4
        Reinstall .NET framework
        Skinning to go... VisualDesigner2!

        Comment


        • #5
          I have uninstalled, rebooted and re-installed .NET v1.1.
          I then ran Windows update and it downloaded SP1 for .NET.

          It still doesn't work.

          I have also uninstalled/re-installed PhoneControl.

          The only problem I had was that I didn't install Directx before I installed PhoneControl. When I realised this I installed it and then uninstalled/re-installed PhoneControl.

          It works fine on my other XP laptop (Different model/spec), any suggestions ?

          Thanks - Paul

          Comment


          • #6
            Maybe it has something to do with you video card driver. Try a default Windows driver...
            Skinning to go... VisualDesigner2!

            Comment


            • #7
              I have tried a Microsoft driver and a ATI driver, it still doesn't work.

              The strange thing is that in PhoneDesigner, if I change the background image it shows it in the very small rectange next to 'BackgroundImage' in the right-hand pane but the main window on the left and the preview at the bottom right just show a white background.

              Any other suggestions as I'm tearing my hair out ?

              What s/w needs to be installed for PhoneDesigner to work ?

              Comment


              • #8
                Take a look at the Phonctllog.txt if it contains an error message according to the background image.

                All you need to run PhoCo or the Designer is enclosed in the setup package.

                BTW: The preview window does a screenshot of the form. So if it's displayed there, it must be in the memory.
                Skinning to go... VisualDesigner2!

                Comment


                • #9
                  Good suggestion:- (Extract from file)
                  The PhoneCtl.PB.xml file is definately there !


                  21/12/2004 11:09:11 COM: <0,42

                  OK

                  ----------------------------------------------------------------------------
                  21/12/2004 11:09:12 Error in LoadPhonebook: PhoneCtl.PB.xml
                  System.IO.FileNotFoundException: Could not find file "C:\Program Files\PhoneControl\PhoneCtl.PB.xml".
                  File name: "C:\Program Files\PhoneControl\PhoneCtl.PB.xml"
                  at System.IO.__Error.WinIOError(Int32 errorCode, String str)
                  at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean useAsync, String msgPath, Boolean bFromProxy)
                  at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
                  at System.Xml.XmlDownloadManager.GetStream(Uri uri, ICredentials credentials)
                  at System.Xml.XmlUrlResolver.GetEntity(Uri absoluteUri, String role, Type ofObjectToReturn)
                  at System.Xml.XmlTextReader.CreateScanner()
                  at System.Xml.XmlTextReader.Init()
                  at System.Xml.XmlTextReader.Read()
                  at System.Xml.XmlValidatingReader.ReadWithCollectText Token()
                  at System.Xml.XmlValidatingReader.Read()
                  at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
                  at System.Xml.XmlDocument.Load(XmlReader reader)
                  at System.Xml.XmlDataDocument.Load(XmlReader reader)
                  at System.Xml.XmlDocument.Load(String filename)
                  at System.Xml.XmlDataDocument.Load(String filename)
                  at PhoneCtl.NET.frmMain.LoadPhonebook(Int32 pi_iPBIndex)
                  ----------------------------------------------------------------------------
                  21/12/2004 11:09:12 COM: >AT+CPBS="ME"

                  Comment


                  • #10
                    It might be damaged.

                    But this has nothing to do with the background picture.
                    Skinning to go... VisualDesigner2!

                    Comment


                    • #11
                      OK.

                      I have removed .NET and PhoneControl,
                      rebooted,
                      re-installed .NET
                      rebooted
                      Run windows update to install .NET SP1
                      rebooted
                      Installed PhoneControl

                      Same problem.
                      I have noticed that the minimise/exit buttons are missing in Phone Control and also in Designer the small grey drop-down arrow next to the Background image properties is missing, instead there is a small square black box.

                      I have also change permissions on all folders to ensure it is not a rights issue.

                      The error in the log file has gone now that I have re-installed.


                      Any other suggestions as I would really like to get this working ?

                      Thanks - Paul

                      Comment


                      • #12
                        Paul, this sounds very strange. The images in PhoCo are one thing but the dropdown arrows belong to the system and will be drawn by system itself.

                        I'm still not sure whether your graphics card driver sucks or not. If you have to chance, you should try to run PhoCo on another machine (with another graphics card) or at least on one with a different driver version.
                        Skinning to go... VisualDesigner2!

                        Comment


                        • #13
                          It works ok on my other P4 XP laptop.

                          I don't experience any problems with graphics in any other Windows software and can happily play DVD's.

                          One strange thing is that when you open PhoneDesigner it shows a small preview of your desktop in the Background image area at the bottom left. This is displayed correctly. As soon as I open an existing PhoneControl image it changes to a white background.

                          Hope that helps.

                          I am more than willing to test anything you can suggest, even a small program you create if required.

                          I have been putting off XP SP2 but could try that if you think it may help ?

                          I can also send you a screen shot by e-mail if that will help to explain what I am seeing.

                          Comment

                          Working...
                          X