No announcement yet.

Error-Dialog on Startup

  • Filter
  • Time
  • Show
Clear All
new posts

  • Error-Dialog on Startup

    In some cases, after the very first start of PhoCo you may get an error dialog as shown in the picture below.
    This message is thrown by the .NET runtime. This is no PhoCo Bug!
    Rather it's something on your machine that is missing or broken.
    Unfortunatelly, it doesn't say much about where the error is located. To get rid of this dialog, do the following:

    o Check your installation for the required components
    - Windows 2000 or Windows XP Professional (SP1/SP2)
    - .NET Framework 1.1
    - DirectX 9.0c
    - SAPI (on Win2K)

    o Let Windows-Update check your installation
    -see Post (

    o Check whether your sound card is running
    - see post (

    o Don't use it on crippled systems!
    - Systems drilled down with nLite (or something similar)
    - Systems with disabled "Performance counters" (

    o For gods sake, read the posts in this forum
    - Use search (try "install, error" or "windows update")
    - It's not getting better to post the same **** in various threads

    Once again, PhoCo ist tested by myself on 4 different Machines with different configurations (W2K, XP Home, Pro). One of the tests is making a fresh install and let PhoCo run.

    It also runs on more than 200 machines (that are the ones that I know, it's been downloaded over 11.000 times). So please don't tell me that this is a common failure.

    If it's not running on your PC, stop complaining and check your installation.
    Attached Files
    Skinning to go... VisualDesigner2!

  • #2
    Does it really require the entire 230meg+ DX9 SDK? Or just the runtime?
    1998 BMW M3
    Mods: Staggered SSR Competition wheels : M Roadster Short Shifter : JTD Aluminum Underpanel : Koni Adjustable SAs : Eibach Pro-kit springs : European clear corners and side markers : Hardwired V1 automatic door and radar detector


    • #3
      You need just the runtime.
      Skinning to go... VisualDesigner2!


      • #4

        I have done everything and i cant figure this out...

        I have directx 9.0c and i downloaded the sdk and tried that...
        I have a normal install of xp home sp2
        i have .net framwork 1.1 and updates and have tried 2.0
        i have no other problems with any other aplications
        my sound card works fine
        i have every update for windows there is at this current time
        i have searched almost every topic availible on phoco on this forum and in forums... I cant get any help or anymore ideas...

        is it because i have a via sp13000 board and im using onboard video? i heard someone say that this boards video isnt dX9 compatible...

        and if thats the case will dX8 work with the new version of phoco?

        Can anyone think of a reason why i would still get this error...

        PLEASE HELP....


        • #5
          Fix in my case was setting the "Disable Performance Counters" value to 0 under the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\PerfProc\Performance key in the registry


          • #6
            here's another method that fixed the issue for me. You need an older tested working version of the software though

            -Install 1.6
            -copy the folder
            -delete 1.6
            -install old tested version ( i used 1.45 i think)
            -copy contents of the phoco 1.6 folder on top of 1.45

            Done.. no more error
   Senior Tech Blogger (Want a product reviewed? Contact me.)
            Follow Me on Twitter or Facebook
            Live mp3Car Facebook Chat