No announcement yet.

at+.... commands in phonecontrol for cdma

  • Filter
  • Time
  • Show
Clear All
new posts

  • at+.... commands in phonecontrol for cdma

    does anyone know how to edit multiple AT commands for phonecontrol? i can get my phone to perform how i want it to from hyperterminal, but since i'm not a programmer, i don't know how to make phonecontrol read multiple lines of AT commands at once to perform a single function. i checked out this post on his forums:, but i still don't get it. can someone help a n00b out?

  • #2
    for example to check my phonebook, my phone needs to be set to mode 2, so it needs to see

    then it needs to look for the phonebook

    this will make it look for entries 1-100, but without it set to mode 2 first, it won't look for the phonebook. if anyone knows how to enable thisin phonecontrol, or where to edit it, let me know. i already edited the phonectl.config file and it doesn't work


    • #3
      I guess you're talking about the v710.

      The only way yet is to alter the <PBRead> command, which is supposed to be +MPBR and change it to +MODE=2;+MPBR.

      This at least will help you to switch into the mode, but not to switch back (which I suppose is needed to work properly). Therfore I would have to extend PhoCo to have a "Switchback" command as well.
      Skinning to go... VisualDesigner2!


      • #4
        the mode=2 uses "+MBAN" i guess this is a motorola system. when you connect the phone it uses mode 0 for info like tower #'s, signal strength, battery life. but mode 2 is for accessing the phonebook and has to be switched to make a call. you can't successfully dial a call from mode 0, it has to be in mode 2, dials the number, then switches back to mode 0. maybe this is why phonecontrol doesn't work with this phone.


        • #5
          used the cscs, cnmi, clip, and crc in mode 0, no go...used in mode 2, works like a charm. this has commands that can be accessed in mode 2 first, that's why it's not working. just looked in the phoneco log, and i'm getting errors for these codes. so i think it needs to switch back and forth for certain codes.


          • #6
            22:17:08,01 --> AT+MODE=2<CR>
            22:17:08,06 Wait...
            22:17:08,15 <-- OK
            22:17:08,17 <-- +MBAN: Copyright 2000-2004 Motorola, Inc.
            22:17:08,21 Wait...
            22:17:08,82 --> ATE0<CR>
            22:17:08,95 <-- ATE0
            22:17:08,96 <-- OK
            22:17:09,10 --> AT+CSCS="UCS2"<CR>
            22:17:09,23 <-- OK
            22:17:09,31 --> AT+CSCS?<CR>
            22:17:09,43 <-- +CSCS: "UCS2"
            22:17:09,45 <-- OK
            22:17:09,56 --> AT+CPBS="AD"<CR>
            22:17:09,71 <-- OK
            22:17:09,76 --> AT+MPBR=1,15<CR>

            this is the command to access the phonebook, i used mpt to get the modem log file.


            • #7
              this is the initial startup, goes to mode 2,

              22:15:56,65 --> AT+MODE=2<CR>
              22:15:56,73 Wait...
              22:15:56,81 <-- OK
              22:15:56,82 <-- +MBAN: Copyright 2000-2004 Motorola, Inc.
              22:15:57,93 Wait...
              22:15:58,57 --> ATE0<CR>
              22:15:58,71 <-- ATE0
              22:15:58,73 <-- OK

              assigns the phonebook, checks it.
              22:15:58,96 --> AT+CPBS="ME"<CR>
              22:15:59,04 <-- OK
              22:15:59,12 --> AT+CPBR=?<CR>
              22:15:59,26 <-- +CPBR: (1-500),32,24
              22:15:59,28 <-- OK

              looks at the internal phone firmware, yadda yadda
              22:15:59,39 --> AT+GMI;+GMM;+GMR;+CGSN<CR>
              22:15:59,53 <-- +GMI: "Motorola CE, Copyright 2000"
              22:15:59,54 <-- +GMM: "CDMA800","CDMA1900","AMPS800","MODEL=V710"
              22:15:59,56 <-- +GMR: "8700_01.02.SD"
              22:15:59,57 <-- +CGSN: ESN********
              22:15:59,59 <-- OK
              22:15:59,64 Wait...
              22:16:00,28 --> AT+CNUM?<CR>
              22:16:00,42 <-- +CNUM: ,********,
              22:16:00,43 <-- OK

              sms message status
              22:16:00,48 --> AT+CPMS="MT"<CR>
              22:16:00,62 <-- +CPMS: 3,1000
              22:16:00,64 <-- OK
              22:16:00,75 --> AT+CPMS="IM"<CR>
              22:16:00,89 <-- +CPMS: 2,250
              22:16:00,90 <-- OK

              then sets itself back to mode 0
              22:16:00,95 --> AT+MODE=0<CR>
              22:16:01,09 <-- OK


              • #8
                So what functions are to be run in mode 0 and what functions in mode 2 (seen from PhoCo)?
                Skinning to go... VisualDesigner2!


                • #9
                  the post above yours is what happens in order (minus the "answers" to the querys). the phone checks itself in the order of the modes above. starts up to mode 2, checks the phonebook in mode 2, checks internal info in mode 2, sms message in mode 2, pretty much everything is in mode 2.

                  periodically it'll post this:
                  22:16:16,29 #### Testing mobile state...
                  22:16:16,37 --> AT+MODE=0<CR>
                  22:16:16,53 <-- OK
                  22:16:16,57 --> ATE0<CR>
                  22:16:16,67 <-- OK
                  22:16:16,84 --> AT+CSQ?;+CBC?<CR>
                  22:16:17,00 <-- +CSQ: 27, 99
                  22:16:17,01 <-- +CBC: 1,100
                  22:16:17,03 <-- OK
                  22:16:17,26 --> AT+CSS?<CR>
                  22:16:17,42 <-- +CSS: ?, 119
                  22:16:17,43 <-- OK

                  actually, looking through the modem log, it checks the mobile state quite often, every few seconds(mode=0).

                  so i think the check for the mobile state is the only thing in mode 0.


                  • #10

                    I was just getting into PhoCo prior to the end of March (Glad to see you back Zorro). I hadn't even started with BT implementation on my Carputer as I know it is a bit fussy and I wanted to keep things clean for when I did. I was going to wait to install since there was no point without PhoCo (except for BT keyboard). Did you install MPT, or are you simply using WidComm4? I have the TrendNet BT101 which is natively supported by WidComm. What PhoneControl setup string are you using? I was considering playing with it, but I though I'd ask for you input first. I too have a 710 and would very much like to use & buy PhoCo. Zorro and I were just starting to whack away at it.

                    @Zorro... Good on you for helping with the 710. I was hoping you might, but I wanted to respect your position with regard to CDMA.

                    If I can help you both in ANYWAY. Please don't hesitate to ask. I am more than ready (eager) to purchase PhoCo.


                    • #11
                      OK, did you try to setup +MODE=2 in AdditionalInit of the config?

                      If so, please send me the PhoCo log.
                      Skinning to go... VisualDesigner2!


                      • #12
                        Originally posted by zorro
                        OK, did you try to setup +MODE=2 in AdditionalInit of the config?

                        If so, please send me the PhoCo log.
                        no, i haven't tried to set much up in phoco. i don't know a lot about xml. i figured out what you have written in the cfg file and how to edit it, but i don't know how to add anything because i don't know any xml programming. everything that i'm working with so far is in hyperterminal, and it is working.

                        i don't think the cdma system is different, the "atd'***********'" still dials out, but only when switched to mode=2. when you use mpt to dial, it uses the "ckpd" command, but the "atd" commands works as well. here's a sample dial from mpt:

                        22:19:22,14 #### Voice call init...
                        22:19:22,21 Wait...
                        22:19:23,39 BR = 57600 8N1
                        22:19:23,43 --> AT&F<CR>
                        22:19:23,59 <-- OK
                        22:19:23,67 --> AT+MODE=2<CR>
                        22:19:23,71 Wait...
                        22:19:23,81 <-- OK
                        22:19:23,82 <-- +MBAN: Copyright 2000-2004 Motorola, Inc.
                        22:19:23,87 Wait...
                        22:19:24,48 --> ATE0<CR>
                        22:19:24,60 <-- ATE0
                        22:19:24,62 <-- OK
                        22:19:24,76 --> AT+CKPD="EE"<CR>
                        22:19:24,95 <-- OK
                        22:19:25,07 --> AT+CKPD="***********S"<CR> i don't know what the "s" is doing here
                        22:19:25,57 <-- OK
                        22:19:25,59 #### Voice call connected init...
                        22:19:25,67 Wait... after this point is hanging up in mpt
                        22:19:26,81 --> AT+MODE=0<CR>
                        22:19:26,93 <-- OK
                        22:19:27,01 --> ATE0<CR>
                        22:19:27,14 <-- ATE0
                        22:19:27,15 <-- OK
                        22:19:28,54 --> AT+CKPD="E"<CR>
                        22:19:28,64 <-- ERROR

                        btw the +mode=2; +mpbr edit doesn't work, tried a few other things in the config file, but still not working. do you have to change the "mode" in phoco script or in xml file?


                        • #13
                          Originally posted by zorro
                          OK, did you try to setup +MODE=2 in AdditionalInit of the config?

                          If so, please send me the PhoCo log.
                          I didn't know about the additionalinit in the config file. I'll get on it as soon as I get home this afternoon.

                          Zorro... für Rat und Hilfe danken

                          Sorry... that's the best I can do (God I love translators)


                          • #14
                            I know, it was well hidden ... in the documentation
                            Skinning to go... VisualDesigner2!


                            • #15
                              here's a noob question: why does the phone need to receive an echo 1 or echo 0 command? why would the text need to be hidden?