Announcement

Collapse
No announcement yet.

Blackberry 7100

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Blackberry 7100

    I'm unable to connect to my phone via Phone Control. Maybe some of this information can be useful for it's development.

    Here is what I get when I "query the modem" in device manager. The phone is seen as com4

    ATQ0V1E0 - OK
    AT+GMM - BlackBerry IPmodem
    AT+FCLASS=? - OK
    AT#CLS=? - OK
    AT+GCI? - OK
    AT+GCI=? - OK
    ATI1 - Research In Motion / BlackBerry IPmodem
    ATI2 - Research In Motion / BlackBerry IPmodem
    ATI3 - Research In Motion / BlackBerry IPmodem
    ATI4 - Research In Motion / BlackBerry IPmodem
    ATI5 - Research In Motion / BlackBerry IPmodem
    ATI6 - Research In Motion / BlackBerry IPmodem
    ATI7 - Research In Motion / BlackBerry IPmodem

    Phone Test see's
    COM4 | \??\Root#PORTS#0000#{86e0d1e0-8089-11d0-9ce4-08003e301f73}

    I get "no response from port" when hitting the test button.

    Any other information you need to help I would be happy to get or try!
    2001 Pontiac Grand Prix GTP Sedan (Sold)
    2007 Scion tC
    WhereIsMyGPS.net Online Tracker
    http://www.cardomain.com/id/leddy

  • #2
    Have you tried HyperTerminal as suggested in the manual at chapter 10?
    Skinning to go... VisualDesigner2!

    Comment


    • #3
      Do you have your blackberry desktop manager running when you are trying to do this? I have the 7100 & 7290 and they both require that to be running to be able to connect.

      I do not use Phone Manager but simply when connecting to the internet this is required.

      Hope this helps,

      Troy
      Done!

      If you're into fishing, checkout my website! http://www.pennsylvaniaanglers.com

      Comment


      • #4
        Troy: can you send me your config.xml?

        I've tried everything. I was able to get "Research In Motion" from using at+gmi in hypterm. I tried creating a new entry in the config with either "ResearchInMotion" or "Research In Motion" Nothing proved beneficial. I keep looping on Initializing phone...Resetting phone...

        For some unknown reason I was able to get past it once and it flashed something other messages and let me into the program. Can't remember what they were. I think it was trying to read the sim. I never found any contacts anywhere though. It then error'd out and never got that far again.

        You won't get any responses from the modem if you don't have the desktop manager open and the phone connected

        I'm stumped
        2001 Pontiac Grand Prix GTP Sedan (Sold)
        2007 Scion tC
        WhereIsMyGPS.net Online Tracker
        http://www.cardomain.com/id/leddy

        Comment


        • #5
          Originally posted by Leddy
          Troy: can you send me your config.xml?
          Sorry, I do not use Phone Control.

          I am on my home PC right now but when I get to work tomorrow I'll I'll post the AT commands I use to connect to the Internet.

          Hope it helps...

          Troy
          Done!

          If you're into fishing, checkout my website! http://www.pennsylvaniaanglers.com

          Comment


          • #6
            I guess I need to stop reading posts so late. I read your message all wrong.

            I can surf the web and everything fine, it's just getting phone co working that's throwing me for a loop. Maybe someday it'll work

            Thanks for the assistance though!
            2001 Pontiac Grand Prix GTP Sedan (Sold)
            2007 Scion tC
            WhereIsMyGPS.net Online Tracker
            http://www.cardomain.com/id/leddy

            Comment


            • #7
              I'm still not having any luck
              tried it on a different computer. I'm wondering if it has something to do with usb->serial vs the bluetooth->serial. When I go into hyperterm I can atz and get responses w/o a problem. When I go into phoco nothing works. Here's a log file:
              4/16/2005 12:11:49 AM MediaPlayer: WMPLAYER
              ----------------------------------------------------------------------------
              4/16/2005 12:11:49 AM Version: 1.4.4.24235
              ----------------------------------------------------------------------------
              4/16/2005 12:11:49 AM Not licensed.
              ----------------------------------------------------------------------------
              4/16/2005 12:11:51 AM Image not found: C:\Program Files\PhoneControl.NET\Icons\2_Switch.png
              System.ArgumentException: Invalid parameter used.
              at System.Drawing.Bitmap..ctor(String filename)
              at PhoneCtl.NET.frmMain.SetButtonProperties(XmlDocume nt pi_oDoc, String pi_sButtonName, zButton& pi_oButton)
              ----------------------------------------------------------------------------
              4/16/2005 12:11:52 AM Keymap "Sample Key-Map for SE T610 simulating a mobile phone like keypad" loaded, 25 mappings found.
              ----------------------------------------------------------------------------
              4/16/2005 12:11:52 AM SMS templates loaded, 5 templates found.
              ----------------------------------------------------------------------------
              4/16/2005 12:11:52 AM Opening COM11
              ----------------------------------------------------------------------------
              4/16/2005 12:11:52 AM COM: >ATZ
              ----------------------------------------------------------------------------
              4/16/2005 12:12:07 AM **** TIMEOUT ****
              ----------------------------------------------------------------------------
              4/16/2005 12:12:08 AM COM: >AT+CSCS="8859-1";+CRC=1;+CNMI=3,1
              ----------------------------------------------------------------------------
              4/16/2005 12:12:11 AM **** TIMEOUT ****

              I just don't understand why phoco is showing timeouts when I get responses in hyperterm.. Any thoughts? (yes I close hyperterm before attempting to use serial port)

              On my laptop phone is seen as com4, on desktop it's com3. I also manually changed it to com11 to see if that would help any.. It didn't
              2001 Pontiac Grand Prix GTP Sedan (Sold)
              2007 Scion tC
              WhereIsMyGPS.net Online Tracker
              http://www.cardomain.com/id/leddy

              Comment


              • #8
                I recently found out that on some (COM) drivers I don't get the events I'm looking for. This definitely has something to do with the COMM control I'm using.
                For now, I don't know why PhoCo behaves like that on your phone. Hence, I have to get such a device to test it myself.

                So, stay tuned.
                Skinning to go... VisualDesigner2!

                Comment


                • #9
                  *this is me staying tuned*
                  2001 Pontiac Grand Prix GTP Sedan (Sold)
                  2007 Scion tC
                  WhereIsMyGPS.net Online Tracker
                  http://www.cardomain.com/id/leddy

                  Comment


                  • #10
                    I was wondering if there anyone has got a blackberry to work. I have a 7290 and have gotten about as far as Leddy.

                    The 7290 can be used as a modem. I just tried it out.
                    I can query the 7290 modem and get the same results as Leddy. I tried the hyperterm test in chapter 10 and everything looks good.

                    What AT commands does the Phone Test send?

                    When I try the phone test I get...

                    JH.CommBase.CommPortException: Receive Thread Exception ---> JH.CommBase.CommPortException: Receive Thread Exception ---> JH.CommBase.CommPortException: IO Error [004]<cr><lf>
                    at JH.CommBase.CommBase.ReceiveThread()<cr><lf>
                    --- End of inner exception stack trace ---<cr><lf>
                    at JH.CommBase.CommBase.ThrowException(String reason)<cr><lf>
                    at JH.CommBase.CommLine.Transact(String toSend)<cr><lf>
                    at PhoneTest.Com.TransactCmd(String pi_sCmd)<cr><lf>
                    --- End of inner exception stack trace ---<cr><lf>
                    at PhoneTest.Com.TransactCmd(String pi_sCmd)<cr><lf>
                    at PhoneTest.Form1.btnTest_Click(Object sender, EventArgs e)

                    Thread Exception can't be good. I'd really like to help to get the Blackberry working with PhoneControl.

                    Please let me know if there is anything I can do to help.

                    Comment


                    • #11
                      did anyone get this to work? I have a 7100t I would like to get to work also.
                      Randell Kelly

                      Comment


                      • #12
                        dont know if it will help any on getting the 7100t to work, but I found a bunch of AT commands for hyperterm here:
                        http://www.blackberryforums.com/arch...hp/t-2019.html
                        Randell Kelly

                        Comment


                        • #13
                          Anyone made any progress?
                          '98 Acura TL 3.2 >Epia M10000 >512ram >200gb >XP pro>Lilli 619> Opus 120
                          TESTING as of 6/22/08 - Intel D945GCLF, 2GB RAM, 80gb HDD, XP pro SP1, same Lilli & Opus 120

                          Comment


                          • #14
                            Here's what you got to do:

                            - Install that modem driver as mentioned in the Blackberry forums thread.
                            - Do the Diagnostic-> Query modem thing
                            - If that works, run PhoneTest and send me the output

                            But don't get too excited - usually those modem drivers support just a subset of the AT-Commandset. Just enough to establish a Dial-Up connection.
                            Skinning to go... VisualDesigner2!

                            Comment


                            • #15
                              I think the best way would probably be a java app that makes use of the net.rim.blackberry.api.phone and net.rim.blackberry.api.invoke APIs available. This allows you call control and notification which could be placed over a bluetooth serial port using the net.rim.blackberry.api.bluetooth API

                              It's a long winded way of doing it, but I see no real reason why it shouldn't work. In fact, once my arm is out of this cast I may well crack on with developing something that Zorro could put to use in PhoneControl assuming no-one beats me to it
                              SB

                              "The gene pool could use a little chlorine..."

                              Comment

                              Working...
                              X