Announcement

Collapse
No announcement yet.

macro help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • macro help

    hi i am trying to set up a macro it does part of it but does not do the rest.
    this is what i have in the ini file
    name307=SETMOUSEPOS[175;536],VK_LBUTTON,VK_LBUTTON,SETMOUSEPOS[768;466],VK_LBUTTON,VK_LBUTTON,VK_LBUTTON,^
    the macro gets to 768;466 with the mouse but i can not get it to left mouse click( i need to click the left mouse 3 times)
    thanks for all your help.
    Michael
    Win 7 Pro 64bit, 4gb DDR2 Ram, q6600 Processor, Solid state drive & 7200 drive, Andrea mic, Sirius, DE HD Radio, Opus power supply, 10.4" touchscreen.
    1.)Orion 2500d Amp
    1.)Orion 15" h2 Sub
    1.)Orion 8004 Amp
    2.) Sets Orion Components - P-SERIES

  • #2
    Originally posted by michaelrj9
    hi i am trying to set up a macro it does part of it but does not do the rest.
    this is what i have in the ini file
    name307=SETMOUSEPOS[175;536],VK_LBUTTON,VK_LBUTTON,SETMOUSEPOS[768;466],VK_LBUTTON,VK_LBUTTON,VK_LBUTTON,^
    the macro gets to 768;466 with the mouse but i can not get it to left mouse click( i need to click the left mouse 3 times)
    thanks for all your help.
    Michael
    My guess: you're supposed to let go of the mouse each time. So put in a ^ after each click.
    PowerVoice v1 | NaviVoice Source
    GammaControl v2.4
    SKINbedder v3

    1995 Lexus SC300

    Comment


    • #3
      Originally posted by 0l33l
      My guess: you're supposed to let go of the mouse each time. So put in a ^ after each click.
      still will not work right.

      With this macro I am trying to "load a certain playlist" in Road Runner.

      If I have this in the ini file:
      name307=SETMOUSEPOS[75;536],VK_LBUTTON,VK_LBUTTON,SETMOUSEPOS[768;466],VK_LBUTTON,VK_LBUTTON,VK_LBUTTON,^
      It gets to the point where it moves the mouse over to 768;466 position but will not click the button (3 times to scroll down)

      As you said then I tried this in the ini file:
      name307=SETMOUSEPOS[175;536],VK_LBUTTON,VK_LBUTTON,SETMOUSEPOS[768;466],VK_LBUTTON,^,VK_LBUTTON,^,VK_LBUTTON,^
      But it does not help this way it scrolls all the way to the bottom of the page not clicking the mouse 3 times.

      I am not sure what I am doing wrong.

      Also at the begining I have "name307=SETMOUSEPOS[175;536],VK_LBUTTON,VK_LBUTTON," I do not really need 2 mouse clicks here but that is the only way I could get it to click 1 time.

      I also tried this there but it still did not help
      "name307=SETMOUSEPOS[175;536],VK_LBUTTON,^,"
      I thought this was the way to make a single mouse click and release it. But it does not work for me.

      Does anyone have any macros setup with mutiple mouse movements and multiple mouse clicks to perforn a task, That you can post or send me a copy of the ini file so I can see the ini file and see what I am doing wrong.

      Thanks
      Michael
      Win 7 Pro 64bit, 4gb DDR2 Ram, q6600 Processor, Solid state drive & 7200 drive, Andrea mic, Sirius, DE HD Radio, Opus power supply, 10.4" touchscreen.
      1.)Orion 2500d Amp
      1.)Orion 15" h2 Sub
      1.)Orion 8004 Amp
      2.) Sets Orion Components - P-SERIES

      Comment


      • #4
        You also need to put the ^ after you move the mouse
        Originally posted by michaelrj9
        still will not work right.

        With this macro I am trying to "load a certain playlist" in Road Runner.

        If I have this in the ini file:
        name307=SETMOUSEPOS[75;536],VK_LBUTTON,VK_LBUTTON,SETMOUSEPOS[768;466],VK_LBUTTON,VK_LBUTTON,VK_LBUTTON,^
        It gets to the point where it moves the mouse over to 768;466 position but will not click the button (3 times to scroll down)

        As you said then I tried this in the ini file:
        name307=SETMOUSEPOS[175;536],VK_LBUTTON,VK_LBUTTON,SETMOUSEPOS[768;466],VK_LBUTTON,^,VK_LBUTTON,^,VK_LBUTTON,^
        But it does not help this way it scrolls all the way to the bottom of the page not clicking the mouse 3 times.

        I am not sure what I am doing wrong.

        Also at the begining I have "name307=SETMOUSEPOS[175;536],VK_LBUTTON,VK_LBUTTON," I do not really need 2 mouse clicks here but that is the only way I could get it to click 1 time.

        I also tried this there but it still did not help
        "name307=SETMOUSEPOS[175;536],VK_LBUTTON,^,"
        I thought this was the way to make a single mouse click and release it. But it does not work for me.

        Does anyone have any macros setup with mutiple mouse movements and multiple mouse clicks to perforn a task, That you can post or send me a copy of the ini file so I can see the ini file and see what I am doing wrong.

        Thanks
        Michael
        PowerVoice v1 | NaviVoice Source
        GammaControl v2.4
        SKINbedder v3

        1995 Lexus SC300

        Comment

        Working...
        X