Announcement

Collapse
No announcement yet.

Error on close- have to kill process from task manager

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error on close- have to kill process from task manager

    I keep seeing this error, which seems memory related. I see it on both my DEV machine and the carpc. Is anyone else getting anything similar with SKINBedder?

    Access violation at 7C822B38 in module "kernel32.dll". Read at address 000000E2.

    RPM, do you know how SB allocates memory?
    CarPC #3: 99% Complete
    Pentium M 1.7Ghz, 1GB DDR2 RAM
    DVD/CD-RW installed in dash below monitor
    OEM LCD relocated for 7" Touchscreen
    Wi-Fi, GPS, PS2 controllers...
    500+ full albums
    4,000+ video games
    music videos, movies, & more!
    old carPC

  • #2
    Nope

    Delphi is supposed to handle that for me.

    Comment


    • #3
      anybody else seen this?
      CarPC #3: 99% Complete
      Pentium M 1.7Ghz, 1GB DDR2 RAM
      DVD/CD-RW installed in dash below monitor
      OEM LCD relocated for 7" Touchscreen
      Wi-Fi, GPS, PS2 controllers...
      500+ full albums
      4,000+ video games
      music videos, movies, & more!
      old carPC

      Comment


      • #4
        I do get that sometimes. Only when exiting Sb. I think it happens if an embedded window has a non-embedded sub-window open when Sb closes. Best just to make a close button that kills(skinbedder.exe) or an auto-it script that ends-task on it.

        Comment


        • #5
          Originally posted by RPM_VR4
          I do get that sometimes. Only when exiting Sb. I think it happens if an embedded window has a non-embedded sub-window open when Sb closes. Best just to make a close button that kills(skinbedder.exe) or an auto-it script that ends-task on it.
          It's happening more often than not, now. Since my shutdown controller sends a hardoff after 45 seconds, I don't want this error message to delay the End Task too long and not give XP a chance to shutdown properly.

          That's exactly what I need...I am in training for work all week, so I don't have much time to focus on this right away. I'll have to try to figure this out. Do you have it implemented already?
          CarPC #3: 99% Complete
          Pentium M 1.7Ghz, 1GB DDR2 RAM
          DVD/CD-RW installed in dash below monitor
          OEM LCD relocated for 7" Touchscreen
          Wi-Fi, GPS, PS2 controllers...
          500+ full albums
          4,000+ video games
          music videos, movies, & more!
          old carPC

          Comment


          • #6
            I need more info. Does your PC shutdown or hibernate? Was I right about non-embedded sub-windows causing the problem? You should never have the problem if you are jsut embedding one screen that has no children open... right?

            Comment


            • #7
              Originally posted by RPM_VR4
              I need more info. Does your PC shutdown or hibernate? Was I right about non-embedded sub-windows causing the problem? You should never have the problem if you are jsut embedding one screen that has no children open... right?
              Shutdown...never hibernate. I'm not sure what sub windows you might be talking about....It's just the plain ol iG map in SKINBedder. No routing windows or anything of that nature are open. Sorry, just confused...
              CarPC #3: 99% Complete
              Pentium M 1.7Ghz, 1GB DDR2 RAM
              DVD/CD-RW installed in dash below monitor
              OEM LCD relocated for 7" Touchscreen
              Wi-Fi, GPS, PS2 controllers...
              500+ full albums
              4,000+ video games
              music videos, movies, & more!
              old carPC

              Comment


              • #8
                I have never had the error when closing just the map. I only have the error if one of the sub windows (routing, GPS info, etc.) is open. You use RR right? Maybe there is something wierd about how RR closes when shutting down. I will look in to it.

                Comment


                • #9
                  its not RR specific...it happens when I run SKINBedder standalone, too. I'll pay more attention and see if it is happening when NO sub-windows are open....to be continued.

                  Do use currently use anything to kill the process rather than closing the window?
                  CarPC #3: 99% Complete
                  Pentium M 1.7Ghz, 1GB DDR2 RAM
                  DVD/CD-RW installed in dash below monitor
                  OEM LCD relocated for 7" Touchscreen
                  Wi-Fi, GPS, PS2 controllers...
                  500+ full albums
                  4,000+ video games
                  music videos, movies, & more!
                  old carPC

                  Comment


                  • #10
                    I can confirm that it happens when no subwindows are open. This is starting to bite because I have to kill it manually from task manager, and then tell the computer to shutdown...so it's not even forcing the kill on shutdown, and the shutdown gets aborted for whatever reason...I can't wait to get out of training so I can work on this thing this weekend.

                    Now, I can say that I've been using GPS a lot this week, so at SOME POINT, there has been a subwindow open, but not when forced to shutdown, as I have cleared/cancelled the nav by then...I'd like to test it if no nav (think subwindows) have ever been produced...
                    CarPC #3: 99% Complete
                    Pentium M 1.7Ghz, 1GB DDR2 RAM
                    DVD/CD-RW installed in dash below monitor
                    OEM LCD relocated for 7" Touchscreen
                    Wi-Fi, GPS, PS2 controllers...
                    500+ full albums
                    4,000+ video games
                    music videos, movies, & more!
                    old carPC

                    Comment


                    • #11
                      I have been using it in both CF and RR, both with hibernating and with pressing the shutdown button in the fornt-end, both in CF and RR. I have not had to end task on Sb at all in the past few months.

                      I did use to have that problem a long time ago though (and I thought it was sub-window related). Do you have SbV3-P2? I don't think that is really any different than my latest build, but I will send you the .exe I run if you like.

                      Comment


                      • #12
                        yes, i'm using v3p2
                        CarPC #3: 99% Complete
                        Pentium M 1.7Ghz, 1GB DDR2 RAM
                        DVD/CD-RW installed in dash below monitor
                        OEM LCD relocated for 7" Touchscreen
                        Wi-Fi, GPS, PS2 controllers...
                        500+ full albums
                        4,000+ video games
                        music videos, movies, & more!
                        old carPC

                        Comment


                        • #13
                          okay...so I made a couple of new skins tonight, and noticed that sometimes I didn't have the error as often. The last skin I made, I was able to narrow it down to the Hide button causing the memory conflict. Ultimately, I found that the following line in the skin file caused the error:
                          OnPressUp=Focus(iGMap),HideSkin(botleft),HideSkin( botright),LoadSkin(iGMap:Show)

                          The issue was resolved by changing it to the following:
                          OnPressUp=Focus(iGMap),LoadSkin(iGMap:Show),HideSk in(botleft),HideSkin(botright)


                          Now, it doesn't make a bit of sense to me, but it seems to have eliminated the problem. (Any spaces in the above lines of code were input by the forum, there really shouldn't be any spaces in there...it does that sometimes...)
                          CarPC #3: 99% Complete
                          Pentium M 1.7Ghz, 1GB DDR2 RAM
                          DVD/CD-RW installed in dash below monitor
                          OEM LCD relocated for 7" Touchscreen
                          Wi-Fi, GPS, PS2 controllers...
                          500+ full albums
                          4,000+ video games
                          music videos, movies, & more!
                          old carPC

                          Comment


                          • #14
                            Good find. I believe a wait(100) or even lower before the load skin would have fixed it as well. It is probably advisable to put a wait(10) between every command.

                            Comment


                            • #15
                              why is that? I'll give it a shot if I continue to get the error.
                              CarPC #3: 99% Complete
                              Pentium M 1.7Ghz, 1GB DDR2 RAM
                              DVD/CD-RW installed in dash below monitor
                              OEM LCD relocated for 7" Touchscreen
                              Wi-Fi, GPS, PS2 controllers...
                              500+ full albums
                              4,000+ video games
                              music videos, movies, & more!
                              old carPC

                              Comment

                              Working...
                              X