Results 1 to 9 of 9

Thread: Skinning request

  1. #1
    Maximum Bitrate Mañana's Avatar
    Join Date
    Jul 2004
    Location
    Sweden
    Posts
    761

    Skinning request

    We'll, this isnt especially important, but would make skinning easier
    The text inside the text boxes are normaly centered. Would it be possible to add attributes for left, center, right adjustment? Much like the existing bold, italic and underlined? And mybe also a scond textcolor for "held down" button?


  2. #2
    Freeway Creator oeri's Avatar
    Join Date
    Jul 2005
    Location
    Pittsburgh, PA
    Posts
    522
    Quote Originally Posted by Mañana View Post
    The text inside the text boxes are normaly centered. Would it be possible to add attributes for left, center, right adjustment? Much like the existing bold, italic and underlined?
    This is already possible. The number immediately before the font name defines the alignment.

    And mybe also a scond textcolor for "held down" button?
    I'm not sure what you mean by this.

  3. #3
    Variable Bitrate mercury7's Avatar
    Join Date
    Jul 2005
    Location
    Dallas
    Posts
    412
    I think he means when a button is pressed, it would be nice to have the ability to set the font to a different color. Example ->
    • Up state - Button has black background and white lettering
    • Down state - Button has white background and blue lettering.
    2002 Grand Am progress :
    [••••••••••••••••………] - 80%
    ...complete setup, but still need to make the install cleaner

  4. #4
    Maximum Bitrate Mañana's Avatar
    Join Date
    Jul 2004
    Location
    Sweden
    Posts
    761
    Yeah, exactly =)

    And just a thought, it seems like FW uses its own mp3 database? Why not use winamps?

  5. #5
    Freeway Creator oeri's Avatar
    Join Date
    Jul 2005
    Location
    Pittsburgh, PA
    Posts
    522
    Because mine is better

  6. #6
    Maximum Bitrate Mañana's Avatar
    Join Date
    Jul 2004
    Location
    Sweden
    Posts
    761

  7. #7
    Maximum Bitrate Mañana's Avatar
    Join Date
    Jul 2004
    Location
    Sweden
    Posts
    761
    Does your database store ID3 info? Or does it get that from Winamp?

    Also, does it handle file deletion? Because I recently deleted a directory from my mp3 folder, and FW still has the files in its library. Thou, when playing, I get "error 76, path not found". I tried rebuilding both winamps library (witch does not contain the files any longer) and FWs database (witch does still have them).

  8. #8
    Freeway Creator oeri's Avatar
    Join Date
    Jul 2005
    Location
    Pittsburgh, PA
    Posts
    522
    Quote Originally Posted by Mañana View Post
    Does your database store ID3 info? Or does it get that from Winamp?
    It reads the ID3 info when you add the files to the library. It uses Winamp's ID3 info during playback.

    Also, does it handle file deletion? Because I recently deleted a directory from my mp3 folder, and FW still has the files in its library. Thou, when playing, I get "error 76, path not found". I tried rebuilding both winamps library (witch does not contain the files any longer) and FWs database (witch does still have them).
    Hmm, I don't think Freeway knows how to handle files that have been deleted. I'll work on this when I get some time, but for the time being, erase the library.ini and rebuild from scratch. It won't have to download album art again, so it should be relatively quick.

  9. #9
    Maximum Bitrate Mañana's Avatar
    Join Date
    Jul 2004
    Location
    Sweden
    Posts
    761
    Quote Originally Posted by oeri View Post
    It reads the ID3 info when you add the files to the library. It uses Winamp's ID3 info during playback.
    I see, cuz it has the same problem as winamp with the ID3 tags when scrolling around a new playlist. (They dont update unless scolling to them, so all you see is the filename)

    Quote Originally Posted by oeri View Post
    Hmm, I don't think Freeway knows how to handle files that have been deleted. I'll work on this when I get some time, but for the time being, erase the library.ini and rebuild from scratch. It won't have to download album art again, so it should be relatively quick.
    Yeah, no hurry =) I'll just try that and see if it works.

Similar Threads

  1. Forum Slowness
    By Quattro in forum Mp3car Forum Suggestions/Comments
    Replies: 41
    Last Post: 10-28-2005, 06:50 PM
  2. Request: Skinning Tutorial.
    By Meelobee in forum RR Skins
    Replies: 11
    Last Post: 08-11-2005, 01:32 PM
  3. Forum Really Slow
    By Quattro in forum Mp3car Forum Suggestions/Comments
    Replies: 58
    Last Post: 05-10-2005, 04:04 PM
  4. errors on the homepage
    By alti in forum Mp3car Forum Suggestions/Comments
    Replies: 61
    Last Post: 04-14-2005, 10:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •