Page 6 of 18 FirstFirst 12345678910111213141516 ... LastLast
Results 51 to 60 of 180

Thread: Development update

  1. #51
    Low Bitrate
    Join Date
    Aug 2006
    Location
    Nottingham, UK
    Posts
    98

    Ultra feature request

    Just wondering whether .m4a files will be supported in Freeway Ultra?

    The old freeway plays them but doesn't seem to read the tags properly etc

    Andy

  2. #52
    High Voltage blk02si's Avatar
    Join Date
    Jul 2005
    Location
    Motorcity
    Posts
    2,267
    Blog Entries
    1
    New build looks good oeri. More stable. Only bugs im getting is as previously stated when refreshing the library (have 4000 songs) it crashes after loading about 75. And sometimes after I skip a few songs it will crash. Other than that launch time, menu response time, GPS launch time, overall speed is HELLA FAST!
    Build Things, it keeps your brain busy.

    AutoPC v1 (Retired) - AutoPC v2 (in progress) - www.shocknet.us

  3. #53
    Freeway Creator oeri's Avatar
    Join Date
    Jul 2005
    Location
    Pittsburgh, PA
    Posts
    522
    New test version

    - Added M4A and OGG tag reading support (please test this especially!)
    - More library bug fixes (hopefully no more crashes on refresh...)
    - Video and music extensions customizable in freeway.ini
    - Video window can be hidden by clicking home... clicking the eye in the bottom right will re-show video window

    http://www2.onu.edu/~m-keryeski/ccfru.zip ... please see installation instructions in previous posts

  4. #54
    High Voltage blk02si's Avatar
    Join Date
    Jul 2005
    Location
    Motorcity
    Posts
    2,267
    Blog Entries
    1
    followed all instructions but im still getting the refresh error. Also i noticed in the library.ini the search started with 'y' for some reason. Got to 62 songs before the crash. Video, GPS, and stability all solid. I can post the exception if it will help ya

    Also volume + - does not seem to be working
    Build Things, it keeps your brain busy.

    AutoPC v1 (Retired) - AutoPC v2 (in progress) - www.shocknet.us

  5. #55
    Variable Bitrate
    Join Date
    Sep 2004
    Location
    Slovenia (EU)
    Posts
    312
    One .vob video was moved to lower and right hand corrner other videos worked great.
    The next button doesn't work.

    In music there is still problem with refreshing library. I haven't play much round here so for now I can't tell more.

    Keep up good work.

  6. #56
    Freeway Creator oeri's Avatar
    Join Date
    Jul 2005
    Location
    Pittsburgh, PA
    Posts
    522
    Quote Originally Posted by blk02si View Post
    followed all instructions but im still getting the refresh error. Also i noticed in the library.ini the search started with 'y' for some reason. Got to 62 songs before the crash. Video, GPS, and stability all solid. I can post the exception if it will help ya

    Also volume + - does not seem to be working
    Please post the complete error message and try to determine the file that crashes the program. The volume buttons have no code yet.

  7. #57
    High Voltage blk02si's Avatar
    Join Date
    Jul 2005
    Location
    Motorcity
    Posts
    2,267
    Blog Entries
    1
    Here is what happened

    Code:
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    System.ArgumentOutOfRangeException: Length cannot be less than zero.
    Parameter name: length
       at System.String.InternalSubStringWithChecks(Int32 startIndex, Int32 length, Boolean fAlwaysCopy)
       at System.String.Substring(Int32 startIndex, Int32 length)
       at FreewayUltra.Program.GenerateLibrary()
       at FreewayUltra.frmSkin.frmSkin_MouseDown(Object sender, MouseEventArgs e)
       at System.Windows.Forms.Control.OnMouseDown(MouseEventArgs e)
       at System.Windows.Forms.Control.WmMouseDown(Message& m, MouseButtons button, Int32 clicks)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
       at System.Windows.Forms.ContainerControl.WndProc(Message& m)
       at System.Windows.Forms.Form.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    
    
    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    ----------------------------------------
    FreewayUltra
        Assembly Version: 1.0.0.0
        Win32 Version: 1.0.0.0
        CodeBase: file:///C:/Documents%20and%20Settings/js/Desktop/fwc/ccfru.exe
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Xml
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------
    System.Configuration
        Assembly Version: 2.0.0.0
        Win32 Version: 2.0.50727.42 (RTM.050727-4200)
        CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    ----------------------------------------
    
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    
    For example:
    
    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>
    
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
    Build Things, it keeps your brain busy.

    AutoPC v1 (Retired) - AutoPC v2 (in progress) - www.shocknet.us

  8. #58
    Low Bitrate farolfo's Avatar
    Join Date
    Apr 2004
    Posts
    69
    Hi Oeri, Plastico HT, my custom frontend have a complete class (in vb6) to control and embed mplayer, do you use it also for music ?

  9. #59
    Newbie
    Join Date
    Oct 2006
    Posts
    36
    Hi again oeri. i must dissapoint you, still getting an (non-critical?) error in your latest build. when playing a song, it takes around 2 seconds before i get an windows-error with info :

    EventType : clr20r3 P1 : ccfru.exe P2 : 1.0.0.0 P3 : 4560c637
    P4 : mscorlib P5 : 2.0.0.0 P6 : 4333ab80 P7 : bd0 P8 : 59
    P9 : system.formatexception

    norwegian xp, havent had a chance to test with the others yet.

  10. #60
    Freeway Creator oeri's Avatar
    Join Date
    Jul 2005
    Location
    Pittsburgh, PA
    Posts
    522
    blk02si -- I am pretty sure I have tracked down the bug and will fix it for the next release.

    farolfo -- I am using mplayer for both music and video, but I'm using C#, not VB6.

    PipPip -- Is that all you're getting? Unfortunately, that doesn't tell me much.

Similar Threads

  1. Chuck's Skins lots of pics Update 7-16-07
    By Chuck in forum RR Released Skins
    Replies: 297
    Last Post: 11-10-2011, 07:22 PM
  2. Update on development
    By netsuo in forum NeoCar Media Center
    Replies: 2
    Last Post: 04-04-2005, 06:37 AM
  3. MediaEngine Development Progress Update
    By CarComp in forum Media Engine
    Replies: 23
    Last Post: 01-07-2005, 12:53 PM
  4. New Diplay Development Update
    By Yamato in forum LCD/Display
    Replies: 14
    Last Post: 02-10-2004, 03:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •