Page 13 of 20 FirstFirst ... 34567891011121314151617181920 LastLast
Results 121 to 130 of 195

Thread: *Release*[SAT RADIO] Alpha 3

  1. #121
    Constant Bitrate
    Join Date
    Feb 2005
    Posts
    189
    Quote Originally Posted by frodobaggins
    Well, I'm not sure, it must not be recieving the hibernate message when embedded.
    I can add a reset command if need be. But it won't be automated unless the embedded app can send it.
    Hmmm...I thought it would be something like that...

    What about just sending a reinitialization command when the app no longer can communicate with the XM Direct? Perhaps when it doesn't receive signal strength data for a duration of a few seconds. Does the XMD echo the commands it was sent? If so, lack of an echo could be used to trigger a reinitialization.

  2. #122
    Constant Bitrate
    Join Date
    Jul 2004
    Posts
    208

    Problems resuming from UPS induced hibernation.

    Bloody amazing, I love it! $10 for the receiver, another $5 for a cable and frodo has made me love my carputer even more.

    I am having trouble resuming from hibernation though. I have the program configured to launch from frodoplayer. No serial mouse present. When I hibernate by pressing the power button everything works out fine. but... I'm using the fake ups trick as my shutdown controller and when the ups service sends the puter into hibernation while SATRADIO app is running I can resume but it doesn't look like the reciever is being reinitialized. I get no sound.

    What's really interesting about this is until ninjamonkey added the new auto-reconnect feature on mapmonkey, I was having problems reconnecting to my gpsmouse when I resumed from a ups service induced hibernate. Also I am wondering if ups induced hibernation is responsible for frodo not resuming volumes properly. When I resume frodo my master and wave volumes are zero.

    So I guess the real question is, what's the difference between ups and power button induced hibernation? Is there one? Is there a registry entry that needs to be tweaked? A fix would be nice, but I'll be setting up a PIC soon as my power controller soon so I don't absolutely need one. Just reporting strange system behavior.

    Cheers and thanks again for the software.

    -momanz

  3. #123
    I'm sorry, and you are....? frodobaggins's Avatar
    Join Date
    Jan 2003
    Location
    Ruston, LA
    Posts
    8,846
    Don't know if I ever posted these Sendmessage/Postmessage codes.
    So here:
    Code:
    Window Title "FRODOSATRADX"
    Window Class "ThunderRT6FormDC"
    
    WM_USER = 1024
    
    WM_USER + 1  'Previous
    WM_USER + 2  'Next
    WM_USER + 3  'Select/Play
    WM_USER + 4  'Up
    WM_USER + 5  'Down
    WM_USER + 6  'Hide Current Selected Channel
    WM_USER + 7  'Hide Channel (wparam = channel)
    WM_USER + 8  'UnHide Channel (wparam = channel)
    WM_USER + 9  'Select Channel (Must be in list) (wparam = channel)
    WM_USER + 10  'Select Channel (Doesn't need to be in list) (wparam = channel)
    WM_USER + 11 'Play Main Favorite # (wparam = favorite)
    WM_USER + 12 'Mute Toggle
    WM_USER + 13 'Mute On
    WM_USER + 14 'Mute Off
    WM_USER + 15 'Volume Up Percent
    WM_USER + 16 'Volume Down Percent
    WM_USER + 17 'Exit
    WM_USER + 18 'Add Favorite Current Selected
    WM_USER + 19 'Add Favorite (wparam=channel)
    WM_USER + 20 'Delete Favorite (wparam=channel)
    WM_USER + 21 'Delete Favorite Current Selected
    WM_USER + 22 'Toggle Min/Max
    WM_USER + 23 'Max
    WM_USER + 24 'Min
    [H]4 Life
    My next generation Front End is right on schedule.
    It will be done sometime in the next generation.
    I'm a lesbian too.
    I am for hire!

  4. #124
    FLAC
    Join Date
    Nov 2003
    Location
    Marietta, GA
    Posts
    1,134
    ....and, if I did this right, here's the .gml file (rename from .gml.txt to .gml).

    Thanks Frodo!
    MikeH

  5. #125
    Raw Wave tj!2k4's Avatar
    Join Date
    Oct 2004
    Posts
    3,294
    Frodo - I'm still experiencing problems w/ BSOD when running FSRX embedded in Centrafuse. I mentioned this to veetid, and he made a suggestion to incorporate additional code in FSRX.

    As always, thank you for your hard work.

    Here is my question, and the response/suggestion:

    Quote Originally Posted by tj!2k4
    If I exit Centrafuse without exiting FSRX first, it'll cause a BSOD and I have to kill the power to the computer and reboot. I'm not expecting a resolution since I don't know if there's anything that you can do within Centrafuse to resolve this issue, or whether this is a Frodo thing since it only happens with his app, or if it's a driver issue with the XMPCR.
    Quote Originally Posted by veetid
    Not much I can really do on my end... The app could easily be fixed by adding a little code to intercept the close window message in the WndProc and setting it to execute the applications close routine...

  6. #126
    I'm sorry, and you are....? frodobaggins's Avatar
    Join Date
    Jan 2003
    Location
    Ruston, LA
    Posts
    8,846
    Quote Originally Posted by tj!2k4
    Frodo - I'm still experiencing problems w/ BSOD when running FSRX embedded in Centrafuse. I mentioned this to veetid, and he made a suggestion to incorporate additional code in FSRX.

    As always, thank you for your hard work.

    Here is my question, and the response/suggestion:

    Well, first off, if centrafuse closes, anything embedded should first be
    unembedded, and/or sent a message to close. So be sure veetid is doing
    that.

    I will check to see if I forgot to add the code to close in there
    on destroy or close, but I believe the major problem will be the above.

    Frodo
    [H]4 Life
    My next generation Front End is right on schedule.
    It will be done sometime in the next generation.
    I'm a lesbian too.
    I am for hire!

  7. #127
    Raw Wave tj!2k4's Avatar
    Join Date
    Oct 2004
    Posts
    3,294
    Thanks Frodo, I will pass the information along to veetid.

  8. #128
    Constant Bitrate
    Join Date
    Nov 2004
    Location
    NY tri-state
    Posts
    189
    Well I set this up last week in my car and it was working 100% perfectly without any problems...

    Yesterday I setup FrodoCam with my Dazzle 80, and all of the sudden I get really high CPU usage out of FrodoSatRadio... Anybody care to take a guess as to what's going on? I only installed the Dazzle drivers, so I figured it wouldn't have any effect on the sat radio app, but I guess I was wrong.

    This happens whether it's launched by itself or from within FrodoPlayer, and the task manager shows nothing else running that could mess with it... CPU usage is in the high 90s-100%, and while it works it takes a LONG time for it to refresh the channel list as well as to basically do anything.

    I suppose I could remove the Dazzle drivers and see if that helps (after all, Frodo XM > FrodoCam ), but of course I'd like to have everything installed...

    Any ideas?

  9. #129
    Newbie
    Join Date
    Jul 2002
    Posts
    25
    My dad recently gave me a good suggestion for this app. Is it possible to configure girder, or something along those lines, to allow a specific channel to be selected by remote control? Say I want channel 150 for comedy. I push the numbers on the remote and that channel is selected. Is it possible?

  10. #130
    Maximum Bitrate
    Join Date
    Mar 2005
    Location
    Pomona, CA
    Posts
    456
    I am having audio quality issues with the XM app. I have the EQ on, (simply because I have not gotten it to work without the EQ enabled) and I can hear alot of artifacts and noise. I have all of the EQ settings disabled, and everything set to its lowest point, but its still there. I do not get any feedback really, just weird artifacts and digital noise occasionally (popping and garbage)

    Can I increase the priority of the XM app in windows? If so, how do I do that?

    Also, how do I make it work without the EQ enabled? I am using a soundblaster live USB external soundcard.

    Thanks

Similar Threads

  1. [SAT RADIO] Alpha 2
    By frodobaggins in forum FrodoPlayer
    Replies: 77
    Last Post: 05-04-2005, 10:13 AM
  2. Alpha 2a is out, skinners i need you
    By netsuo in forum NeoCar Media Center
    Replies: 13
    Last Post: 12-24-2004, 02:57 AM
  3. MapPoint Embedded Alpha Testing Results
    By antimatter in forum Software & Software Development
    Replies: 6
    Last Post: 04-01-2004, 04:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •