Results 1 to 4 of 4

Thread: FP and Keyboard Automation

  1. #1
    Low Bitrate uptpilot's Avatar
    Join Date
    Jun 2005
    Location
    Oklahoma City
    Posts
    77

    FP and Keyboard Automation

    Frodo , or anyone else that might know :

    I'm using an IR remote control to send keyboard commands to FP. Using the touchscreen while driving is too difficult.

    Most of the keyboard automation commands I need are there, except that I'm having a bit of a problem with the DirListing commands:
    w dirlist down
    q dirlist up
    e dirlist select
    a dirlist left
    s dirlist right
    I use this mode 99% of the time. While I can go up and down in the directory hierarchy, I cannot expand a folder if it has subdirectories using the keys above. FP requires a double click at that location to expand the subdirectories. How can I assign a keyboard shortcut to expand out a directory's subdirectories?

    Thanks.

  2. #2
    Low Bitrate uptpilot's Avatar
    Join Date
    Jun 2005
    Location
    Oklahoma City
    Posts
    77

    Exclamation more little issues

    I've been experimenting with keyboard shortcuts and in addition to the previous post, here's another issue i'm having.

    What works:
    When I press "Z" to go to the previous song, the song properly decrements in the playlist, then the previous song is highlighted and played.

    What doesn't work:
    If I have a notional dir structure such as:
    \mp3
    \80's
    \soft
    ----\mydir1
    ----\mydir2


    If I start at "80's", and then I send "Q" for DirList Up, the dirlisting selection properly moves up. The playlist also updates properly. The playlist window does not appear to have a selected song though. Pressing "Z" (previous) does properly select the first song in that new directory and plays it. Hitting "Z" (previous) again recycles the selection to the last entry, and then it properly continues to cycle backwards through the listing. Doing the same thing again, but instead using "M" for Next selects the 1st song in the playlist, but hitting M again just keeps it stuck advancing to the 1st song. In summary, going Previous ("Z") seems to work properly, but going Next ("M") does not properly function.

    Am I doing something wrong or is this a problem with FP?

    Help is urgently appreciated. I've spent alot of $$$ and time tearing my car apart to add a SWI-X + IR receivers to make this work. I'd have to have spent all the time and money only to have this last component not work :-(

    Also, the song name being played doesn't properly update at the top. If you switch to another directory and Play is pressed, the new song plays, but its corresponding information does not.

    It appears as if the Directory window becomes unsynchronized with the Playlist window if keyboard shortcuts are used.

    CTRL Z previous
    CTRL X rewind
    CTRL C play
    CTRL V pause
    CTRL B stop
    CTRL N fast forward
    CTRL M next
    , down
    . up
    ; left
    ' right

    w dirlist down
    q dirlist up
    e dirlist select
    a dirlist left
    s dirlist right


    g playlist down
    f playlist up
    t playlist select

    Click to enlarge



  3. #3
    Para Laura thanatos106's Avatar
    Join Date
    Nov 2004
    Location
    Miami Beach,FL U.S.A
    Posts
    3,497
    Firts of all you need to tell us more about the settings in FP, such as what ver, what mode are you using and also what skin!!! (or you want us to guess )

    Also I please ask you no to come with stuff like this "I've spent alot of $$$ and time tearing my car apart to add a SWI-X + IR receivers to make this work. I'd have to have spent all the time and money only to have this last component not work", we all here spended a lot of time and money and friends and girlfriends and fingers and much more doing this, so saying that will no take you enywhere (at least with me)

    Thanatos.
    RexBruMet Skin for FrodoPlayer

    Nissan Aux-in MOD


    Quote Originally Posted by bgoodman
    We're an international forum, post in whatever langauge you like.

  4. #4
    Low Bitrate uptpilot's Avatar
    Join Date
    Jun 2005
    Location
    Oklahoma City
    Posts
    77
    Quote Originally Posted by thanatos106
    Firts of all you need to tell us more about the settings in FP, such as what ver, what mode are you using and also what skin!!! (or you want us to guess )

    Also I please ask you no to come with stuff like this "I've spent alot of $$$ and time tearing my car apart to add a SWI-X + IR receivers to make this work. I'd have to have spent all the time and money only to have this last component not work", we all here spended a lot of time and money and friends and girlfriends and fingers and much more doing this, so saying that will no take you enywhere (at least with me)

    Thanatos.
    Sorry, I didn't mean it that way.

    I have Version 1.0.10 (I believe the latest version). I'm testing the software out on this laptop. I'm running 1.0.9 in my car though, but so far, all the problems have been with 1.0.10, although I had similar problems with older versions. I'm using the default skin that comes with ver.1.0.10. As for modes, this happens when I view the files in directory mode. Again, it's just the default install without any modifications, although I will be using a different skin.

Similar Threads

  1. FP 1.09 Status Report
    By frodobaggins in forum FrodoPlayer
    Replies: 304
    Last Post: 01-29-2006, 04:19 PM
  2. Problem watching movies with FP & Powermate
    By maxxell in forum FP Bug Reports
    Replies: 0
    Last Post: 04-09-2005, 10:36 AM
  3. FP Feature Requests
    By frodobaggins in forum FrodoPlayer
    Replies: 171
    Last Post: 10-15-2004, 01:19 PM
  4. FP Manual - & (need help)
    By frodobaggins in forum FrodoPlayer
    Replies: 10
    Last Post: 06-05-2004, 03:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •