Page 3 of 6 FirstFirst 123456 LastLast
Results 21 to 30 of 52

Thread: Fusion Brain CarPC LT1 dash gauges project

  1. #21
    Newbie
    Join Date
    Aug 2008
    Location
    Decatur Illinois
    Posts
    41
    True, if you want to live with errors of up to 25% at the readings you are most concerned about. I don't care if there is errors at close to 0%. I aim for the highest accuracy overall and the highest accuracy at the readings I am most concerned about. I plan on a maximum of 4% error anywhere with my reading calibrated for minimum error at the critical readings. For temps, pressures I could care less about noise at readings close to zero. It is up to you what you want. I just wanted to point out the down side.

    If you use a constant current source, then these errors go away.

  2. #22
    Constant Bitrate ACCLR8N's Avatar
    Join Date
    Apr 2009
    Location
    Davisburg, MI
    Posts
    195
    I'm seeing all my readings fluctuating 0.15-0.2V on the virtual brain and on my gauges. It usually takes a 15 or 20 average to stabilize my display. I'm using the FB 5V out in most cases for the power supply. What are you using to get stable out puts below 1V?

    Tach is comming around. I had the input ground connected to chassis. FB analog input (-) was better, nothing was best. At the moment the Hz to V board is wearing a 220K ohm 1/4 watt. Something is still wrong with my calculated RPM, I'm going to fudge the numbers and reconcile it with my scanner.

    Speedo still likes 140MPH. I'm getting @3V with the VSS input unhooked. 0.5-0.6V on that port with nothing hooked to it. Going to change ports, cables, converter next try.

  3. #23
    Newbie
    Join Date
    Aug 2008
    Location
    Decatur Illinois
    Posts
    41
    I am not seeing the fluctuations you are seeing. I ground any unused inputs, even for testing. I use twisted pair leads to all my sensors and a 0.1uf capacitor to decouple the input. If you have an O-Scope you could look for the source of the noise.

    You could use an LM317 to produce a constant current and have a very accurate output and use the full 5 volt input range of the FB. Bad thing is the LM317 requires at least a 3 volt drop, so you would need to start with 8 volts. Very easy to get an over-voltage to the FB and burn it out. That is why I am not using it.

  4. #24
    Constant Bitrate ACCLR8N's Avatar
    Join Date
    Apr 2009
    Location
    Davisburg, MI
    Posts
    195
    Thanks Fred. I now have 0.1 uF on the Tach and Speedometer inputs and a 1 uF on power input to FB. Getting better. Noise is coming from the engine cooling fans. When both are on they add about 0.15V to my Tach input. Fluctuation on the Tach is now down to 0.03V with fans disabled. Need to figure out what to suppress fans with, 'nuther capacitor?

  5. #25
    Variable Bitrate
    Join Date
    Apr 2004
    Posts
    409
    Quote Originally Posted by ACCLR8N View Post
    I don't think you can do pretty pictures with that. The OBD port doesn't provide oil pressure, fuel level, fuel pressure or idiot lights that I'm looking for. When my scanner is connected, the check engine light is on and the fans run. Does Datamaster do that?
    Your scanner is putting the PCM in program mode. Whenever I flash the eprom in the PCM I get the fans but I don't remember the check engine light. Datamaster on the other hand just reads the data without turning anything on or off. On one PCM I got a bad flash and I had to unsolder the eprom and flash it in a rom burner. I soldered a socket in just in case it happens again. if you need any help setting up datamaster, flashing the PCM or making up an interface cable let me know. Your project is very interesting.

    Chris

  6. #26
    Constant Bitrate ACCLR8N's Avatar
    Join Date
    Apr 2009
    Location
    Davisburg, MI
    Posts
    195

    Success

    Tach and speedo interference was coming from check engine indicator 5V input that was on at same time as fans.

    Tachometer: 4 pulses per revolution. FB F2V modified with a 150K ohm resistor. The F2V board has 3.6-3.7V output limit when powered by the FB 5V. I have a jumper on FB port 1 to block residual voltage getting to port 2 where my tach is connected. There is also a 0.1uF capacitor at the FB connector for decoupling.

    Speedometer: LT1 w/M6 has a 17 pulse per driveshaft revolution VSS. F2V board modified with a 33K ohm. The F2V board didn't like the cleaned sine wave the PCM put out and I had to tap the signal wire between the VSS and PCM. Same as the tach a jumper was placed on port 3 and the speedometer lead on port 4. The input to the FB was also decoupled with a 0.1 uF capacitor. That got it working, but when I stopped the speedo would bounce up to 25-30MPH when sitting still. A 270 ohm resistor and a 0.1 uF cap on the VSS input at the F2V board to FB ground cleared that out. Anyone care to explain why that worked? I'm curious if a 0.01uF cap would allow a larger resistor.

  7. #27
    Newbie
    Join Date
    Oct 2009
    Posts
    6
    what front end are you using for this? if you dont mind me asking

  8. #28
    Constant Bitrate ACCLR8N's Avatar
    Join Date
    Apr 2009
    Location
    Davisburg, MI
    Posts
    195
    The Fusion Brain software, MDX. I create the images with Gimp.

    Goal is MDX on a dash screen for gauges, RR with RRFusion on a center touch screen for radio, HVAC, mirrors...everything else.

  9. #29
    Constant Bitrate ACCLR8N's Avatar
    Join Date
    Apr 2009
    Location
    Davisburg, MI
    Posts
    195

    Where to put it all

    I've pruned away my hanging garden and made my first through hole circuit board. The drivetrain update has left me with the original ECM box that mounted in the dash. Two more FB's needed but most of the wiring is in place. Ready for second FB.
    Attached Images Attached Images   

  10. #30
    Constant Bitrate ACCLR8N's Avatar
    Join Date
    Apr 2009
    Location
    Davisburg, MI
    Posts
    195

    Want brains!

    Got the bugs worked out. Waiting for parts again. Anybody bored with their project and want to let go of a V4 FB? I can't wait to see if the other half of my dash works...

Page 3 of 6 FirstFirst 123456 LastLast

Similar Threads

  1. Replies: 86
    Last Post: 02-23-2011, 06:31 AM
  2. *NEW* USB Input/Output Board -- Fusion Brain
    By 2k1Toaster in forum Fusion Brain
    Replies: 1123
    Last Post: 02-22-2010, 02:33 AM
  3. Fusion Brain and Auto HVAC. h3rk where are you?
    By Willn in forum Fusion Brain
    Replies: 4
    Last Post: 04-17-2009, 09:08 AM
  4. need help on fusion brain 25A Relay wireing
    By wethecom in forum Power Supplies
    Replies: 2
    Last Post: 09-01-2008, 02:59 PM
  5. The Vectra CarPC / CarPuter Project v2
    By ccsnet in forum Show off your project
    Replies: 28
    Last Post: 08-29-2005, 05:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •