Page 26 of 33 FirstFirst ... 161718192021222324252627282930313233 LastLast
Results 251 to 260 of 328

Thread: Fusion Brain Version 6 -- Beta Testing

  1. #251
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    Delete your UserConfig.xml

    it has debug code in it. Best to start fresh, or just edit out that line as described above.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  2. #252
    Constant Bitrate
    Join Date
    May 2006
    Posts
    116
    That got rid of the info boxes along with all the screen buttons etc.

    I add a sensor and it recognized there was a temperature sensor and offered it as a choice and offered F or C. I selected F.

    The outpur that it generates on the screen is -4.923F.

    Is the sensor bad or do I need to modify the code?

  3. #253
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    Quote Originally Posted by waltersaegir View Post
    That got rid of the info boxes along with all the screen buttons etc.

    I add a sensor and it recognized there was a temperature sensor and offered it as a choice and offered F or C. I selected F.

    The outpur that it generates on the screen is -4.923F.

    Is the sensor bad or do I need to modify the code?
    Select Celcius and see what the temperature reports. If it is something between 20 and 26, it is probably working fine assuming it is indoors with humans.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  4. #254
    Constant Bitrate
    Join Date
    May 2006
    Posts
    116
    The output value for Celsius is -20.531C. Which seems good except for the minus sign. Is the minus sign resulting from some reversed connection somehow?
    One quick thing that I noticed about the Fahrenheit calculation code is that it is using the Celsius value in the calculation and "Initialize___TempSensor___Celcius" likely has not been called. Of course I really don't see how "Initialize___TempSensor___Celcius" for the Celsius calculation output (and other functions) get called. Suppose somewhere in your FuseGL engine.

    BTW: getting rid of that initial file and starting with a blank slate/page makes it easier for me to focus on what can be done without the distraction of the demonstration screen buttons/entries that I found confusing as to what they were and what to do with them.
    Last edited by waltersaegir; 12-10-2011 at 11:42 AM.

  5. #255
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    Quote Originally Posted by waltersaegir View Post
    The output value for Celsius is -20.531C. Which seems good except for the minus sign. Is the minus sign resulting from some reversed connection somehow?
    One quick thing that I noticed about the Fahrenheit calculation code is that it is using the Celsius value in the calculation and "Initialize___TempSensor___Celcius" likely has not been called. Of course I really don't see how "Initialize___TempSensor___Celcius" for the Celsius calculation output (and other functions) get called. Suppose somewhere in your FuseGL engine.

    BTW: getting rid of that initial file and starting with a blank slate/page makes it easier for me to focus on what can be done without the distraction of the demonstration screen buttons/entries that I found confusing as to what they were and what to do with them.
    If you look in the userconfig, you will see where the celcius initialization gets called. The sensor along with the rest of the world is a celcius. So the sensor reports back the value in C. If you want it in F, then you have to convert it to F, which is what it does.

    -20C means 0v. You don't have it hooked up to the right port, or you have it hooked up backwards. The red wire is +.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  6. #256
    Constant Bitrate
    Join Date
    May 2006
    Posts
    116
    No difference.

    I *did* have it backwards from the recent fumbling/testing, but upon reversing and restarting several times it has the same output.

    If you remember the pesty debug box that kept popping-up, it read 0.832v and 0 when the sensor was disconnected.

    Fired-up a 6/18 version of FuseGL and the box at the bottom of the screen displayed 0.800 to 0.794 varying just like from the first try months ago, then it did the Auto-Update, restarted and continued to display 0.800 to 0.794

    Yikes! Just added *another* output box and noticed that the *first* index that it asked-for was Fusion Brain Index and *this* time I input "0" and then "001" for the AI index.

    *Now* I see output of 20.347C to 20.513C

    Next I will try a Fahrenheit box. I expect it will now work.
    Last edited by waltersaegir; 12-10-2011 at 01:28 PM.

  7. #257
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    (0.8 - 0.4) / 0.0195 ~= 20.5C or 68F to 70F.

    Sound about right?
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  8. #258
    Constant Bitrate
    Join Date
    May 2006
    Posts
    116
    Fahrenheit looks good, but the font on the Button is not scaled.

    Name:  FuseGLwalt.JPG
Views: 114
Size:  68.8 KB

  9. #259
    Constant Bitrate
    Join Date
    May 2006
    Posts
    116
    Quote Originally Posted by 2k1Toaster View Post
    You will need either the isolator/divider board or build your own resistor divider network for 12v. Using 12v direct will explode your FB.
    I'll order that with the Relay Pack.
    Last edited by waltersaegir; 12-10-2011 at 05:32 PM.

  10. #260
    Newbie
    Join Date
    May 2011
    Posts
    8
    Hi, I have issue with my fusion brain 6

    if I tried to set more than 3 output ON on the same time (or even of there was 2 output ON and tried to set one more output ON) it freeze and I can't set anything ON/OFF unless if I plug out the USB and the power
    but that only if I use power supply and it did not happen when I use USB only

    the power supply output: DC 12v 300mA max && I use FuseGL and hyperterminal and it same .

    how I can solve this ?

Similar Threads

  1. ** NEW Fusion Brain Version 6, Pre-Order NOW **
    By 2k1Toaster in forum Fusion Brain
    Replies: 259
    Last Post: 04-07-2013, 03:48 PM
  2. Fusion Brain version 4
    By MattFreitag in forum Fusion Brain
    Replies: 7
    Last Post: 08-01-2010, 05:32 PM
  3. Fusion Brain -- Digital Encoder Beta Test
    By 2k1Toaster in forum Fusion Brain
    Replies: 52
    Last Post: 09-18-2009, 03:11 PM
  4. Fusion Brain Version 4 Manual
    By greenman100 in forum FB Documentation and Tutorials
    Replies: 0
    Last Post: 12-19-2008, 03:11 PM
  5. Fusion Brain Version 4 ready for Beta Testers!
    By greenman100 in forum Fusion Brain
    Replies: 15
    Last Post: 11-13-2008, 11:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •