Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: [Release] GammaControl v.2

  1. #1
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516

    Exclamation [Release] GammaControl v.2

    Download GammaControl v.2

    NEW:
    • Tray Icon
    • More stuff in menu
    • Automatic Gamma change based on time
    • only 2 settings that have to be configured manually (Open minimized, and minimize to tray)


    GammaControl will check every 5 seconds if your time is less than that of the last value, if it is not then it will go to the next value until it finds one.

    Important! Arrange the date/time/month/etc in reverse chronological order! Otherwise you will get an ugly screen refresh!

    INI Example:
    Code:
    [gamma]
    gamma0_month=12
    gamma0_day=24
    gamma0_hour=23
    gamma0_minute=25
    gamma0_value=255
    
    gamma1_month=10
    gamma1_day=25
    gamma1_hour=0
    gamma1_minute=15
    gamma1_value=255
    
    gamma2_month=10
    gamma2_day=24
    gamma2_hour=23
    gamma2_minute=25
    gamma2_value=-143
    The 0, 1, and 2 represent the date's number. Month, day, hour (24 hour), minute are self explanitory. They are in reverse chronological order.

    Long term project: make a program that will convert the website that gives the rise/set right into gamma settings. To make it easier, I'll make GammaControl read the day and night values.

  2. #2
    Low Bitrate fireball106's Avatar
    Join Date
    Jul 2004
    Location
    Israel
    Posts
    78
    Let me try to help with that ATI thingy...
    I'm using a relatively new version of Catalyst, I can surely change them, but out of curiosity let's try to solve these out (for me, and for the rest of the ATI owners).

    I installed the following drivers:
    wxp-w2k-catalyst-7-991-040224m-013831c.exe

    I posted 2 screenshots of my driver.
    Attached Images Attached Images   
    Lior "Fireball"

  3. #3
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    Quote Originally Posted by fireball106
    Let me try to help with that ATI thingy...
    I'm using a relatively new version of Catalyst, I can surely change them, but out of curiosity let's try to solve these out (for me, and for the rest of the ATI owners).

    I installed the following drivers:
    wxp-w2k-catalyst-7-991-040224m-013831c.exe

    I posted 2 screenshots of my driver.
    Told you to update the drivers. You're using Catalyst 4.3 according to this place. Version 4.4 has it fixed I think. And we're on version 4.7 or higher already.

    What I'm saying is that your drivers ARE the problem, and updating them should solve it IMO, and other's too. Even ATI says that gamma has problems under the 4.3 drivers Sorry for forcing you to do a big download

  4. #4
    Low Bitrate fireball106's Avatar
    Join Date
    Jul 2004
    Location
    Israel
    Posts
    78
    Okay, I'll update them and report

    ATI ->
    Lior "Fireball"

  5. #5
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    Quote Originally Posted by fireball106
    Okay, I'll update them and report

    ATI ->
    Cool. I sincerely hope that this solves your problems

    Here's the ATI flame thread I was talking about

  6. #6
    Low Bitrate fireball106's Avatar
    Join Date
    Jul 2004
    Location
    Israel
    Posts
    78
    1. I installed the new ATI drivers, now I *can* adjust the Gamma using your program!

    2. The slider seems to act weird! the original (medium setting) is fully on the right side, when sliding to the middle it gets brighter, then suddenly it getting darker and darker.
    Means: rightmost is the default settings, middle is the brightest, leftmost is the darkest.
    Anyone encounted this?

    3. All the remember/restore buttons does not seem to work. My gamma.ini looks this way now:
    [Settings]
    Night=50
    Day=-255
    But still, I get no affect when pressing the buttons.

    I think this is all weird ATI ****
    Lior "Fireball"

  7. #7
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    Quote Originally Posted by fireball106
    1. I installed the new ATI drivers, now I *can* adjust the Gamma using your program!

    2. The slider seems to act weird! the original (medium setting) is fully on the right side, when sliding to the middle it gets brighter, then suddenly it getting darker and darker.
    Means: rightmost is the default settings, middle is the brightest, leftmost is the darkest.
    Anyone encounted this?

    3. All the remember/restore buttons does not seem to work. My gamma.ini looks this way now:
    [Settings]
    Night=50
    Day=-255
    But still, I get no affect when pressing the buttons.

    I think this is all weird ATI ****
    YES! I knew it was crappy ATI drivers!
    I know about the slider thing, its because I use two different algorythms, one for darker, and one for lighter. But the slider is JUST for config.
    The remember/restore buttons remember yoru original gamma before playing with the program. In other words, they are useless. I should disable the set buttons w/o the slider visible.

    BTW: To be fair, its not ATI's fault that the screen gets brighter/darker while adjusting the slider, that's just my coding.

  8. #8
    FLAC IntellaWorks's Avatar
    Join Date
    Jun 2004
    Location
    NH
    Posts
    1,173

    .

    Thanks for this, I havent actually tried it yet but I've been meaning to do the same thing.. But now I dont have do.. one less thing to check off my list of 100000000000 things to do.
    Progress [I will seriously never be done!]
    Via EPIA MII
    512MB RAM
    OEM GPS (embedded)
    nLite WinXP pro on
    1GB Extreme III CF card
    Carnetix 1260 startup/ DC-DC regulator
    Software: Still, re-Writing my existing front end in .Net

  9. #9
    My Village Called 0l33l's Avatar
    Join Date
    Jul 2004
    Location
    Berkeley, CA
    Posts
    10,516
    Quote Originally Posted by IntellaWorks
    Thanks for this, I havent actually tried it yet but I've been meaning to do the same thing.. But now I dont have do.. one less thing to check off my list of 100000000000 things to do.


    BTW: Your sig says voice recognition (including the song list). How'd you get this?

  10. #10
    FLAC IntellaWorks's Avatar
    Join Date
    Jun 2004
    Location
    NH
    Posts
    1,173

    .

    Using SAPI 5.1's XML file feature, I created an XML file that's loaded into sapi (instead of using its own dictionary) the XML file acts as a "custom" dictionary with only artist and song name collectively. SAPI then can interpert this and improve accuracy on complicated songnames such as: "Megalomaniac"

    I can send you an example XML file just PM me. You can enter it into SAPI's test tool and try a song name.
    Progress [I will seriously never be done!]
    Via EPIA MII
    512MB RAM
    OEM GPS (embedded)
    nLite WinXP pro on
    1GB Extreme III CF card
    Carnetix 1260 startup/ DC-DC regulator
    Software: Still, re-Writing my existing front end in .Net

Page 1 of 2 12 LastLast

Similar Threads

  1. [Release] GammaControl v1.2
    By 0l33l in forum GammaControl
    Replies: 64
    Last Post: 07-31-2005, 03:16 AM
  2. [Release] GammaControl v1.0
    By 0l33l in forum GammaControl
    Replies: 2
    Last Post: 04-17-2005, 10:20 PM
  3. [Release] GammaControl v.7
    By 0l33l in forum GammaControl
    Replies: 11
    Last Post: 02-07-2005, 01:04 AM
  4. [Release] GammaControl v.4
    By 0l33l in forum GammaControl
    Replies: 8
    Last Post: 11-10-2004, 06:32 PM
  5. [Release] GammaControl v.3
    By 0l33l in forum GammaControl
    Replies: 19
    Last Post: 11-09-2004, 04:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •