Results 1 to 5 of 5

Thread: USB Devices, and Hibernation / Suspend to RAM

  1. #1
    Variable Bitrate
    Join Date
    Jun 2002
    Location
    Norway
    Posts
    310

    USB Devices, and Hibernation / Suspend to RAM

    Anybody else that has had any problem coming out of Suspend To Ram / Hibernation, and the USB human Interface (keypad) is not responding. ? .. I have to restart the carputer, to get the Keypad working...

    crappy ...



    Regards

    Richard
    "If A equals success, then the formula is: A=X+Y+Z. X is work. Y is play. Z is keep your mouth shut."
    Albert Einstein

  2. #2
    Low Bitrate
    Join Date
    Jun 2002
    Location
    UK
    Posts
    65
    I had the same problem with a usb-rs232 convertor that I used for gps. Never did find an answer ...

  3. #3
    Variable Bitrate
    Join Date
    Jun 2002
    Location
    Norway
    Posts
    310
    arg.... it really ****es me off.. its the one thing, that makes my setup incomplete I cant controll anything with the keypad after i resume from standby, and I do not want to restart the carputer everytime I start up the car...




    I'we read about some fixes, or updates on Microsoft.com .. but I cant find the same page ... (its impossible to find anything at Microsoft.com)


    Richard
    "If A equals success, then the formula is: A=X+Y+Z. X is work. Y is play. Z is keep your mouth shut."
    Albert Einstein

  4. #4
    Constant Bitrate
    Join Date
    Jun 2002
    Location
    TN
    Posts
    196
    I found that when I came out of hibernation my USB-Serial for my GPS did not work. Restarting will fix it, but I also found that if you unplug it, and plug it back in it comes up fine. So I wonder if you could rig some sort of relay to allow you to do this automatically... have not looked into that yet though.

  5. #5
    Variable Bitrate
    Join Date
    Jun 2002
    Location
    Norway
    Posts
    310
    I'we noticed that to re-hot plug the device also brings it back... (as well for a restart) .. .but.. Iwe read that the problem is some sort of a "state" problem in registry in windows.. ie. before hibernation, the state of a usb device could be something like this:

    xxx.xx.xxx..xxxx.1 .. and after hibernation / suspend the number one would change to "2" ... which would make windows not correctly "talk" to the device ...

    anyway..

    its really a pain ... iwe finally got Girder up and running, with alot of sweet solutions for controlling my carputer, and everytime I, either have to hot plug the device or restart the carputer

    arg..


    Richard
    "If A equals success, then the formula is: A=X+Y+Z. X is work. Y is play. Z is keep your mouth shut."
    Albert Einstein

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •