Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Computer and amps not turning on, very temperamental.

  1. #21
    Constant Bitrate
    Join Date
    May 2009
    Location
    Hampshire, England
    Posts
    156
    so confused lol, but I do know that when I drop the clutch, the power steering also almost stops working.
    Also I have a Fiat Brava 1.2, 16V, X Reg (2000)

    Hopefully it's a loose belt of something (nice n cheep).

    So have we ruled out the battery?

    Also, I have a bad feeling that it is the alternator, if so, what do I need to look for?
    I think what I need to look for is a brava/brava/marea 95-01 alternator =S
    But do I need to get right powers n shiz as well? should I get a more powerful one to power my stuff? most importantly, who sell them? can't find em anywhere. :'(
    Car: Ford Focus
    Currently stock setup. Trying to decide on the best setup for me.

  2. #22
    FLAC freeflashstuff's Avatar
    Join Date
    May 2008
    Location
    Socorro, New Mexico, United States
    Posts
    1,142
    If the power steering goes when you drop the clutch, then it may be the belt. That is the cheapest fix; I'd go for it first, then the next expensive one, etc. then go from there.
    I have bad luck with vehicles...

  3. #23
    Constant Bitrate
    Join Date
    May 2009
    Location
    Hampshire, England
    Posts
    156
    yay, fixed.

    My Dad cleaned the injection and now it works fine, starts up a lot smoother as well.

    Also I redid the grounding. I cleaned up the 1st grounding point that I originally had and it worked fine, but to be on the safe side I made another grounding point .

    Doesn't it feel great when something works =P
    Car: Ford Focus
    Currently stock setup. Trying to decide on the best setup for me.

Page 3 of 3 FirstFirst 123

Similar Threads

  1. M1-ATX not timing, not turning on PC
    By sYx66 in forum Power Supplies
    Replies: 2
    Last Post: 02-20-2006, 09:13 AM
  2. Amps Protecting at high volumes
    By kdunn926 in forum Car Audio
    Replies: 1
    Last Post: 08-30-2005, 09:14 PM
  3. Amps power up AFTER computer is on and still pops
    By Ascension in forum Car Audio
    Replies: 5
    Last Post: 07-16-2005, 02:24 AM
  4. Replies: 13
    Last Post: 04-15-2005, 02:55 PM
  5. Anyone running their computer AND amps off the Opus?
    By brrman in forum Power Supplies
    Replies: 12
    Last Post: 12-09-2003, 01:30 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •