Page 5 of 9 FirstFirst 123456789 LastLast
Results 41 to 50 of 83

Thread: BoomzBox HD Radio. Not quite a review, more of a progress report.

  1. #41
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    Quote Originally Posted by mitchjs View Post
    kev000, that modprobe stuff, what do u do with it..
    type it when you boot? thats ugly
    is there a system file you put that stuff in?
    You open up a terminal and you type it in. After that, it should just work, on every reboot.

    the udev rule should go in a file 10-boomzbox.rules and installed to /etc/udev/rules.d. When mal is finished with his lib, i'll probably create a linuxice package that does all this.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  2. #42
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,263
    kev000, great...

    i prob need to make a VM of LinuxICE
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  3. #43
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    Quote Originally Posted by mitchjs View Post
    i just noticed

    the file http://www.ftdichip.com/Drivers/VCP/...io_vid_pid.tar
    contains the souce code
    the PIDS are in the .h
    and added to a struct in .c

    instructions are here
    http://www.ftdichip.com/Documents/Te..._FT_000106.pdf

    could you add some in? and compile it?
    would that help?

    provding the binary driver with the pid in it
    for linux users

    i dont know

    or should each linux user just compile it him/herself
    If you want Linux support in the kernel driver out of the box, you need to patch that file, and submit the patch to the kernel developers or the maintainer of that code. The maintainer probably has a git repo somewhere. If you can find that out for me, I can see about patching it and pushing it to the maintainer.

    The problem will be that it will be in future kernel versions (probably 2.6.34+) which won't help LinuxICE users or any current users of any linux distro. The only option for them is to do the modprobe thing and force the current ftdi_sio driver to work with this device.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  4. #44
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,263
    ok, you know better than me...

    but why wouldnt it help future kernel versions?

    ok, this is the dev

    http://ftdi-usb-sio.sourceforge.net/

    but that code looks OLD
    the one at FTDI's download (i posted link above) is MUCH MUCH newer

    man i cant tell... it looks like a dead project


    but for sure one can add the pids, and make the ftdi_sio driver, and copy it to their system modules

    also, isnt this driver in LINUXICE? cant you just patch it there?
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  5. #45
    And then I was mod. Tidder's Avatar
    Join Date
    Sep 2003
    Location
    New Mexico, USA
    Posts
    4,207
    Quote Originally Posted by mitchjs View Post
    you cannot EDIT .inf files on WINDOWS OSes
    they are digitially signed (A REALLY SMART THING)
    MS put thier foot down, to poorly written drivers
    all drivers must be WHQL and signed, for x64 os and ALL servers OS
    and warnings will be given on x86 os(for now)
    Really? That's odd... I wonder how I've been getting away with it this whole time. I use hacked up inf's for laptop nVidia adapters to work with the latest desktop drivers, I use hacked up x64 Vista infs that I did myself for huawei Alltel data cards to work with XP 64-bit... surely I didn't sign them before I decided to use them.

    I'm sure these guys don't sign their infs... http://www.laptopvideo2go.com/

    I loaded OpenVPN a couple days ago on windows 7... the drivers aren't signed by MS but they still worked... how weird. I've been using them for years on server 2003...

    I must have found a loophole?

    For someone who writes drivers you sure are ignorant. Perhaps you've read misleading information. Or perhaps I'm bending the matrix, realizing there is no spoon...
    Tidder

    Try RevFE
    The best resurrected frontend I've ever used, period.

  6. #46
    licensed to kill - FKA kev000
    Auto Apps:loading...
    tripzero's Avatar
    Join Date
    Aug 2006
    Location
    16.40618, 120.61106
    Posts
    2,494
    Quote Originally Posted by mitchjs View Post
    ok, you know better than me...

    but why wouldnt it help future kernel versions?

    ok, this is the dev

    http://ftdi-usb-sio.sourceforge.net/

    but that code looks OLD
    the one at FTDI's download (i posted link above) is MUCH MUCH newer

    man i cant tell... it looks like a dead project


    but for sure one can add the pids, and make the ftdi_sio driver, and copy it to their system modules

    also, isnt this driver in LINUXICE? cant you just patch it there?
    My guess is that the driver is maintained directly in the kernel source tree. It would be helpful for future kernels, yes. I do maintain the LinuxICE kernel, so i could patch it there. that's a good idea.
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  7. #47
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,263
    Quote Originally Posted by Tidder View Post
    Really? That's odd... I wonder how I've been getting away with it this whole time. I use hacked up inf's for laptop nVidia adapters to work with the latest desktop drivers, I use hacked up x64 Vista infs that I did myself for huawei Alltel data cards to work with XP 64-bit... surely I didn't sign them before I decided to use them.

    I'm sure these guys don't sign their infs... http://www.laptopvideo2go.com/

    I loaded OpenVPN a couple days ago on windows 7... the drivers aren't signed by MS but they still worked... how weird. I've been using them for years on server 2003...

    I must have found a loophole?

    For someone who writes drivers you sure are ignorant. Perhaps you've read misleading information. Or perhaps I'm bending the matrix, realizing there is no spoon...

    XP 64bit is OLD, and doesnt have that RULE
    server 2003 like XP is a OLD OLD, operating system.
    (from 2002)

    todays modern OSes:

    VISTA and WINDOWS 7 and SERVER 2008

    ALL require driver signing from Winqual to be legit on X64 systems (AND EVEN LOAD)
    and x86 too, or you will get a warning

    all this is to keep driver quality up, AND tampering(malware) down


    and there is NO legit way around it

    tidder, so you can learn

    http://www.microsoft.com/whdc/winlog...n/drvsign.mspx
    just read the bullets

    and besides, if i didnt HAVE to sign them, i wouldnt have spent the $1k with MS to do it
    but I want a professional product, with drivers that are trusted, and work on win 7 x64
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  8. #48
    And then I was mod. Tidder's Avatar
    Join Date
    Sep 2003
    Location
    New Mexico, USA
    Posts
    4,207
    Quote Originally Posted by mitchjs View Post

    tidder, so you can learn

    http://www.microsoft.com/whdc/winlog...n/drvsign.mspx
    just read the bullets
    Thanks but I already know that. I'll however still stick to my real-world experience than what some paper says I can or cannot do.
    Tidder

    Try RevFE
    The best resurrected frontend I've ever used, period.

  9. #49
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,263
    malcom,

    read
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/460857
    says FTDI_SIO is fixed for ubunto kernel, i dont know how to get the fix... confuses the heck out of me

    in kernel 2.6.31-18 or -17 too

    if i download ubunto 9.10, how do i update to that kernel?
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  10. #50
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,127
    Quote Originally Posted by mitchjs View Post
    malcom,

    read
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/460857
    says FTDI_SIO is fixed for ubunto kernel, i dont know how to get the fix... confuses the heck out of me

    in kernel 2.6.31-18 or -17 too

    if i download ubunto 9.10, how do i update to that kernel?
    Installing updates in Karmic-proposed fixes that issue, however that issue is unrelated to any issues we are discussing here.
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

Similar Threads

  1. HDZ300 Zoom HD Radio + Mitch's HD Cable
    By Iceplayagt14 in forum Classifieds
    Replies: 2
    Last Post: 11-08-2008, 08:12 AM
  2. HD Radio + Latest Road Runner not working for me
    By BlackStealth in forum Road Runner
    Replies: 11
    Last Post: 09-28-2008, 02:00 PM
  3. HD Radio
    By pcullin in forum Car Audio
    Replies: 2
    Last Post: 09-01-2008, 12:31 PM
  4. Which EQ for HD radio?
    By ccrum in forum RR Skins
    Replies: 4
    Last Post: 06-24-2008, 11:26 AM
  5. Phx Area HD Radio Question
    By 99WhiteSleeper in forum Car Audio
    Replies: 1
    Last Post: 06-23-2008, 12:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •