Page 8 of 9 FirstFirst 123456789 LastLast
Results 71 to 80 of 83

Thread: BoomzBox HD Radio. Not quite a review, more of a progress report.

  1. #71
    MySQL Error
    Auto Apps:loading...

    Join Date
    Oct 2004
    Posts
    5,261
    not pratical, and the libusb32 is not x64 friendly and not WHQL
    and i wanted it to be a comport for backwards compatibility with older hd radio applications that already exist

    but libusb could be usefull for other stuff i do, if someone wanted to do it on non windows platforms, thanks for that link

    drivers for this are in the newest linux kernels and windows platform
    for mac its there to, but end user has to edit a file for vid and pid... but mac people are used to working around things like that...
    -Thanks
    Mitch
    www.rush2112.net

    "Did you test it in carwings??"

    Sun, Come shine my way
    May healing waters bury all my pain
    Wind, Carry me home
    The fabric of reality is tearing apart
    The piece of me that died
    Will return To live again

  2. #72
    SuperMod - OBDII GPS Logger forum
    Auto Apps:loading...

    Join Date
    Mar 2009
    Location
    Los Angeles
    Posts
    924
    The point of doing it this way is that it's entirely userspace. No WHQL necessary. Good point about win64, but a brief bit of googling indicates that libusb-win32 apparently can work on win64 with minimal hassle.

    Anyways. This is just me subscribing to the attitude that with the right tools, all this platform-specificcery is just completely unnecessary, and heartache. I also like C and C APIs :-)

    Gary (-;
    OBDGPSLogger, for logging OBDII and/or GPS data
    OBDSim, an OBDII/ELM327 software simulator
    mp3car forums: obdgpslogger, obdsim

  3. #73
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    91
    Confusion, i has it.. no surprises there am i right?

    So first I really have to admit.. I am to a large extent a neophyte to linux. I always tend to end up in a situation like this where pretty much everything on the assistance side assumes a larger degree of knowledge than I have.

    So disclaimer out of the way. I am running Ubuntu 10.04. I power up and plug in the boomzbox and it attached to ttyUSB0 according to dmesg

    micah-xb@micah-xb-Brain:~$ dmesg | grep ftdi
    [ 6652.565608] ftdi_sio 4-1.1:1.0: FTDI USB Serial Device converter detected
    [ 6652.567304] usbcore: registered new interface driver ftdi_sio

    micah-xb@micah-xb-Brain:~$ dmesg | grep ttyUSB0
    [ 6652.567242] usb 4-1.1: FTDI USB Serial Device converter now attached to ttyUSB0

    so that's all well and good.
    I'm also getting "junk" off the connection

    micah-xb@micah-xb-Brain:~$ cat /dev/ttyUSB0
    ��p�������� �����p���������~���������������������� ������������������^C

    great... ok, now what? how do i point this to an application? I grabbed the radiotest from this thread and get a form that is asking for a comport. So im guessing i need to point /dev/ttyusb0 to a comport somehow.

    in the linux fdti driver docs in this thread I apparently need to uninstall brltty to access a virtual comport.. which i did, but ok.. then what?
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  4. #74
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,127
    chronoglass: I never really wrote a test app for this, however there is a Qt libboomzbox in the works and an alpha native linux player application. /dev/ttyUSB0 is technically a com port, however I have not tested that app in linux, so I'm not sure how good WINE is with virtual com ports.

    Another option, you could take the source and compile it in Mono, and see if it works?

    As soon as I can get Qt-Multimedia working as I would like it to, I'll have a native app for you all
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

  5. #75
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    91
    i tried that with the C# file and got a few errors missing references.. But i'll see what can happen with the sln.. im guessing it's going to look about the same (form1 with a bunch of buttons that don't work/display anything) (yup, turned out the same)

    but basically, it's seeming like this might just be another "not working in linux YET" thing?
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  6. #76
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,127
    Quote Originally Posted by chronoglass View Post
    i tried that with the C# file and got a few errors missing references.. But i'll see what can happen with the sln.. im guessing it's going to look about the same (form1 with a bunch of buttons that don't work/display anything) (yup, turned out the same)

    but basically, it's seeming like this might just be another "not working in linux YET" thing?
    Yeah the c# file was not meant to run in Linux, and is a stop-gap for windows developers so they can get development done until I get the c++ library working :P
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

  7. #77
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    91
    heh, reading through this thread it LOOKED like it was working and I was just an idiot. I'm glad im not quite as dumb as I thought. However the store does point to this thread for "linux support" on the product page. heh

    thanks for the quick replies
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  8. #78
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,127
    Hmm, I didn't know it actually pointed to this for linux support. I'll see if I can't get at least a test radio app available for download soon.
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

  9. #79
    Constant Bitrate chronoglass's Avatar
    Join Date
    Nov 2009
    Posts
    91
    So for the sake of argument, I started poking at your code in radiotest.zip in mono.. and maybe someone with a bit more knowledge with mono could pipe up, but the button to "power on hd device" is giving me an error stating that the function isn't implemented yet.

    the poweron() doesn't appear to call anything crazy though

    Thread m_loopThread;
    public bool PowerOn()
    {
    m_loopThread = new Thread(new ThreadStart(threadLoop));
    m_loopThread.Start();
    return true;
    }
    ---------
    I'll do the bumbling, and i'll be the idiot.
    if you've got a "stupid" question, search for some of mine!

  10. #80
    Newbie
    Join Date
    Jul 2010
    Posts
    1
    Quote Originally Posted by malcom2073 View Post
    chronoglass: I never really wrote a test app for this, however there is a Qt libboomzbox in the works and an alpha native linux player application. /dev/ttyUSB0 is technically a com port, however I have not tested that app in linux, so I'm not sure how good WINE is with virtual com ports.

    Another option, you could take the source and compile it in Mono, and see if it works?

    As soon as I can get Qt-Multimedia working as I would like it to, I'll have a native app for you all
    You mention doing things with Qt which is great. Are you aware of the Qt Mobility APIs for Radio Control? http://doc.qt.nokia.com/qtmobility-1...ercontrol.html. How easy would it be to implement a backend for these APIs to connect to BoomBox?

    Let me know if you need any help with Qt Multimedia.

Similar Threads

  1. HDZ300 Zoom HD Radio + Mitch's HD Cable
    By Iceplayagt14 in forum Classifieds
    Replies: 2
    Last Post: 11-08-2008, 08:12 AM
  2. HD Radio + Latest Road Runner not working for me
    By BlackStealth in forum Road Runner
    Replies: 11
    Last Post: 09-28-2008, 02:00 PM
  3. HD Radio
    By pcullin in forum Car Audio
    Replies: 2
    Last Post: 09-01-2008, 12:31 PM
  4. Which EQ for HD radio?
    By ccrum in forum RR Skins
    Replies: 4
    Last Post: 06-24-2008, 11:26 AM
  5. Phx Area HD Radio Question
    By 99WhiteSleeper in forum Car Audio
    Replies: 1
    Last Post: 06-23-2008, 12:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •