Results 1 to 4 of 4

Thread: USB Devices Disconnect

  1. #1
    Low Bitrate capcadetjc's Avatar
    Join Date
    May 2008
    Location
    Lubbock, TX
    Posts
    108

    USB Devices Disconnect

    I have a few devices plugged into a USB hub that is on a USB extension. Sometimes these devices disconnect and it takes a system restart to get them to work again. Could this be because they are not getting enough power or because the hub is not getting enough power?


    Thanks for any help.

    By the way, devices not plugged into that hub dont have that problem. I have the other devices plugged into a hub that is plugged into an active USB extension cable and have few problems with them. Those include the USB touch screen control, USB keyboard receiver, and USB Clear Modem (occasionally disconnects from the network but could be due to motion Im guessing).
    My 2007 Jeep Wrangler Worklog

  2. #2
    FLAC
    Join Date
    Jun 2006
    Location
    Calgary, Alberta
    Posts
    1,237
    Blog Entries
    1
    Check the voltage. What are you powering your USB hub from? I know I have this problem with my 7 port USB hub and M2-ATX psu. The M2 doesnt seem to be able to handle high loads on the +5v rail very well. If your USB extension is long, it could also be dropping the voltage.

  3. #3
    Low Bitrate capcadetjc's Avatar
    Join Date
    May 2008
    Location
    Lubbock, TX
    Posts
    108
    I think thats the problem. With that added length and it being just a generic 4 port hub with no extra power source its just too weak. I guess Ill have to save up and buy a good powered one for there.
    My 2007 Jeep Wrangler Worklog

  4. #4
    Maximum Bitrate Crinos's Avatar
    Join Date
    Mar 2009
    Location
    Kristiansand, Norway
    Posts
    483
    Powered hub's is ALWAYS a must. Unless your just plugging devices with their own power source.

Similar Threads

  1. Hardware Review: 4-Port USB Hub CNX-P5USB
    By Sonicxtacy02 in forum The Review Palace
    Replies: 1
    Last Post: 12-11-2009, 05:02 AM
  2. Windows XP Hangs when Resuming from Hibernation Only When USB Devices Plugged In
    By tbird2340 in forum Software & Software Development
    Replies: 5
    Last Post: 10-30-2009, 10:37 PM
  3. So many devices, so few USB ports
    By JLemieux in forum Newbie
    Replies: 5
    Last Post: 10-18-2007, 10:54 PM
  4. No USB Devices Working Out of the Blue
    By tbird2340 in forum General MP3Car Discussion
    Replies: 6
    Last Post: 10-17-2007, 12:21 PM
  5. USB devices die off in 20 min. HELP ?
    By anik321 in forum General Hardware Discussion
    Replies: 5
    Last Post: 08-04-2005, 10:01 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •