Page 2 of 6 FirstFirst 123456 LastLast
Results 11 to 20 of 57

Thread: Serial PC Interface for HD Radio (Directed) - DIY??

  1. #11
    Newbie
    Join Date
    Jul 2012
    Posts
    11
    Can you send me a list of parts you used to make your cable?

  2. #12
    Variable Bitrate we87's Avatar
    Join Date
    Nov 2005
    Location
    Dallas, TX
    Posts
    404
    I finally built the cable, and I am trying to find a TEST program to make sure I did everything correctly.

    My PC is actually in the back on my car so instead of tearing everything out just so I could connect the antenna to the Directed box, I just connected everything else to make sure the cable is functioning properly... Is there a PC program I can download that will initialize the HD radio box just so I can confirm my cable is working before I have my dash apart just for the antenna?
    Carputer Progress
    [||||||||||] 100%
    Finally Installed!!
    Everything is in the car and working.
    I painted the cilpboard mount and it looks good.
    Shutdown/Startup is working excellent!
    View My Progress Here

  3. #13
    FLAC SNOtwistR's Avatar
    Join Date
    Nov 2009
    Location
    Keswick,On Canada
    Posts
    1,619
    you can get from mitch's site here http://www.rush2112.net/phpBB3/portal.php they work excellent SNO

  4. #14
    Variable Bitrate we87's Avatar
    Join Date
    Nov 2005
    Location
    Dallas, TX
    Posts
    404
    Quote Originally Posted by SNOtwistR View Post
    you can get from mitch's site here http://www.rush2112.net/phpBB3/portal.php they work excellent SNO
    Are you talking about the SatAmp program? That will work and talk to the HD Radio box thru the cable I made (from this thread) even though its not Mitch's cable?
    Carputer Progress
    [||||||||||] 100%
    Finally Installed!!
    Everything is in the car and working.
    I painted the cilpboard mount and it looks good.
    Shutdown/Startup is working excellent!
    View My Progress Here

  5. #15
    FLAC SNOtwistR's Avatar
    Join Date
    Nov 2009
    Location
    Keswick,On Canada
    Posts
    1,619
    Yes it will or use hd-pcr from same site both will do the job SNO

  6. #16
    Constant Bitrate
    Join Date
    Mar 2011
    Location
    Ohio
    Posts
    153
    HD Radio works pretty good in Driveline for the little bit if testing that I have done. One fault that I had was somehow even though I have no DAB radio, the input was active and tied to line in, caused some weird stuff.

  7. #17
    Constant Bitrate
    Join Date
    Mar 2011
    Location
    Ohio
    Posts
    153
    I've also noticed in my testing over the last few days there have been a couple times I booted up and the radio was not found. I have Mitch's cable and the Directed Unit. I found that even though the cable looks like it's plugged completely in, sometimes it wiggles out a little. The radio even clicks like it's powering on, it just can't be found.

  8. #18
    Variable Bitrate we87's Avatar
    Join Date
    Nov 2005
    Location
    Dallas, TX
    Posts
    404
    Well, something is wrong somewhere

    I built the cable with all of the components required (even the bc337 transistor) and the cable does not work. Also, as soon as I plug in the cable I hear the directed hd radio "click" like its powering on. Is this right? Shouldnt only be powered on when my front end or SatApp calls it to power on? BTW I edited my com port 1 in settings to be correct 115 baud rate.

    Secondly, I have no drivers installed. Just Centrafuse and I downloaded SatApp aswell. Should I be using drivers? It wasnt mentioned so I assumed I didnt need any.

    BTW the directed module works fine when I use the included screen to scan channels, and mitchs SatApp picks up my XM satellite radio module just fine. So both are working, so it has to be lack of drivers or the cable itself.
    Last edited by we87; 09-15-2012 at 12:35 AM.
    Carputer Progress
    [||||||||||] 100%
    Finally Installed!!
    Everything is in the car and working.
    I painted the cilpboard mount and it looks good.
    Shutdown/Startup is working excellent!
    View My Progress Here

  9. #19
    Variable Bitrate we87's Avatar
    Join Date
    Nov 2005
    Location
    Dallas, TX
    Posts
    404
    Alright, I have re-built the cable three times thinking some part of my components were bad, still no good.

    I have also downloaded a third app to test with (hdpcr from mitch's site) and still no good.

    I have even played around with the comport settings thinking maybe it was 96 instead of 115, still no good.

    I am following the schematic as good as I know how to. I am no expert by any means but I have built an Shut Down Controller that worked just fine, plus tons of other projects non carpc related, so I understand how to read schematics and solder, etc.... But I will admit I do not fully understand the way transistors in particular work.

    My big question is: Why when I plug in my cable the HD radio box immediately ticks on? I see the 5v connected to pin2 of the DIN thru the resistor, and I cant understand why exactly that is. In my head, that is why inserting the cable triggers the HD box to turn on without the need for the DTR voltage.

    Since the site was translated, perhaps there is a mistake somewhere? Either with the resistor values or even a typo? I am not trying to get spoonfed, I am just asking in this thread because other people here have built this cable successfully, and I am obviously missing something.
    Carputer Progress
    [||||||||||] 100%
    Finally Installed!!
    Everything is in the car and working.
    I painted the cilpboard mount and it looks good.
    Shutdown/Startup is working excellent!
    View My Progress Here

  10. #20
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,127
    Quote Originally Posted by we87 View Post
    My big question is: Why when I plug in my cable the HD radio box immediately ticks on? I see the 5v connected to pin2 of the DIN thru the resistor, and I cant understand why exactly that is. In my head, that is why inserting the cable triggers the HD box to turn on without the need for the DTR voltage.
    When you plug it in, WITHOUT the application running it does that? The purpose of the 1k resistor is to pull-up the DTR pin. So when The PC's DTR is on, the HD Radio's DTR is pulled low by the transistor (Are you sure you're using a NPN transistor, and not a PNP?), and when the PC's DTR goes low, the HD Radio turns on. Then click can possibly mean that you have that logic reversed, which would also explain the HD Radio not working since the application would attempt to turn the radio on, and accidently turn it off. If you remove the transistor and just wire pin2 of the DIN to 5V through the 1k resistor, it should be always on for testing.
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

Page 2 of 6 FirstFirst 123456 LastLast

Similar Threads

  1. Directed DMHD-1000 HD Radio Serial Connection Pinout!
    By srlake in forum General Hardware Discussion
    Replies: 6
    Last Post: 03-24-2012, 11:25 PM
  2. Directed HD Radio Causing static in factory radio
    By bchiang in forum Input Devices
    Replies: 2
    Last Post: 09-28-2011, 06:10 PM
  3. FS: Directed HD Radio + MJS Serial Cable $30
    By billmee in forum Classifieds
    Replies: 1
    Last Post: 06-08-2011, 05:09 AM
  4. Replies: 14
    Last Post: 10-11-2010, 02:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •