Results 1 to 3 of 3

Thread: Selfmade LPT Relay board

  1. #1
    zvi
    zvi is offline
    Constant Bitrate zvi's Avatar
    Join Date
    Jan 2004
    Location
    Tbilisi, Georgia
    Posts
    156

    Selfmade LPT Relay board

    I have soldered 8 Way LPT RElay Board by myself from here:
    http://www.southwest.com.au/~jfuller/8way.html

    it was very easey to do the board, but it did not worked. As I've read, LPT data pins give 5v when going active, but my M10K gives 3v, may that is the reason?
    '93 Opel Vectra A with Custom Dash with 7" lilliput
    VoomPC/M1-ATX/M10K/256 RAM/20GB 2,5' HDD/Gemtek USB Radio/WinLite/RoadRunner
    http://zvi.home.ge/pics/?dir=vextra

  2. #2
    Constant Bitrate Vineet Singh's Avatar
    Join Date
    Jul 2003
    Location
    Naperville IL
    Posts
    166
    On a different "kit", the datasheet has this snippet, maybe it's useful to you? The circuit looks similar, but yours uses darlington array's (in the IC) instead of the transistors on the CK1601.

    Anyway,

    "Note that this analysis assumes 5V is available from the
    parallel port pin. In more modern computers this may not
    be so. If the LED turns on but the relay does not then you
    will know that the transistor is not saturating. Reduce the
    value of R1 (and all the similar resistors) to 2K7 from 3K3
    will probably fix this. Measure the voltage on the collector.
    When the relay is on then the voltage should be around
    0.1V. If it is 3V - 4V then the transistor is not fully on."

    Quoted from http://electronickits.com/kit/complete/elec/ck1601.pdf

    91 Stealth RT/TT
    CarPuter: Inspiron 5150 P4 3.0ghz; Built-in WiFi; Deluo GPS; Radio Shark; OBD1; Nostromo Speedpad
    Audio: Audigy 2 NX; Clarion 500.5 amp; 100.2 center channel amp; Kicker Solo-baric L7 10" Sub
    Display: Lilliput 7" Touchscreen

  3. #3
    zvi
    zvi is offline
    Constant Bitrate zvi's Avatar
    Join Date
    Jan 2004
    Location
    Tbilisi, Georgia
    Posts
    156
    Thanks Singh, probably this is the reason, that LPT output is less than 5v, as I cant give my IC 5v, I have to rebult the board then, on transistors, and tune voltage on base
    '93 Opel Vectra A with Custom Dash with 7" lilliput
    VoomPC/M1-ATX/M10K/256 RAM/20GB 2,5' HDD/Gemtek USB Radio/WinLite/RoadRunner
    http://zvi.home.ge/pics/?dir=vextra

Similar Threads

  1. relay, inverter, fuse problems
    By cheesyhoward in forum Power Supplies
    Replies: 5
    Last Post: 06-02-2005, 10:04 AM
  2. My LPT Relay Control Software
    By wizardPC in forum Software & Software Development
    Replies: 23
    Last Post: 02-13-2005, 01:10 PM
  3. relay, inverter, fuse problems
    By cheesyhoward in forum General Hardware Discussion
    Replies: 6
    Last Post: 06-22-2004, 04:05 PM
  4. Relay control board software for XP enjoy :)
    By Mastero in forum Software & Software Development
    Replies: 10
    Last Post: 09-26-2003, 06:45 AM
  5. Will someone help me program my relay control module
    By cproaudio in forum Software & Software Development
    Replies: 6
    Last Post: 09-04-2002, 05:50 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •