Page 5 of 11 FirstFirst 1234567891011 LastLast
Results 41 to 50 of 107

Thread: BMW I-Bus How to connect..

  1. #41
    Newbie
    Join Date
    Dec 2003
    Location
    France
    Posts
    5
    1. Every 10 seconds or so this message pops up in Ibus Comm:

    Process Msg RAD_CDPOLL (Radio Polls CD)
    Reply was CD_POLLRESP (CD poll Resp)

    What does that mean? Is this normal IBus traffic?
    Yes. That means the radio checks if the CD player is here. It is a programmed behaviour in IbusComm.ini.

    2(....)Since the program doesn't respond to pushing these buttons does that mean I need to find out the codes for these buttons somewhere else and manually add them to the .ini file?
    Yes. look at the demo ibuscom.ini provided with ibuscomm

    3. Some of the commands work (using "simulate message" makes this testing easy). But many do not. Example: One of the pre-defined mapping sends a "keyboardmap" command of ALT-F4 - which as expected quits Winamp when I push "simulate message". BUT if I manually change one of the "keyboardmap" commands to, say ="f" it doesn't work (I have a GLOBAL HOTKEY setup so that pressing 'f' on the keyboard skips forward).
    Should work...

  2. #42
    Newbie Lukasz's Avatar
    Join Date
    Oct 2004
    Location
    NJ
    Posts
    7
    Quote Originally Posted by m3evolution@hot
    How do you map those buttons to Frodoplayer? or any programs? I have my ibus connected and shows that its working button cant get the volume to change or mute

    can you post your .ini file? or give example how to map to different apps.

    Thank you
    I just did it. Click here

  3. #43
    Newbie
    Join Date
    Jun 2005
    Posts
    14
    Has anybody tried CarX in their bimmer? http://www.creative-nightshifts.de/carx.htm

  4. #44
    Variable Bitrate
    Join Date
    Jun 2004
    Location
    AZ
    Posts
    247
    I have the IBUs hooked up to my Cd changer harness IBUS wire and downloaded al software. I dont know what COM port my serial connection is assigned to. How do I determine what com port the IBUs is using on my M10000 board? I tried com 1 and 2 but not getting it to work. I also tried teh analyser and I could not get the buttons to pick up.

  5. #45
    Variable Bitrate
    Join Date
    Jun 2004
    Location
    AZ
    Posts
    247
    found the ibus on com 1. the buttons work! however, when I press up or down for volume.....the volume meter keeps going in that direction. I am using the frodoplayer ini file that was posted just above. Thoughts?

  6. #46
    Variable Bitrate Hark's Avatar
    Join Date
    Feb 2005
    Location
    Atlanta, GA USA
    Posts
    440
    (cough) Volume problem (cough)

  7. #47
    Variable Bitrate
    Join Date
    Jun 2004
    Location
    AZ
    Posts
    247
    Hark, thanks for going easy on me Going to try this today.

    I also noticed last night that when the ibus com program was running, frodoplayer was acting real slow and my music videos started to lag. It seemed like it was pulling CPU power like crazy. It was like it was working extra hard or trying to interpret lots of commands, though I am not sure how to trouble shoot. My CPU froze up a few times. I stopped running IBUC com and everything works fine. I rand teh IBUS Analyser just for giggles. I set it to COM1 and man, there were a lot of signals comming through the analyser....then it freezes. Does thi mean anything? I really want to get this to work as I am sooooo close.

  8. #48
    Variable Bitrate Hark's Avatar
    Join Date
    Feb 2005
    Location
    Atlanta, GA USA
    Posts
    440
    Haven't seen this happen - there is a lot of messages that go through the bus, but it shouldn't drag you down. Let me know if you don't make any headway and I'll upload my ini file as well (not sure if it's different or not, but I know it's working for me).

  9. #49
    Variable Bitrate Hark's Avatar
    Join Date
    Feb 2005
    Location
    Atlanta, GA USA
    Posts
    440
    Here's another question - how can I make the SW volume buttons be the volume control for everything, regardless of the app I'm in? When my GPS screen (Copilot 8) is up, I'd still like the ability to control the volume - but it doesn't appear to let me until the focus is changed back to Frodo.

  10. #50
    Variable Bitrate Hark's Avatar
    Join Date
    Feb 2005
    Location
    Atlanta, GA USA
    Posts
    440
    bump - there must be a way to do this, since some keyboards have volume keys that affect the volume regardless of which app has focus. Anyone?

Similar Threads

  1. Solved: USB bus stays powered after shutdown
    By S4Per in forum Power Supplies
    Replies: 19
    Last Post: 05-28-2007, 09:09 PM
  2. 03 BMW 330i Dinan S3 Project
    By fattytl in forum Show off your project
    Replies: 29
    Last Post: 09-27-2005, 10:24 PM
  3. Replies: 1
    Last Post: 07-28-2004, 10:26 AM
  4. BMW pre-installed system - TFT ?
    By tsingsu in forum LCD/Display
    Replies: 11
    Last Post: 08-05-2002, 02:16 AM
  5. BMW TFT Sharp LQ065T9BR52 - how to connect?
    By tsingsu in forum LCD/Display
    Replies: 2
    Last Post: 05-31-2002, 09:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •